[Stable Update] 2021-04-09 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

Just updated my laptop w/KDE. As always no problem whatsoever. Running kernel 5.12. Nothing has changed, well, as of now only one icon!
Kudos and many great thanks. :+1: :+1: :beers: :wine_glass:

1 Like

sudo pacdiff
use this not cp


Can’t complete a successful update via terminal. Errors below. I’ve tried and failed updating answering y or n to both questions with the same result. Should I be deleting or removing a package? Thanks for any help.

:: Starting full system upgrade...
:: Replace python-dbus with extra/dbus-python? [Y/n] y
:: Replace python-dbus-common with extra/dbus-python? [Y/n] y
resolving dependencies...
looking for conflicting packages...

python-chardet-4.0.0-1  python-cryptography-3.4.7-1
           python-dbus-1.2.16-3 [removal]
           python-dbus-common-1.2.16-3 [removal]  python-gobject-3.40.0-1
           python-idna-3.1-1  python-importlib-metadata-3.7.3-1
           python-pep517-0.10.0-1  python-pillow-8.1.2-1
           python-pyxdg-0.27-1  python-reportlab-3.5.66-1
           python-setuptools-1:54.2.0-1  python-urllib3-1.26.4-1
 :: Proceed with installation? [Y/n] y

178/178) checking for file conflicts              [######################] 100%
error: failed to commit transaction (conflicting files)
python-chardet: /usr/lib/python3.9/site-packages/chardet/__pycache__/langrussianmodel.cpython-39.pyc exists in filesystem
python-chardet: /usr/lib/python3.9/site-packages/chardet/langrussianmodel.py exists in filesystem
python-chardet: /usr/lib/python3.9/site-packages/chardet/metadata/__init__.py exists in filesystem
python-chardet: /usr/lib/python3.9/site-packages/chardet/metadata/__pycache__/__init__.cpython-39.pyc exists in filesystem
python-chardet: /usr/lib/python3.9/site-packages/chardet/metadata/__pycache__/languages.cpython-39.pyc exists in filesystem
python-chardet: /usr/lib/python3.9/site-packages/chardet/metadata/languages.py exists in filesystem

Errors occurred, no packages were upgraded.

When pasting terminal output, highlight it then use the Preformatted text </> button.

Alternatively, add three backticks ` above and below the text:


Please edit your post accordingly.

Disable silent grub, systemd will most likely show you a stop job for what’s hanging.

Look for




and remove “quiet”. I think you have to update grub afterwards.

# update-grub
1 Like

Hello guys,
the new update went smoothly with my system (Xfce), thank you for the amazing work!! :blush: The only thing I noticed is that the context menu item to empty the recycle bin can no longer be clicked. The menu item remains grayed out even when a file has been moved to the recycle bin. See screenshot. This affects both the desktop PC and the notebook.

A post was split to a new topic: How do I use an older version of wine with PlayOnLinux?

Anyone here using KDE notice that KDialog is no longer being used for GTK applications, such as Chromium/Chrome, Firefox, Vivaldi, etc, when opening or saving a file?

It just started after applying these updates.

Can you check with Google Chrome, Chromium, Firefox, or another GTK-based browser if you try to Open or Save a file, does it still use KDE’s native KDialog, or does it use the GTK file dialog now?

“thrash” and “trash” are different words with different meanings - and they sound different. :wink:


i have the same problem, the font display is not the same in Firefox

My fonts in Firefox look the same as usual, but suddenly the font in JMeter (a Java GUI tool from Apache) is a monospace font after today’s update. All other software I’ve run (not Java software) looks the same as usual. What could possibly cause that? I want the previous non-monospace font in JMeter. JMeter itself did not update. I’m using JMeter from the AUR, which was last updated in January.


Top bar on gnome seem to have gotten thicker. How to set its size?

I’m not an expert, so I might be wrong, but as no-one answered this after 5 hours …

pacman says “exists in filesystem” because pacman did not put it there.
This often happens with python files because people install things with pip
and forget to add --user, so the files end up in system python.

Usually the solution is to simply delete all the files listed as “exists in filesystem”
then run the upgrade again.
But usually they are not essential system files, and chardet files might be.
Still, pacman will replace them, so it might be safe –
just don’t reboot between deleting them and finishing the upgrade.

No warranty implied. Backup first. Don’t blame me if it borks your system. :wink:

What you first tried is pacman, not pamac.
Your try with pamac worked because it can auto solve this kind of dependency problem :grin:

1 Like

Yes I meant to say pacman, made a little typo. Nice to know that there’s auto resolvers in pamac for dependencies. Thanks!

Too bad, it didn’t stand the night : today’s start show the issue again : Pulseeffects is silent on first start and has to be rest (I’ll mention it on above thread)

Indeed it works via Pamac GUI!

Does this solution work for you?


There was a new issue with the Trash icon in XFCE Thunar 4.16.6, where it doesn’t stay in sync with the contents of the Trash. Apparently the XFCE team has already fixed this for 4.16.7. The workaround is to open the Trash and manually delete its contents.

Many thanks to the Manjaro team!