[Stable Update] 2021-02-19 - Kernels, AMDVLK, Palemoon, Firefox-dev, Firefox, Haskell, Python

Another silky smooth update. Thanks to all of the team for such incredible effort. You rock!!!

1 Like

Smooth update on gnome, thanks Manjaro team :heart:

@Yochanan yep, xfce4-notifyd is installed

2x KDE plasma. No issues

A post was merged into an existing topic: Nemo broken after latest update on testing branch

I upgraded my KDE x64 desktop.

It still boots and all, but upon I want to play a DVD, VLC crashes when I pick anything else than “Open File…” and “Save Playlist” within the Media menu:

LANG=C vlc
VLC media player 3.0.12 Vetinari (revision 3.0.12-1-0-gd147bb5e7e)
[000055a81b8d8640] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
[000055a81b96ca00] main playlist: playlist is empty
ASSERT failure in QList::operator[]: “index out of range”, file /usr/include/qt/QtCore/qlist.h, line 579
Afgebroken (geheugendump gemaakt)

However, I tried out the unofficial AppImage of VLC and the breaking options in the Media menu did not crash.

So I contined tinkering around with other applications, and HandBrake within the community repo does not even draw its screen. A "screenshot’ of a application (or desktop) behind Handbreak fills Handbreak’s window.

I don’t know If both issues existed before the 2021-02-19 update, but it’s annoying.

After this update, nautilus does not work. When attempting to open Nautilus, the process hangs indefinitely, then times out. When running from the terminal: Failed to register: Time-out was reached. This is a rather problematic bug as nautilus is rather important, obviously. Any help here would be great. I’ll post what logs I can.

Edit: So, I exited my Megasync client and all the nautilus boxes popped up. Seems like the nautilus application is waiting for something from the Megasync client it never gets. So, now, I cannot run nautilus and the Megasync client at the same time.

The update went smooth on all my GNOME machines.

Keep up the good work!

Everything working fine on Manjaro KDE with AMD Ryzen, great job! :slightly_smiling_face:

1 Like

4 posts were split to a new topic: How can I revert changes to the firefox startpage

  • File a bug with VLC upstream
  • try creating an additional user (E.G. RoestVrijStaal2) and see if it happens there too.

Any concern about this news related to the new format of initramfs images (from gzip to zstd) ?

We’ve been posting about that for a very long time and stopped posting about it in the meantime. Last time we posted was in 2020-10-10:

More specifically:

1 Like

with this update, this bug is still present:

can someone tell me if there is a package that I can downgrade for fix the issue? It’s annoying

This is about the default mkinitcpio uses when building and that is a different kind of heads up if I understand it correctly, eg if you don’t actively do anything you might end up in a situation where the booting of a kernel prior then 5.9 will result in a non bootable system. So when you have kernel 5.9 or earlier running you have to edit configuration option in mkinitcpio.conf to prevent a broken boot.


Update on 10 Systems without Problems.


Hi @salome,

I use KDE, but I’ve just installed lxtask to test this and mine works flawlessly.

  • Are you sure you default browser is set correctly?
  • Or it might be a MIME type association.

Unfortunately, I don’t know where else to check or/and test.

Hope this helps.


Accoring to this page:

Alternate way is to add the following line export BROWSER=/usr/bin/firefox to your ~/.bashrc

So, assuming you use ZSH, the command to make that permanent would be:

$ echo "export BROWSER=<directory_to_browser_executable>" >> ~/.zshrc

If you use bash the command would be:

$ echo "export BROWSER=<directory_to_browser_executable>" >> ~/.bashrc

For example, in my case the directory is


So the command would be

$ echo "export BROWSER=/usr/bin/firefox" >> ~/.zshrc

That should, in theory at least, set it.

Hope this helps!

Thanks for that info. Switched to lz4 cause I’m planning to stay on 5.4 LTS for a long time. My old iMac 13,2 (27" late 2012) cannot change display brightness with newer kernels…

Everything good on two computers running KDE and one with XFCE.

Since we support older LTS kernels this change won’t be made on our end.

No, it’s about the Arch default. We have our own kernels and mkinitcpio package.