Nemo broken after latest update on testing branch

I’ve posted in the testing thread but really want to get to the bottom of this. After updating yesterday nemo is completely unresponsive unless run as root, this also breaks the desktop. Running nemo from terminal gives the following error

Current gtk theme is not known to have nemo support (CBlack) - checking…

and then nemo just hangs until I f/c it. The same error happens on every theme.

The only gtk package that got updated gtk-update-icon-cache , downgrading gtk-update-icon-cache still breaks nemo but with a different error

(nemo:11990): dbind-WARNING **: 14:07:27.689: Couldn’t register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Could not register nemo as a remote: Timeout was reached

Any idea’s or pointers are greatly appreciated as the system is unusable atm

First step is changing the theme - then check again.

Then remove/rename the nemo settings folder in your home/.config

I’ve changed the theme several times same issue so it’s not theme related, happens every theme. Only nemo folder in .cong has desktop-metadata in it and deleting that doesn’t fix anything unfortunately

Edit, getting this error now

Could not register nemo as a remote: Timeout was reached

Looks like the issue is megasync. I removed nemo-megasync plugin and megasync, then everything started working fine now. I noticed the issue only started as soon as megasync launched (there’s a delay in start up). Hopefully it helps someone else

1 Like

I have the same nemo problem after the latest update.
After several hours it appears that glib2 update is the source of problem (from 2.66.6-1 to 2.66.6-2).
Timeshift helped a lot during update routine to identify the problematic update.
For just now, I ignore the glib2 update and everything works. When I try to update glib2 nemo brakes and dektop becomes unresponsive.
I don’t have megasync. So I don’t have the option to remove it. :slight_smile:
Any suggestions will be very welcomed.

Not sure if it helps but it was the nemo-megasync plugin rather than megasync itself that broke nemo for me.

Thanks for your prompt reply.
Neither megasync nor nemo-megasync is installed on my system.
The problem regenerates when I update glib2.
I don’t know how to fix the issue.
I tried changing theme, nemo config files, several restart/shutdown-refresh boot options but couldn’t bypass the bug…

I have glib 2.66.6-2 so it’s not glib. Looking at the dependencies for glib2 I see desktop-file-utils amongst others so it may well have been glib2 that broke nemo-megasync plugin for me. Do you have any nemo plugins installed


I see glib2-git is at 2.67.2 have you tried that to see if it fixes anything

Also maybe post an issue tracker here

Thanks a lot.
Your analytic thinking and hints lead to narrow the problem for me.
The problem is nemo plugin: nemo-dropbox.
I will try glib2-git 2.67.2 also.
But for now I need to choose between two options:
A. Nemo-dropbox plugin enabled with glib2 2.66.6-1
B. Nemo-dropbox plugin disabled with glib2 2.66.6-2
I will inform you about glib2-git 2.67.2 trial…
Again thanks a lot for your support and time.

1 Like

nemo-dopbox is at the same as nemo-megasync. All the other nemo plugins are at 4.8.0-4, I’m guessing nemo-dopbox and nemo-megasync both need updating to 4.8.0-4.

1 Like

Couldn’t solve the problem with glib2-static 2.66.6-1.
Couldn’t solve the problem with glib2-git 2.67.3-9.
As you have stated, I think we need to wait for nemo plugin update to4.8.0-4.
All the best wishes for now.

Post the issue here

hopefully the maintainer will push an update

1 Like

Running Cinnamon and kernel 5.10

Issue: Dropbox works and seems to updates files changes but Nemo-dropbox 4.8.0-1 AUR does not show update tick mark in the corner on files anymore. Rebuilt Dropbox 116.4.368 AUR and nemo-dropbox but now luck. Found this in supoport/cinnamon in testing:

Edit: Was moved here, running stable and update 2021-02-19 created isse for me.

OK I fired up an arch based distro in my VM to test. Stock arch is at glib2.66.7.1, I installed nemo-dopbox and nemo-megasync plugins which are both the same as manjaro (aur) and zero issues. So the problem is with manjaro not the plugins, hopefully once glib2 gets updated to 2.66.7-1 the issue will get fixed if not the solution is out of my skillset

@nightmare-2021 sorry to tag you but have you any ideas what’s causing the plugins to break nemo ? It seems to be manjaro specific


Might be related, I have my gdrive accounts attached to nemo and they have stopped working now. They are listed under network but i get “invalid credentials” when I try and open them with nemo. If I try and remove my google/drive accounts from gnome accounts manager i get this error “GDBus.Error:org.freedesktop.Goa.Error.Failed: Failed to delete credentials from the keyring”


Running “sudo nemo” gives “Nemo can not handle network locations”


Ok so good news and bad news. Updating glib2 to glib2.66.7-1(which is in unstable atm) fixes dropbox and megasync plugins crashing nemo. So either update to 2.66.7-1 or wait for the update to reach stable.

Unfortunately it doesn’t fix the issues with gdrive being mounted in nemo, still get the same authentication error “invalid credentials”

1 Like

Thank you for your news and efforts! I will probably wait, my dropbox seems to still work fine but without graphical feedback.

Edit: Quick follow-up… Did not realize until now that all my desktop icons was unresponsive/locked and a process called nemo-desktop was very high on cpu, however nemo worked fine when started from panel/menu.
Solved it by going in to nemo plugins and disabling nemo-dropbox and restarted. Dropbox still works fine.

1 Like

Today’s stable update fixed my Nemo-dropbox plugin, works fine again :smiley:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.