[Stable Update] 2021-02-09 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice

I still have problem from here - Latest Stable manjaro xfce boots to the black screen
but developers team ignore this :cold_sweat:

You have posted you rebooted into a black screen but no other information. You’ll need to give full system information and system logs as well for the developers to help you trouble shoot

What data other than inxi and the X server logs are needed to solve the problem?
I will provide whatever the developers need.

I’d say inxi-fazzy and whatever logs you can provide

Thank you! Provided complete information in the thread -

1 Like

You can grab one of our Nightlies if you want …

1 Like

My locale settings disappeared and my gnome terminal did not open. I had to regenerate my locales to fix it.

Plasma compositor is still down with the 'rona it seems. It occasionally gives up and takes a breather (e. g. after resuming from hibernate). Even though I am using OSS drivers and intel gpu only.

And in case you are wondering, the “Enable compositor on startup” is definitely checked.

I’m feeling very frustrated by fact, that PipeWire, which is not fully functional (at least on KDE) is deployed to stable branch. It’s not only my experience, but also it’s pretty frequent on internet’s forums. So, I’m experiencing problems with sound freezing, also freezing programs concerned to multimedia (even k3b freezes), glitches in DE, pipewire is using about 20 % cpu for nothing etc. I’ve managed to install back Pulseaudio and stop to using PipeWire (what solved my problems), but is it possible uninstall PipeWire at all? Also why is these changes are made, when PipeWire is not stable? Thx.

Welcome to the forum. You should be more specific and provide better information if you expect people to help you.
Kind regards

https://forum.manjaro.org/t/how-to-provide-good-information/

Edit: Link added.

As I wrote, pipewire and pulseaudio freezes. Also pipewire using about 20 % cpu for no reason. I’ve tried to unistall it, but it cant be done.

What kind of issues with gnome and nvidia? I’m running gnome and nvidia and have had yet another flawless update. The only “issue” but not really an issue as it was fully documented and discussed was when several of the legacy nvidia drivers were dropped, even though I was on the latest version prior to the update (I believe 2 updates ago) but all that had to happen was install the latest nvidia drivers again with their new package name after the update. I was fortunate that the free drivers worked with my nvidia card so aside from looking funny and performance being slow while I installed the new nvidia driver everything worked fine. I do know that some of the nvidia cards don’t work with the free drivers they were forced back onto so they had a bit more problem since they didn’t get their desktop environment back after the update but once again it was fully documented as to what you had to do to get back up and running.

As for running Timeshift before any update that is just a good standard practice everyone should be doing regardless of the DE environment or they video card/processor they use.

1 Like

Same problem here. Looks out of play with my green adwaita theme.

I had the same problem but with Italian language. Thank you for the fix!

On Xfce network manager crashes with SIGSEGV when trying to edit a connection with default VPN or when trying to create a new connection with VPN.

Steps:
$ nm-connection-editor
Click + to add new ethernet connection
On general tab check “automatically connect to VPN”

“nm-connection-editor” terminated by signal SIGSEGV (Address boundary error)

Same error when opening existing connection with VPN set to auto connect.

It is possible to uninstall Pipewire, but you may also need to remove Pulseeffects (that requires Pipewire) and replace it with pulseffects-legacy to work with PulseAudio

If you are still having problems with reverting Pipewire to PulseAudio start a new topic and post responses to

systemctl --user -l --no-pager status pipewire*

systemctl --user -l --no-pager status pulseaudio*

Updated with TTY on desktop computer Intel i7 LTS kernel KDE Plasma, all apps n system OK , again great OS , Thank You

for me, pipewire didn’t installed with pulseeffects update automatically but pulseeffect 5.0 crashed, as expected. I could easily uninstall it and installed legacy version. Then, I wanted to try pipewire. I installed manjaro-pipewire, also uninstalled pulseaudio-related packages except plasma-pa, libcanbera-pulse and pavucontrol. After a restart pipewire and pulseeffects work flawlessly. Pipewire needs fewer ram than pulseaudio for me.
also I needed to reset the pulseeffects configuration.

Hi, I’ve repaired my PC with Timeshift and then I’ve upgraded PC again, but with cautious for PipeWire. Now it’s OK. It seems that PipeWire is mandatory part of the system, but when is not used for sound, it not generates problems.

Manjaro Gnome.
Fine Update, no issues at all :ok_hand:

1 Like