[Stable Update] 2021-02-09 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice

I was in your situation until last month when I upgraded to 5.10: seems to be fine now (5.10 is an LTS candidate)

:+1:

2 Likes

5.10.7 didn’t support MDADM RAID, my RAID was constantly getting out of sync. This should have been fixed with 5.10.8, but I haven’t tried it yet. Thank you for mentioning it though!

1 Like

I just realised that sudo would just not accept my password.

I just logged in as root and

pacman -S pambase
passwd user

(user being my username) and re-entered my old password.
Problem fixed!

I get this after an update:

inxi: local (3.3.01.1-1) is newer than community (3.3.00.1-1)

Any idea why?

I got an update for inxi after a reboot so now its OK

And after the update I cant open the terminal. Nothing happens when I click on the icon
Same with Minecraft. Other programs starts ok
Running on Gnome

Solution:
1- uncomment en_US.UTF-8 from /etc/locale.gen
2- generate locale by this command locale-gen
3- add LANG=en_US.UTF-8 and LC_COLLATE=C to /etc/locale.conf
and that’s it. Everything worked.

1 Like

After the update the audio returned to work correctly but I noticed that every time I start the PC I have to select the correct audio output by pavucontrol, is there any way to correct this?

1 Like

My problem is I can install all the pipewire components except pipewire-pulse, because of the dependencies with pulseaudio

Timing of the stable snap, perhaps. The situation has be rectified.

Did I miss it? Was there a solution for the missing Power Manager system tray icon? Mine is still missing after the update.

looking for conflicting packages...
warning: removing 'opencolorio' from target list because it conflicts with 'opencolorio1'
:: opencolorio1 and opencolorio are in conflict. Remove opencolorio? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: opencolorio1 and opencolorio are in conflict

is there then update or not? can’t see anything besides opencolorio1 which would be actually downgrade…

The update went smoothly on my old ThinkPad, but my desktop ran into locale troubles. Gnome Terminal failed to start, so I installed another one through Pamac. Following the “[root tip] Troubleshooting locale errors” instructions, I resolved the error and now Gnome Terminal opens. Initially I checked the locale in Manajro Settings Manager and noticed there were none listed. Can’t say it was necessarily the update that caused the problem, but others had similar issues.

Hope the feedback helps, and thanks for making Manjaro so great!

Try removing opencolorio1 and if that would want to remove something that you need, open a new topic in #support , link back to your topic here, provide the full output together with An inxi --admin --verbosity=7 --filter --no-host --width and mention @Fabby

1 Like

That’s the thing, I don’t have it installed even:

[deemon@Zen ~]$ sudo pacman -R opencolorio1
[sudo] password for deemon: 
error: target not found: opencolorio1
[deemon@Zen ~]$ sudo pacman -R opencolorio
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing opencolorio breaks dependency 'opencolorio' required by blender
:: removing opencolorio breaks dependency 'opencolorio' required by openimageio

or you mean let me replace it and then try to remove?

it seems to be new dependency for blender

4 posts were split to a new topic: Switching from PulseAudio to PipeWire as a result of the PulseEffects update

Great update! Got rid of:
veebr 07 21:47:22 Zen kernel: Error: Driver 'pcspkr' is already registered, aborting...
from journald :face_with_hand_over_mouth:

also system startup fsck whining about some write right not being there ascii-box-thing got removed (after pacdiff (grub) + grub-update) :grin:

Great update on Manjaro XFCE edition.

No issues so far except the few minor things already reported by other people:

  • some favorites are gone.
  • power icon missing.
  • some Papirus icons looks incorrect.

I have been lazy updating so this time it was around 680 packages (2GB), which includes the big updates from December, January, and February.

Celebrating 2 years with Manjaro this month and never had any major issues.
A big shoutout to the whole team!.

1 Like

Can you elaborate? Updated also xfce but all my xfce bugs and irritations are still present. (Luckily no new problems either… great in that regard … hehe)

Also welcome to forums! :slight_smile:

1 Like

ah sorry for not being precise (I have edited my post). I meant, that I updated my Manjaro XFCE installation :slight_smile:

1 Like

2 posts were split to a new topic: Trouble booting after stable update

On two machines (XFCE, Kernel 5.10), no problems, no issues, nothing. Thanks to Manjaro team.

Initial update went fine, however shortly after that I got upgraded to Kernel 5.10.15-1 (This is the current testing kernel, so still unsure what happened here) which has not done much good for my system.

I’m back to nvidia driver constantly crashing, my notifications have moved half off the screen and some widgets are not working. This is KDE btw. Going to try downgrading to 5.4 I think, as this is not great.