Trouble booting after stable update

This update broke my installation.
I have a Dell XPS 13 9380 which comes with Ubuntu, but I installed Manjaro i3 to dual boot.
Since the last update, when I select Manjaro in Grub, the Dell logo shows again and then in enters in some loop where the screen will go black and then the logo will come back.
I can only stop it by pressing power and at that point, I get some irrelevant messages for like half a second, it’s hard to see:

  • “snd_hda_intel… No response from coded…” I went and disabled the audio in the bios and that message disappeared, but it still didn’t boot.
  • “psmouse … Failed to disable mouse…” I think this had always been there.
    I tried with all the kernels I have installed: 5.4 and 4.18 (I think). I also tried both in fallback mode and got same thing.

Since I can’t even get to a terminal, I can’t diagnose the system. I have access to the Manjaro file system from the Ubuntu installation, but I don’t know what to do.
Thank you in advance!

Hi, one option you have is to chroot into the installation useing a live ISO and see if it updates correctly, grub in installed correctly etc. See this link in the wiki to get started. I would use the automatic chroot, manjaro-chroot -a check if I was up to date with pacman and upgrade-grub, iff that does not fix it make a new post with the issue.

Thank you for the reply. I did not know about manjaro-chroot. It was very convenient to have access to my installation.
I tried to update with pacman and upgrade-grub and it didn’t work.
After that, I tried downgrading everything I had recently upgraded, I rebooted and it worked! I updated again to the latest version, rebooted again and it is working!
So I guess there was an issue when I first updated.
Thanks again!

1 Like

Great to hear you are up and running again :smiley:

1 Like