[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

they just updated pulseaudio in this update so you may want to do a quick timeshift backup, do the upgrade and you may find you no longer need the pulseaudio from the aur. If the new pulseaudio updates don’t fix your problems it only takes a minute to roll back with timeshift and then hold off on the update until it gets resolved in the future.

1 Like

video-nvidia should work fine with your card (those are going to be the latest nvidia proprietary drivers). Otherwise if you for whatever reason you want to lose all the performance/advantages of the nvidia drivers the “video-linux” option is the nouveau drivers.

For me, I have an Nvidia GeForce GTX 1050 and I used 440xx driver.
This driver doesn’t work after the last stable update of Manjaro.
So I have used the 390xx driver temporarily to strat the system.
After, I have installed the last video-nvidia driver with the Manjaro mhwd UI.
( it’s the 460xx driver).
I had to remove the 390xx driver first.
Now with the 460xx all the system works perfectly.
Hope to help you.

1 Like

Thanks @Roland1,
Yes, I got the 460 drivers. Everything is fine now.
Glad you got yours working.

1 Like

I do not know if this belongs to here, but the nvidia-340xx-dkms AUR build still does not work, even in this stable update. The AUR package requires 5.10 kernel. The other problem is that it does not compile automatically. Instead I have compiled and installed it manually, so that I can use my computer with LTS 5.4 kernel. 5.10. does not support nvidiabl - so I need to use 5.4.

==> Starting build()...
NVIDIA: calling KBUILD...
make[1]: Entering directory '/usr/include/linux'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/usr/include/linux'
nvidia.ko failed to build!
make: *** [Makefile:202: nvidia.ko] Error 1
==> ERROR: A failure occurred in build().

Thanks for this tip.

Thanks for your guidance. Vanilla pulseaudio now installed and everything is working. Had to use the typically ill-advised pacman -Rdd command to remove pulseaudio-git, which was nervewracking. But since I installed the pulseaudio package from the stable update at the same time, no dependencies appear to be broken. Everything now working as expected with the repo package, just as you suggested. And I’m happy to now be able to use an official package for such an essential aspect of the system.

3 posts were split to a new topic: Megasync: error while loading shared libraries

On my system I had to remove “vulkan-intel” since Path of Exile was trying to use the integrated GPU instead of my Radeon RX570 while on Vulkan render.

@philm Recommended or not, kernel 5.10.x should be marked as LTS

It will be once 5.11 is released. See https://www.kernel.org/

1 Like

The XFCE power manager now uses battery icons that display charge in 10% increments (like in gnome). So you need an icon theme that has the status icons like “battery-level-10-symbolic” and so on.

Like in the papirus icon theme:

A post was split to a new topic: What is the correct way to install package “manjaro-pipewire”?

XFCE edition, 5.10:

Overall: GOOD, working

Minor problems:

  1. Some icons for the updated applications got deleted from my Favourites in the start menu
  2. qt4 seems to be bugged and can’t update - probably a never ending cycle.

@Jazz But I read somewhere here that qt4 is no longer needed? Like the whole package? So qt4 4.8 can be safely removed from the system?

And what about the size of its icon? Also if I change the icon theme, its icon remain the same, bigger than before:


This didn’t work, at least for me: the size of the icon’s battery is still big

Reported on upstream:

1 Like

Hi, after update (KDE Plasma env.) I’m missing “Documents” folder in my /home folder. Is that possible???

$ pactree -rl qt4
$ pactree -rl qt5-base
[ heaps of packages ]

According to this, you may be right. I don’t think I need any of those qt4 packages from above.

I have a general freeze, even with light usage. I had only a couple of tabs open and the computer froze twice in an hour, which was unthinkable before the update.
It freezes the screen badly, not even the pointer moves, and after sometime the sound stops working too.
It’s so bad I am not even able to switch to another tty!
I can post inxi on request, but since some friends had the same issue, we believe it’s something to do with the update.
It’s an AMD GPU.
Related issues:

I’m downgrading.

the update seems to have gone well for the most part.
i rebooted and it was fine,then i rebooted again and it was really slow to shutdown,so i looked in KSystemlog and saw a long error related to Baloo;same as what these persons:

i think i’ll just disable Baloo.
Baloo status is inactive and file indexer isn’t running,so idk,