[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

Last update working perfectly with kernel 5.4 and 5.10 (with nvidia 340 driver, installed using the terminal as explained in the forum and not through AUR). Until now I have not had any freeze as I used to have in the past

I like the elementary Xfce dark icons and would like to keep them. I can’t imagine that this shouldn’t be possible anymore. It would be nice if someone could help me with this issue.

Finally I voted the poll: No issue, everything went smoothly :slightly_smiling_face:

The first thing that I’ve done after the updates has been to install libxfce4ui-nocsd (I had already installed Gtk3-classic from AUR - now again available in the official repo); I also had to set DialogsUseHeader to false in
Settings Editor > xsettings > Gtk, which is easily doable by executing xfconf-query -c xsettings -p /Gtk/DialogsUseHeader -s false in a Terminal window.

I didn’t faced issues with lost settings in Whisker Menu; I didn’t lost the battery icon(s) - my icon theme has the “level” icons for battery (battery-level-*-symbolic.svg).

Some minor annoyance was the fact that some other icons, like eg the “Show Desktop” have changed the name scheme: previously was named show-desktop.svg and was available in the icon theme folder; now is take from /usr/share/hicolor/32x32/apps/ and is named org.xfce.panel.showdesktop.svg; so I copied the previous icon from icon theme folder, as ~/.icons/hicolor/32x32/apps/org.xfce.panel.showdesktop.svg and is like before :slightly_smiling_face:
And as I’ve said above, the battery icon in the panel is big/huge.

Obviously I also run PACDIFF and the only pacnew was the one of dnscrypt-proxy, which for me has only introduced new phrases in the config file.

Xfce 4.16 seems to acting better than before: is blatantly faster/smooth; the panels are improved (before, when set to auto-hide, they had the tendency to not hide/unhide properly).


Now, the panels, when set to autohide, they have a fade out animation, which, by default, imho, is too slow.
Is possible speed it up by adding the following code to ~/.config/gtk-3.0/gtk.css:

.xfce4-panel {
  -XfcePanelWindow-popup-delay: 100;
  -XfcePanelWindow-popdown-delay: 10;

Or by further lowering these values.

(personally I prefer -XfcePanelWindow-popup-delay: 5 and -XfcePanelWindow-popdown-delay: 2;)

KDE with USB Tethering looses connection and can crash TaskBar

USB Tethering with an Android 6.1 smart phone, looses connection after a few minutes.
First it connects successfully as “wired connection 2” then - from what I can see from
the network icon in the TastBar - it turns on “Mobile Network” and looses connection.
Clicking on the network “Wired connection 2” CRASHES the TaskBar,
which will recover after a few minutes.

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.4.89-1-MANJARO
OS Type: 64-bit
Processors: 2 × Intel® Core™2 CPU T5500 @ 1.66GHz
Memory: 1,9 GiB of RAM
Graphics Processor: Mesa DRI Intel® 945GM

I’m having the same issue on my laptop. Pamac takes 60 seconds before it launches. It launched instantly before the update
Installation date of Manjaro was 04/10/2020.
Kernel: 5.4.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
Desktop: KDE Plasma 5.20.5 Distro: Manjaro Linux
Device-1: Intel 2nd Generation Core Processor Family Integrated
Hope this gets fixed soon!

Same here. Here is a screenshot of what it looks like. The first Konsole icon is a Widget added to the panel, and the the other icons are running programs. The size of the Widget icon size is what the running program icons looked like before. Also, like you said I tried changing the Icon size in the Task Manager Settings but it does nothing.

All right, I’ve increased the panel width to be a bit bigger and the task manager icons have taken a bigger size. It bothers me that the Icon size setting does not work tough.

1 Like

Are you looking in the correct location?

ls -l $HOME/Documents

You mean ls -l $HOME/ ?

Yes, of course. Documents folder (in my case in Czech “Dokumenty” and files in it just missing. I’ve even tried program “R-Linux” to recovery them, if they are deleted, but folder of files is just gone and program didn’t find anything from that folder.

Have you a nvidia GPU ? If it’s the case, you have the bug of the driver from 450 to 460 (you can ssh in your freeze system and check journalctl -b 0 to confirm that).

1 Like

update went well then after few hours my laptop started to just freeze. i thought its something to do with extended screen so i disconnected it and still happened. no issues with suspend or sleep it just random.

screen extended over hdmi to vga cable to a old 19inch dell monitor. running a resolution of 1280x720_60
i5 10gen, 8gb ram, 512 nvme
Manjaro 20.2.1 Nibia
mesa intel uhd graphics (ICL GT1)

After the update, pamac warns me that there is an update for qt4 4.8.7-33 of AUR. What should I do?

If you know the filename of a document search for it. the folder might be moved or renamed, since nothing is recoverable? you do have a backup solution for your documents I hope.

qtwebkit-bin tries to build qt4 from source, do I need to keep qtwebkit-bin installed or can I remove it ?

Thank you! Incorporated into solution wiki for this update.

(I just upgraded to 5.10 and 460 and that seems to work too, added below your solution)

For the future, please read this


1 Like

Look for ‘-d’ in pacman man page. You can use -Rdd in extreme cases like these

See new edit to the wiki solutions of this update.

use pacman

Well, that was first thing that I’ve tried. There was some appimage apps and some backups. I use different folder for documents. But, it looks like, that whole folder with it content magically disappeared :(. Maybe it is not related with update, but seems like it. So I’m just trying it, if somebody has same problem. Seems not.

Real mystery over there…