[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Do you still have another kernel version installed?

Enter grub menu by press and hold ESC key.
In grub, go to advanced options (not sure how exactly it is called) and try the fallback image or another kernel version if installed.

If you get into your system again, reinstall the kernel:

sudo pacman -S linux510

If not, you will need to chroot into you install. Follow @stephane’s link for instructions.

1 Like

I assume this is for the btrfs filesystem? At the same time, the #DefaultFileSystemType in /etc/systemd/homed.conf changed from ext4 to btrfs.

1 Like

No, had this on XFS not on BTRFS
Testing XFS in VM

Same problem here on my daughters computer. She has a NVidia card.

Hi @Katharsisdrill,

Please see here. I believe it’s either the same or related.

I sincerely hope this helps.

1 Like

So after updating I ran the command:

sudo mhwd -a pci nonfree 0300

and when I try to play CS GO using Steam I get 9fps.

I’m using kernal 5.10.2-2 and nvidia-390xx

Thanks Taylor. I didn’t have a Timeshift backup but uninstalling the Nvidia drivers and mhwd allowed me to boot Manjaro up again. I have installed kernel 5.10 and the package linux510-nvidia however 455 driver is not listed for install in Manjaro Settings Manager.

The new nVidia package is now called video-nvidia
See also: My switch to the 5.10 kernel with update 2020-12-30


I don’t want have troubles, when I do a complete update.
On my other System with nVidia I can not use xbacklight anymore, and the Update made some strange changes which I don’t understand. I don’t understand how I can solve my nVidia Problems.

What means

Kann Abhängigkeiten nicht erfüllen:

  • das Entfernen von mhwd-db verletzt Abhängigkeit von ‘mhwd-db’ benötigt von mhwd,
  • wenn möglich, entferne mhwd und versuche es erneut

Also if I ignore all needed updates and want only update FF, this message appear.
What have FF to do with mhwd? confused

There are a lot packages with “mhwd” installed. Or does it mean, that I only have to uninstall the package mhwd-db 0.6.5-4? And otherwise the update ist not running fine?

On my actual bootet System there is no nVidia driver, so I guess there will be no problems when I update? Kernel 5.4.85-1

[me@me ~]$ mhwd -l
> 0000:01:00.0 (0300:10de:11bd) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-418xx            2020.10.04               false            PCI
    video-nvidia-390xx            2020.10.04               false            PCI
    video-nvidia-340xx            2020.10.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Thx TM

I’ve got installed nvidia-utils and linux510-nvidia and nothing else. Still I can’t manage to install any nvidia drivers with mhwd -a pci nonfree 0300 or listed in Manjaro Hardware Configuration.

It worked! I had to go in through a live-usb and chroot, but then I simply just ran:

sudo pacman -S nvidia-utils
sudo pacman -S linux510-nvidia

and rebooted.

I am eternally grateful!


Happy to hear you managed!!!

Thanks for the update.
Xfce with RX 5500 XT and amdgpu driver here.
After the new update I had a black screen freeze when I started my pc the next day. Switching kernel with the bootloader from 5.10 to 5.9 fixed it for me.
BUT I thought I follow the solution where you have to edit grub and put the amdgpu.dc=0 line in so I could use 5.10 again. I used the nano editor for it as discribed. I did “sudo update-grub” and rebooted.
But then I couldn’t get to the terminal or tty because of a freeze with graphical glitches before login screen.
I had to boot to the console to edit the grub file with nano again. For that I googled about how to boot to console/tty by editing the kernel parameters from the grub menu (I’m not allowed to include a link obviously) and followed the instructions from the first google suggestion. Then I did “sudo nano /etc/default/grub” and removed amdgpu.dc=0 again. That didn’t fixed it even for 5.9. Still freeze with all 3 available kernels in the grub menu. But strangely removing “quiet” and amdgpu.dc=0" fixed it all.

Finally for me the solution was booting from grub directly to the console/tty, then “sudo nano /etc/default/grub” then removing “quiet” and “amdgpu.dc=0” from the GRUB_CMDLINE_LINUX_DEFAULT= line and then “sudo update-grub”, reboot. Some weird log info…restart again.

Now it’s all good and working with kernel 5.10.
I hope this helps anyone with a similar problem because it drove me crazy

edit: thanks @Zesko "Not quite , that is quiet "

Not quite, that is quiet .

1 Like

I pushed out some new ISOs. Manjaro Nibia 20.2.1: KDE, XFCE and Gnome


I have DELL (Intel + nVidia Quadro NVS 135M). Installed the 340xx driver (dkms 5.4) according to the manual in the forum header. Everything works fine. Thanks philm. Great activity for the New Year. If not for this activity, I would have had to drink a lot of vodka))

Is anyone else seeing a huge spike in power usage? I have a ThinkPad X1E. My idle power draw was around 5W, now it’s 25W when CPU is idle. I upgraded to the latest Nvidia 455 drivers, but running on intel graphics through optimus-manager.

maybe this but i have no idea:

1 Like

Did anyone manage to solve the font problem? I create a symlink in /etc/fonts/conf.d/ and reinstall ttf-dejavu but doesn’t change anything.