[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

package grub-customizer is not compatible with this update:

:: grub and grub-customizer are in conflict. Remove grub-customizer? [y/N]

@LS650V, have a look into this thread, it explains, why.

Hi. I gave a second chance to manjaro. After clean installing OS I’m still struggling with the same problem. On first boot after installing whole OS i see in mhwd GUI that there is a 455 version of drivers are available to install. I am such a user that before using system I let the system update itself. That’s what I did, and unfortunately for me in mhwd GUI I lost all NVIDIA driver versions except 390 available to install. I have a GTX 650 Ti Super GPU and according to the NVIDIA website, for the latest released driver (455) my card is supported.

How to fix that to install latest NVIDIA driver 455 via mhwd?

inxi -Fazy
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=c79209d9-8416-47b1-a8a9-472b737df337 rw quiet apparmor=1 
  security=apparmor resume=UUID=d358d149-6ed5-41f5-b20d-7683346173ac 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: MSI model: Z270 PC MATE (MS-7A72) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.A0 date: 07/04/2018 
  Info: Dual Core model: Intel Pentium G4560 bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE 
  L2 cache: 3 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28009 
  Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GK106 [GeForce GTX 650 Ti] vendor: Micro-Star MSI 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:11c6 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2880x900 s-dpi: 96 s-size: 762x238mm (30.0x9.4") 
  s-diag: 798mm (31.4") 
  Monitor-1: DVI-I-1 res: 1440x900 hz: 60 dpi: 89 size: 410x257mm (16.1x10.1") 
  diag: 484mm (19.1") 
  Monitor-2: DVI-D-1 res: 1440x900 hz: 60 dpi: 90 size: 408x255mm (16.1x10.0") 
  diag: 481mm (18.9") 
  OpenGL: renderer: NVE6 v: 4.3 Mesa 20.3.1 direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GK106 HDMI Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0b 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
  v: kernel port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 698.65 GiB used: 9.85 GiB (1.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung 
  model: SSD 970 EVO Plus 250GB size: 232.89 GiB block size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXM7 
  temp: 33.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: KC44 
  ID-1: / raw size: 223.79 GiB size: 219.28 GiB (97.98%) used: 9.85 GiB (4.5%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 27.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1080 
  Processes: 189 Uptime: 45m wakeups: 0 Memory: 7.73 GiB 
  used: 2.15 GiB (27.8%) Init: systemd v: 247 Compilers: gcc: N/A Packages: 
  pacman: 1273 lib: 381 flatpak: 0 Shell: Bash v: 5.1.0 running in: konsole 
  inxi: 3.2.01
find /var/lib/mhwd -type f -name "*.old"
mhwd -la
> All PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
  video-virtualmachine            2020.03.26                true            PCI
          video-sisusb            2020.01.18                true            PCI
           video-linux            2018.05.04                true            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
              video-s3            2020.01.18                true            PCI
            video-vesa            2017.03.12                true            PCI
          video-voodoo            2017.03.12                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
     video-modesetting            2020.01.13                true            PCI
      video-openchrome            2020.01.18                true            PCI
       video-rendition            2020.01.18                true            PCI
     network-rt3562sta            2013.12.07                true            PCI
       network-slmodem            2013.12.07                true            PCI
         network-r8168            2016.04.20                true            PCI
   network-broadcom-wl            2018.10.07                true            PCI

Warning: No USB configs found!

dont care about fisrt post , so you dont read

sudo mhwd -a pci nonfree 0300

I updated my system then rebooted and got the following message on screen:-

Warning: /lib/modules/5.10.2-2-MANJARO/modules.devname not found - ignoring
mount: /new_root: unknown filesystem type ‘ext4’.
You are now being dropped into an emergency shell.
sh: can’t access tty; job control turned off
[rootfs ]#

My keyboard and mouse don’t work when this message is displayed.

Please help

Do you still have another kernel version installed?

Enter grub menu by press and hold ESC key.
In grub, go to advanced options (not sure how exactly it is called) and try the fallback image or another kernel version if installed.

If you get into your system again, reinstall the kernel:

sudo pacman -S linux510

If not, you will need to chroot into you install. Follow @stephane’s link for instructions.

1 Like

I assume this is for the btrfs filesystem? At the same time, the #DefaultFileSystemType in /etc/systemd/homed.conf changed from ext4 to btrfs.

1 Like

No, had this on XFS not on BTRFS
Testing XFS in VM

Same problem here on my daughters computer. She has a NVidia card.

Hi @Katharsisdrill,

Please see here. I believe it’s either the same or related.

I sincerely hope this helps.

1 Like

So after updating I ran the command:

sudo mhwd -a pci nonfree 0300

and when I try to play CS GO using Steam I get 9fps.

I’m using kernal 5.10.2-2 and nvidia-390xx

Thanks Taylor. I didn’t have a Timeshift backup but uninstalling the Nvidia drivers and mhwd allowed me to boot Manjaro up again. I have installed kernel 5.10 and the package linux510-nvidia however 455 driver is not listed for install in Manjaro Settings Manager.

The new nVidia package is now called video-nvidia
See also: My switch to the 5.10 kernel with update 2020-12-30


I don’t want have troubles, when I do a complete update.
On my other System with nVidia I can not use xbacklight anymore, and the Update made some strange changes which I don’t understand. I don’t understand how I can solve my nVidia Problems.

What means

Kann Abhängigkeiten nicht erfüllen:

  • das Entfernen von mhwd-db verletzt Abhängigkeit von ‘mhwd-db’ benötigt von mhwd,
  • wenn möglich, entferne mhwd und versuche es erneut

Also if I ignore all needed updates and want only update FF, this message appear.
What have FF to do with mhwd? confused

There are a lot packages with “mhwd” installed. Or does it mean, that I only have to uninstall the package mhwd-db 0.6.5-4? And otherwise the update ist not running fine?

On my actual bootet System there is no nVidia driver, so I guess there will be no problems when I update? Kernel 5.4.85-1

[me@me ~]$ mhwd -l
> 0000:01:00.0 (0300:10de:11bd) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-418xx            2020.10.04               false            PCI
    video-nvidia-390xx            2020.10.04               false            PCI
    video-nvidia-340xx            2020.10.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Thx TM

I’ve got installed nvidia-utils and linux510-nvidia and nothing else. Still I can’t manage to install any nvidia drivers with mhwd -a pci nonfree 0300 or listed in Manjaro Hardware Configuration.

It worked! I had to go in through a live-usb and chroot, but then I simply just ran:

sudo pacman -S nvidia-utils
sudo pacman -S linux510-nvidia

and rebooted.

I am eternally grateful!


Happy to hear you managed!!!

Thanks for the update.
Xfce with RX 5500 XT and amdgpu driver here.
After the new update I had a black screen freeze when I started my pc the next day. Switching kernel with the bootloader from 5.10 to 5.9 fixed it for me.
BUT I thought I follow the solution where you have to edit grub and put the amdgpu.dc=0 line in so I could use 5.10 again. I used the nano editor for it as discribed. I did “sudo update-grub” and rebooted.
But then I couldn’t get to the terminal or tty because of a freeze with graphical glitches before login screen.
I had to boot to the console to edit the grub file with nano again. For that I googled about how to boot to console/tty by editing the kernel parameters from the grub menu (I’m not allowed to include a link obviously) and followed the instructions from the first google suggestion. Then I did “sudo nano /etc/default/grub” and removed amdgpu.dc=0 again. That didn’t fixed it even for 5.9. Still freeze with all 3 available kernels in the grub menu. But strangely removing “quiet” and amdgpu.dc=0" fixed it all.

Finally for me the solution was booting from grub directly to the console/tty, then “sudo nano /etc/default/grub” then removing “quiet” and “amdgpu.dc=0” from the GRUB_CMDLINE_LINUX_DEFAULT= line and then “sudo update-grub”, reboot. Some weird log info…restart again.

Now it’s all good and working with kernel 5.10.
I hope this helps anyone with a similar problem because it drove me crazy

edit: thanks @Zesko "Not quite , that is quiet "

Not quite, that is quiet .

1 Like