[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

No it’s not:

  • Switch to a console using Ctrl+Alt+F2

  • Log in as Admin user

  • Execute:

    sudo -s

    to become root

  • execute:

    diff --side-by-side /root/.zshrc.pacnew /root/.zshrc 
  • See if you need to copy-paste anything from /root/.zshrc.pacnew to /root/.zshrc.

  • If you don’t, just delete the .pacnew

  • if yes, please use your favourite CLI editor to incorporate the changes (nano, vi, emacs) Not Kate / Gedit / Atom / …

  • exit the root prompt ASAP as that’s the way to totally fùçk up seriously mess up your system.


See edit to known issues.

CC @Alfy


1 Like

A post was split to a new topic: Errors after update


For all of you having black screen with AMD GPU with kernel 5.10


  1. Open a terminal/TTY (alt+f2)
  2. Enter sudo nano /etc/default/grub
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save, then run sudo update-grub

For systemd-boot:

  1. Open a terminal/TTY (alt+f2)
  2. Enter sudo nano /boot/loader/entries/manjarolinux5.10.conf
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot!

Hope this helps!
It is a bug in the latest AMD drivers…


Try again from a command line:

pamac upgrade


Kernel 4.14, Xfce.
All fine: I had to do the usual system maintenances to check pac files and rebuild AUR packages; however, now in the journal logs, I see a new warning:
systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

Which seems to need this Grub parameter:

I will try and report back.
Yes: I needed to add systemd.unified_cgroup_hierarchy=true to grub to get rid of such error, but I’d like to know if it is ok.

1 Like

Oh, thanks, but already updated… Wouldn’t even be able to run this, as pamac partially uninstalled itself for some reasons…

But sweet, all issues are fixed for me, now!!

1 Like

Your theme is not compatible any more… Try another one…


Ah, ok, thanks.

Do I get that corrrectly: Commenting out that grub line would prevent the warning to appear, but also prevent the usage of systemd-fsck?
So I can ignore this warning?

5.9 is EOL. Try 5.4 LTS (Long Term Support) Instead…


Thank You…

1 Like

same here

Editing that into the known issues right now.
Edited in (with some minor modifications)

:+1: :blush:


I am happy to say everything works sweetly!! :partying_face:

The AMD GPU driver did not work, but with the fabulous help of @The_Quantum_Alpha, it is up and running!! :blush:

Thank you for Manjaro updates :hugs:

Wish a sweet sweet day! :grinning:


Do NOT do that. Whatever AUR package you ran that produced that error needs to be rebuilt.



I had a small issue, the bpython interpreter got uninstalled for some reasons, so I tried to reinstall it, there was a few file conflicts but removing them was enough to solve it, everything is back to normal now.

Also there is something I find weird :
I had nvidia 450 driver installed so far, and when I run mhwd -l, it’s not listed anymore in the avaiable drivers, which means it should have been uninstalled, but nvidia-smi tells me that 450 is still here, I also did a short test with pytorch and everything works fine, any explanation ?

@Fabby Thanks, that helps me :slight_smile:

1 Like

See edit to known issues:

and especially note:

(I’m in the same situation here: need to go to Nouveau as I’m on a GTX 1070 and that should be supported now but too tired to try now)

:bed: :zzz:


GT520 + linux54 5.4.85-1 + linux54-nvidia-390xx 390.138-2 = absolutely terrible performance:

  • Firefox is unbearably slow and is consuming 100% CPU, I can barely type this post
  • games are running at slide show speed
  • GUI is noticeable slow(ish), too
    (glxgears reports 400 fps, though)
    So… I have no idea what to do now to fix or revert everything as it was before the update (previous 5.4 + nvidia-390xx). What I tried:
  1. Removed nvidia-390xx and switched no Nouveau just to see if it’s usable these days (it is not - way faster than my current situation, but still, like, 3 times slower than Nvidia before the update)
  2. Switched back to Nvidia drivers (sudo mhwd -a pci nonfree 0300) - everything is slow again.
    Any advice? I’m in serious trouble now, sorry for begging, but I really, really need an advice :frowning:

I got the following error: