[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Grub Customizer was removed during upgrade. For some reason it conflicts with the new version of GRUB.

It has been that way for a while.
PS - grub-customizer is considered broken/dangerous/incompatible.

If you must use it (please dont) then you will have to use another package like grub-vanilla

1 Like

Installed linux510 before upgrade and rebooted. Everything went fine! Thanks a bunch.

Thanks for the info.
What’s wrong with Grub Customizer? Been using it for many years without any problems.

Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true                                                                                                                
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG                                                     
Processing classid: 0300                                                                                                               
Sourcing /var/lib/mhwd/scripts/include/0300                                                                                            
:: Synchronizing package databases...                                                                                                  
warning: nvidia-prime-1.0-4 is up to date -- skipping                                                                                  
warning: lib32-nvidia-utils-455.45.01-3 is up to date -- skipping                                                                      
core is up to date                                                                                                                    
extra is up to date                                                                                                                   
community is up to date                                                                                                               
multilib is up to date                                                                                                                
resolving dependencies...                                                                                                              
looking for conflicting packages...                                                                                                    
:: nvidia-utils and nvidia-455xx-utils are in conflict (nvidia-libgl). Remove nvidia-455xx-utils? [y/N] error: unresolvable package co
nflicts detected                                                                                                                       
error: failed to prepare transaction (conflicting dependencies)                                                                        
:: nvidia-utils and nvidia-455xx-utils are in conflict                                                                                 
Error: pacman failed!                                                                                                                  
Error: script failed!

I faced the same problem.
Just uninstall nvidia-455xx-utils and install nvidia-utils via Pamac.
After that, install the driver via Manjaro Settings Manager.

Kernel 5-10 refuses to boot; stuck at black screen after grub selection at “NVME” prompt

@Pcwolf Do you have a LTS Kernel as fallback (5.4)? Try that.

Possible to go into TTY? crtl + alt + F2?

5.4 is a must :wink:

1 Like

With the mentioned command I installed the Nvidia drivers.

yep, if you have newer hardware too (for troubleshooting like booting into the system, if it doesn’t work with the stable kernel)

1 Like

I have another problem:
If I try the command pacman -rvk3 then console writes Konnte alpm-Bibliothek nicht initialisieren.

Many Thanks; everything works great (Gnome, Kernel 5.9.16, Thinkpad). Happy New Year everyone.

Thank you! I had the same problem, and your solution worked.

I have the same error message, too. I was actually getting that error in the tty. I would love to know if we can delete the file, or just not worry about it or what. I would rather clean it up now than have to deal with it 6 months from now.

When will there be a new iso with Linux 5.10?

Same here:

[sum@ordi1 ~]$ sudo pacman -rvk3
erreur : l’initialisation de la bibliothèque alpm a échoué
(trouver ou lire le répertoire a échoué : vk3/var/lib/pacman/)
[sum@ordi1 ~]$ 

@nam1962 @Keruskerfuerst

No problem there … thats simply not a valid command.

I think you are looking for paccache

(ex: paccache -rvk3)

@nam1962 what are you doing running random commands [with sudo] others post without understanding them?
You should drop that habit yesterday :wink:


[sum@ordi1 ~]$ sudo paccache -rvk3
[sudo] Mot de passe de sum : 
'/var/cache/pacman/pkg/pamac-common-9.5.12-2-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-common-10.0.0-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-common-10.0.1-1.0-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-gtk-9.5.12-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-gtk-10.0.0-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-gtk-10.0.1-1.0-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/thunderbird-78.5.0-0.1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/firefox-i18n-fr-83.0-1-any.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-flatpak-plugin-9.5.12-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-flatpak-plugin-10.0.0-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-flatpak-plugin-10.0.1-1.0-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-cli-9.5.12-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-cli-10.0.0-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/pamac-cli-10.0.1-1.0-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/firefox-i18n-en-us-83.0-1-any.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/firefox-83.0-1-x86_64.pkg.tar.zst' supprimé
'/var/cache/pacman/pkg/firefox-83.0-2-x86_64.pkg.tar.zst' supprimé

==> finished: 17 packages removed (disk space saved: 169.7 MiB)
[sum@ordi1 ~]$ 

Is obviously better (I only had my first coffee on the first attempt)

Updating to Linux kernel 5.10 borked my Bluetooth driver in KDE Plasma (says “no adapters found” when opening the tool). Was working fine on 5.9, but since that’s EOL I’m back to using the LTS 5.4 kernel until 5.10 gets fingers crossed patched.

  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: Gigabyte model: Z87-HD3 v: x.x serial: <filter> 
  UEFI: American Megatrends v: F8 date: 08/12/2014 
  Info: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP arch: Haswell 
  rev: 3 L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 55889 
  Speed: 3890 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3890 2: 3889 
  3: 3888 4: 3872 5: 3889 6: 3887 7: 3848 8: 3891 
  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI 
  driver: nvidia v: 455.45.01 bus ID: 01:00.0 chip ID: 10de:2182 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia 
  resolution: 1920x1080~60Hz s-dpi: 92 
  OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:1aeb 
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 3-10:4 chip ID: 046d:0825 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Lite-On 
  driver: ath9k v: kernel port: d000 bus ID: 06:00.0 chip ID: 168c:0034 
  IF: wlp6s0 state: down mac: <filter> 
  Local Storage: total: 709.83 GiB used: 246.56 GiB (34.7%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 476.94 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-1: / size: 468.16 GiB used: 246.56 GiB (52.7%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 29 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 44% 
  Processes: 242 Uptime: 3m Memory: 15.58 GiB used: 2.18 GiB (14.0%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1363 Shell: Bash 
  v: 5.1.0 running in: konsole inxi: 3.2.01

Oh, and systemctl status bluetooth.service reports “active”. Not sure what’s going on, or what else I should post here.

1 Like

I get this when updating:
“pipewire-pulse and pulseaudio are in conflict. Remove pulseaudio? [y/N]”
Why does an addition to PulseAudio conflict with PulseAudio itself?