New NVIDIA drivers are not available in mhwd after update

Unfortunately video-nvidia driver config is not available. I put output od mhwd in main post.

Just read through most of the last stable update thread and it seems your problem has not been reported until now, so i would recommend making a post about it in the relevant thread.
What you could do for now, would be to

    • use the 390xx driver series, as it is available for your system


    • install the 455xx driver manually by installing the packages required for it and if need be edit/create the necessary config files

One last thing we could check though would be if the needed mhwd files are installed. Could you post the output of pamac list -i | grep mhwd?

I seem to have the same problem i did some updates and got a black screen ,a few lines at the top of the page error that says about back light error.So i did a fresh install then followed the install nvidia drivers from the front manjaro page .Now i activate nvidia server settings and the monitor isnt there .im not sure what drivers i have installed as the list -i | grep mhwd cmd not found .The page has allso no maximize to full screen now .when i click the top right middle upside down v the page goes down not out .

For driver version 455 mhwd files are installed.

mhwd                               0.6.5-2                     core       253,4 kB
mhwd-amdgpu                        19.1.0-1                    core       1,0 kB
mhwd-ati                           19.1.0-1                    core       4,0 kB
mhwd-db                            0.6.5-7                     core       28,0 kB
mhwd-nvidia                        455.45.01-3                 core       1,5 kB
mhwd-nvidia-340xx                  340.108-1                              2,5 kB
mhwd-nvidia-390xx                  390.138-1                   core       1,9 kB

Then i would really recommend a report in the stable update thread. Sorry that i wasn’t able to be of much help.

1 Like

See if this post can help… :arrow_down:

You need to install linux510-nvidia (have 455.45.01 driver)

I don’t have nvidia-455xx-utils installed, there is nvidia-utils installed in version 455.45.01-2 by default.

No any change. I installed that then rebooted but nothing changed, same issue.

I think NVIDIA 455 is only available for LTS Kernel 5.4. It’s not in the 5.10 repos yet.

You are most likely thinking wrong. I installed linux-54 via mhwd-kernel and linux54-nvidia via pamac and I booted to that kernel via grub but still mhwd not showing any other NVIDIA versions.

GPU has kepler chipset (GK106-240-A1) and should be supported by latest v455 driver
mhwd-nvidia 455.45.01-3 core 1,5 kB
it works on my GK108B GPU

Suggest you go to Manjaro Settings Manager

manjaro-settings-manager -m msm_mhwd

Right-click and select uninstall for any driver shown as ‘Open-Source’ and ‘Installed’

Then right-click video-nvidia and select install

click on ‘show details’ during uninstall/install process to watch for any errors

Okay, I can confirm mhwd does not show Nvidia drivers up in linux-510 either.

there is not video-nvidia option to select.

1 Like

I got the same problem after the big update. But i fixed it by uninstalling nvidia-prime,
nvidia-utils, and lib32-nvidia-utils, then install the driver back with mhwd
hope this helps

I’ve uninstalled nvidia-utils and its dependency linux510-nvidia. I rebooted and still mhwd -a pci nonfree 0300 does not install any nvidia drivers. Nvidia drivers aren’t listed in Manajaro Hardware Manager either.

Did you install the driver using mhwd in some specific way?

I removed nvidia-utils, rebooted, and still same issue. linux510-nvidia are not installed either

Manjaro [Stable Update] 2020-12-30 included new package linux-nvidia replacing linux-510-nvidia-455xx

                     linux510-nvidia-455xx        455.45.01-1.1                    -

                     linux510-nvidia                   -          455.45.01-8

I suggest you check to see if you got the updated packages

pamac search -r linux510-nvidia

When I try:
mhwd -a pci nonfree 0300

the output I get is:

Skipping already installed config ‘video-linux’ for device: 0000:41:00.0 (0300:10de:1e04) Display controller nVidia Corporation TU102 [GeForce RTX 2080]

If I unistall video-linux and I run mhwd again, it just simply installs ‘video-linux’ again, regardless if I had specified ‘nonfree’

1 Like

Yes, I can see the package linux510-nvidia. I’ve installed it before but I didn’t change anything.