[Stable Update] 2020-12-03 - Xorg-Server, Plasma 5.20.4, Cinnamon 4.8.0, Deepin, KDE-git

No issue with the update (Plasma). However, I’ve noticed that the shutdown time has increased: it has appeared a black screen with the mouse cursor that lasts 10 seconds more or less. It seems that, after killing plasmashell, wallpaper etc., there’s a process that now takes more time to kill.

I’m on a Thinkpad T480S with encrypted home folder.

1 Like

Cinnamon, 5.4, all is well. thanks Manjaro team.

Smooth update on Gnome, 5.9 kernel, nvidia 455. Thanks to the manjaro team for another smooth update.

All went well wit the update on two machines, both XFCE and Kernel 5.9. Thanks to the team for the good work.

A post was merged into an existing topic: Update requests for packages imported from Arch Linux

Plasma fresh install = unstable 100% CPU usage Panel unusable. Temporary fix available but not worth it as issue comes back after a while. Awaiting permanent solution.

I use plasma in testing, Xorg version works flawlessly. Wayland version was always unstable.

It works. I tested a couple of scenarios.

  1. remove the pamac-flatpak-plugin and pamac-snap-plugin

Step 1 : Run “pamac remove pamac-flatpak-plugin pamac-snap-plugin” in terminal
Step 2 : Start pamac-manager
Result: pamac-manager application can start

  1. So I reinstall the flatpak and snap plugins

Step 1 : Run “pamac install pamac-flatpak-plugin pamac-snap-plugin” in terminal
Step 2 : Start pamac-manager
Result: pamac-manager application can start
Checks: plugins are disabled

I think the plugins are exposing issues when they get enabled.

I hope the plugins will work again. There are a few flatpak and snap applications installed on my computer.

Updated, everything ok!! Thanks Manjaro Team

You can just install flatpak and snapd to manage these applications from the terminal if nothing else.

sudo pacman -S flatpack snapd

~ >>> sudo pacman -Syu
[sudo] password for ben:
:: Synchronising package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
there is nothing to do
~ >>> lsb_release -a
LSB Version: n/a
Distributor ID: ManjaroLinux
Description: Manjaro Linux
Release: 20.1.1
Codename: Mikah
~ >>>

Seems I can’t get past 20.1.1

Update: It seems Thai mirrors are 1400 hours behind - changed mirrors and running update now.


I don’t know if i have missed info, but pamac gui does not show files for selected package any more (I’m using Gnome).

I don’t have such problem …

1 Like

Xfce, Kernel 4.14. All went OK; I didn’t faced any mentioned issue.
Furthmermore, I faced an improvement: now my system is faster than ever to boot:

Startup finished in 875ms (kernel) + 755ms (initrd) + 1.367s (userspace) = 2.998s 
graphical.target reached after 1.144s in userspace

4 posts were split to a new topic: Issue installing web-installer-url-handler

Okay, journalctl helped me to understand what’s going on, more or less.

Basically, in many kde folders (such as the plasmoid ones, /usr/lib/qt/qml/org/kde/plasma/core/private), different .qml files report “TypeError: Cannot read property '… ’ of null”. Maybe this is the reason for the ten seconds more in shutdown process?

Fresh install of Manjaro Gnome 20.2 on a 2nd PC. Everythings was fine until this morning, the whole themes were back to white. Automatic dark theme was selected but the global theme was set to Matcha-sea. Trying to select Matcha-dark-sea reverted back to Matcha-sea.
Had to toggle off Automatic dark theme, and I could switch my theme to Matcha-dark.

It already happened before : Manjaro Gnome Dark Theme

It’s my first Gnome attempt (I have a dual boot KDE/Cinnamon on the other PC), I don’t know if this extension is prone to bugging.

Why in a Stable branch there are a lot of KDE -git packages?
I see, for eache of them, a regular version in the repos. :thinking:

Getting this in every update

:: Running post-transaction hooks...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Compiling GSettings XML schema files...
No such key “allow-bold” in schema “org.gnome.Terminal.Legacy.Profile” as specified in override file “/usr/share/glib-2.0/schemas/99_manjaro-settings.gschema.override”; ignoring override for this key.
(3/4) Updating icon theme caches...
(4/4) Updating the desktop file MIME type cache...

Since Cinnamon last update i noticed my system takes a little more to boot into desktop. Sometimes, when i interact with the DE, it gets painful slow, like if cpu usage bursts to 100%, (or RAM got OOM) and then it freezes with no apparent reason and i have to hard reset. No reisub or switching tty works. I can tell it’s just the DE which become unresponsive, because this afternoon the issue happened again, while i was downloading a file and after the hard reset i noticed the download progressed like anything happened.
I have another installation with arch and cinnamon and i am experiencing the same issue.