[Stable Update] 2020-12-03 - Xorg-Server, Plasma 5.20.4, Cinnamon 4.8.0, Deepin, KDE-git

@fhins and @galeot: do a flatpak update from the console and try to fire up discover again (also from a console). If this does not work try flatpak repair. Let me know if it worked :slight_smile:

KDE Plasma, kernel 5.4.80-2, just finished a quick update. A rapid and very smooth reboot and experiencing no apparent problems.

Cheers :+1:

My Pacman seems buggy on Minimize/Maximize/Close after update to kde 5.20.3 and now 5.20.4!

on Cinnamon some keyboard shortcuts no longer work (even if i change the shortcut for them they still wont work); for me the media keys are not working (Audio Play, Next/Previous) and when i press the Audio Play button it flashes the screen as if it was taking a screenshot without doing so. iv also found that the Prnt Screen key doesn’t take a screenshot either, i have to use alt + prnt screen now.

iv found this issues tracker for it from 5 days ago that has been closed Cinnamon 4.8 breaks media keys · Issue #9732 · linuxmint/cinnamon · GitHub

and for reference im using a Ducky One TKL keyboard

1 Like

I have the same issue. I tried both

  1. flatpak update
  2. flatpak repair

I am still seeing the same issue

** Message: 11:09:08.666: flatpak_plugin.vala:125: last flathub appstream refresh is older than 6

** Message: 11:09:08.666: flatpak_plugin.vala:126: refreshing flathub appstream data

(process:8626): GLib-GIO-WARNING **: 11:09:08.953: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here. Only the non-desktop-specific mimeapps.list file may add or remove associations.

(pamac-manager:8626): GLib-GIO-CRITICAL **: 11:09:08.955: g_application_run: assertion ‘acquired_context’ failed

I have the same issue (pamac-gtk does not launch), with a Manjaro MATE installation.

1 Like

I managed to run pamac again by following the mapac wiki from manjaro.

I did the following:

Dealing with Orphaned Packages

To check to see if there any orphaned packages(packages which are no longer needed) installed you can use:

pamac list -o

To remove all orphans use the command:

pamac remove -o

Cleaning the Cache

When pamac installs packages, it keeps a copy of all the old packages you have downloaded. This cache can be very useful if you have to install older packages in an emergency. However, left unchecked, this cache will grow very large over time.

A safer way to remove old package cache files is to remove all packages except for the latest three package versions using:

pamac clean --keep 3

Finally run

pamac-manager

You should see the add/remove program again

If the steps above do not work for you, disable the flatpak and snap plugins for pamac.

remove the pamac-flatpak-plugin and pamac-snap-plugin

Step 1 : Run “pamac remove pamac-flatpak-plugin pamac-snap-plugin” in terminal
Step 2 : Start pamac-manager
Result: pamac-manager application can start

If you still want the plugins and keep them in disabled state, do the following:

Step 1 : Run “pamac install pamac-flatpak-plugin pamac-snap-plugin” in terminal
Step 2 : Start pamac-manager
Result: pamac-manager application can start
Checks: plugins are disabled
3 Likes

Hi @b_quest, thank you for your feedback. For me gnome-sogtware did the trick. A little bit annoying thing: it upgraded a bunch of flatpak packages automatically, without asking nor letting me taking note of what it was doing.

Luckily it worked.

1 Like

Updated with TTY …Desktop-Intel i7 Dual screens
LTS kernel KDE Plasma, Quick check all apps work OK …

Thank You

what happens if you remove the pamac-flatpak-plugin and pamac-snap-plugin?

pamac remove pamac-flatpak-plugin pamac-snap-plugin

We had a similar issue in v10.0 we are currently testing. Seems something changed and affected also the stable release.

You can also disable the plugins like so:

sudo sed -i -e /EnableSnap/d /etc/pamac.conf
sudo sed -i -e /EnableFlatpak/d /etc/pamac.conf

I have an issue after update my system. I use Cinnamon edition, and after update i have NO menu. I only see desktop icons, and can’t access other applications.

To solve this problem:

sudo mv .config .config_NEW

sudo mv .local .local_NEW

Updated my gnome System, everything went smoothly.

Kudos to Manjaro team. :innocent:

(KDE) Great. Normally, every update breaks the rtl8723de wifi chipset driver and I have to spend some time fixing it but this time it just worked. Update changes the Chromium zoom and UI levels as well, it retained the changes I had made this time.

May be related: GTK themes doesn't work correctly after Plasma 5.20 upgrade (Manjaro testing)

Thunderbird 78.5.1 breaks Cardbook functionality. A fix is to install the latest Cardbook version, see this page for details.

@alfeo.silvestro

Thanks for the info you provided. I wasn’t able to figure out how to get the pamac to work reading the Wiki, but it worked after I followed your notes. :slightly_smiling_face:

If anyone got problems with rendering on firefox, especially with white popups in extensions see this link:

A workaround is to disable gfx.webrender.all in about:config.

Printer service remains unavailable through reboots after update, KDE official release. Is this the right solution? https://bbs.archlinux.org/viewtopic.php?id=185298

Just use the CUPS related commands showed in Known issues and solutions from above.

1 Like