[Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin

What was this crappy pulseaudio update? Now it is not possible to choose an audio channel

2 Likes

Thanks, Manjaro team! Everything works great. :clap: :blush:

This is my best birthday present. :penguin: :hugs::grin:

4 Likes

Sorry,
But I don’t find anything related in the wiki.
Enabled / disabled wayland, in / etc/gdm/custom.conf but that didnt change anything.

To be fair I’m not qualified enough to give you a proper answer. I think when this .pacnew arrived in Testing, a comment suggested that was the only thing to do, maybe with more explanation. I can’t find the message anymore. I’ll try to edit this message if I find it.

//EDIT: maybe one of these guys can answer Search results for 'mkinitcpio topic:34776' - Manjaro Linux Forum

@pheiduck
@koshikas
@Jaypee

invocation of random power users: @linux-aarhus @Chrysostomus @Fabby @moson

Can one of you guys clarify how to handle properly the new changes in mkinitcpio.conf.pacnew please?

2 Likes

Ive had this issue for some time too.
I tried different things, such as checking network-manager, switching cupsd to a socket, and installing haveged, none of these worked.

I can always to Alt+F2 to a tty and go back with Alt+F1 and the login will start after that for some reason.

I suppose for users that have a splash screen, the system will just hang on their computer logo screen and it will look like nothing is happening.

I really wish we can figure this out.

1 Like

Parentheses is the new standard, but quotes are still supported for the time being.

2 Likes

Everything appears to ok!
5.8.18, KDE & Nvidia.

I am neither of the guys you pinged, but if you’re worried about the keymap, you should leave it in if you’re going with the proposed set of hooks.

However, I myself am no longer using that, because for a while already I’m having systemd take care of the configuration instead of udev ─ it shaves a bit of time off the boot process, and it automatically detects a separate /usr filesystem without needing the usr hook ─ and my HOOKS line looks like this… :arrow_down:

HOOKS=(base systemd autodetect modconf block keyboard sd-vconsole filesystems shutdown)

The sd-vconsole hook here-above takes care of the keymap. You should also include the fsck hook if your root filesystem is not on btrfs.

Other than that, as was explained, the bracket notation is the new standard way of doing things.

3 Likes

Just updated Pamac - Add/Remove Software when pinned to my favourites in gnome now shows a duplicate icon when I open it.

Not sure why that happened.

3 Likes

i’m not qualified on the subject matter either. besides the " changing to (), i think important changes are the changed hooks and their order;

old conf read;

HOOKS=“base udev autodetect modconf block keyboard keymap filesystems”

new conf reads;

HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)

changes being “keyboard” coming before “filesystems”, “keymap” removed and “fsck” added at the end.

now there is some info on these hooks in archwiki;
https://wiki.archlinux.org/index.php/mkinitcpio#Common_hooks

from the little i understood, i think the new conf could be used as is. missing “keymap” hook is required if you use full-disk encryption apparently (so beware). having additional “fsck” hook is recommended practice. that is all i can fathom.

4 Likes

Update went smoothly, however I had one issue.

After I booted into desktop, I had no audio, and journalctl -xef was spewing out a LOT of pipewire error messages.

Had to remove pipewire-jack, pipewire-pulse and pipewire-alsa to get audio back and running (Jack2 + Pulseaudio).

Both “” and () are recognized as bash arrays.

I don’t know where and what or why it has changed but I know that () is the preferred approach to define an array.

For the order of appearance in HOOKS array it is roughly

  • Everything before autodetect is included in your init.
  • Everything after autodetect is included on a device detection basis when the initial ramfs is loaded.

The order of appearance is important in certain use cases - most notably - with encrypted root filesystem and MD/RAID.

Read more at Arch wiki - link to hooks section

8 Likes

Ok thanks everyone, I’ll try to solidify my understanding of hooks and mkinitcpio.

Is it ok to download and keep using this version or should I wait for the release?

I get the same error. Any help is appreciated.

As a workaround downgrading helps:

sudo pacman -U /var/cache/pacman/pkg/pulseaudio-13.0-3-x86_64.pkg.tar.zst /var/cache/pacman/pkg/libpulse-13.0-3-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pulseaudio-bluetooth-13.0-3-x86_64.pkg.tar.zst /var/cache/pacman/pkg/
pulseaudio-equalizer-13.0-3-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pulseaudio-jack-13.0-3-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pulseaudio-lirc-13.0-3-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pulseaudio-zeroconf-13.0-3-x8
6_64.pkg.tar.zst

3 Likes

Uh! So big and huge update! All fine here on Xfce, Kernel 4.14.

I also had the pacnews files about mkinitcpio.conf and /etc/pulse/daemon.conf;

Already months ago I embraced the new syntax for mkinitcpio.conf - parentheses instead of quotation marks, so I just keep my settings (which, obviously, are specific for my system specs):

MODULES=(ahci sd_mod ext4 i915)
HOOKS=(base udev keyboard keymap autodetect modconf block filesystems)
COMPRESSION="cat"

Oddly, the last section - COMPRESSION, still have quotation marks also in the pacnew.

The pacnew of pulse, instead, wanted to change some comments which I made; all my settngs of pulse are in ~/.config/pulse/daemon.conf

For the rest I didn’t received any errors during sudo pacman -Syyu :metal:

1 Like

pacman -Qtd

js68 libpwquality

Running Manjaro GNOME on a Lenovo ThinkPad T14s (Intel model). My Bluetooth keyboard (ThinkPad Trackpoint Keyboard II) appears to have stopped working with the update. It no longer paired automatically. Tried selecting “Remove Device” from the GNOME Bluetooth settings menu, thinking I could re-add it. But it no longer shows up in the menu at all (at least not as a named device—there is an “Unknown” device listed, but it’s grayed out with no option to connect to it). Any guidance would be appreciated.

EDIT: The problem seems to have self-healed after multiple reboots. I’m unsure as to what changed. The only significant thing I did was to run pacdiff, which I’d forgotten to do before. Neither of the .pacnew files (mkinitcpio.conf and php.ini) would appear to have anything to do with Bluetooth connectivity, however. So I’m unsure what happened.

ran the update haven’t rebooted yet but I noticed an error during the download.
error: failed retrieving file 'lib32-libpcap-1.9.1-2-x86_64.pkg.tar.zst' from mirrors.ocf.berkeley.edu : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
is that critical? I tried updating mirrors and rerunning the download but it didn’t bother to re-fetch it.

Edit: manually fetched it and it said it was a reinstall. I’ll update this post or make a new one when I reboot later.

Do a pacman -Qi on both packages and check the section “Required By”, but you should also consider “Optional For”.

For me these packagese were completely orphans.

2 Likes