Speaker, microphone problems

Dir Sir or Madam,
I recently got a thinkpad x1 carbon gen 8 and I have installed manjaro gnome. At first the speaker and the microphone didn’t worked. After installing the sof-firmware the microphone worked but the speakers didn’t. After adding the also option “options snd-hda-intel dmic_detect=0” the speakers worked, but the mic didn’t. I also tried to use older kernels but the same problem. All the solutions I have found haven’t worked for me, so I’m hoping someone else can help me.

1 Like

Could you provide the output of pacmd list-sinks and pacmd list-cards formatted between three backticks like



Or on a pastebin

Bumping this thread hopefully someone can help you with the information you have provided.

Your laptop is a very new device and it’s possible it’s just not well supported and in time this will be ironed out. Unfortunately sound issues are common in the Linux space because of how the device vendors choose to operate.

All the best

The modprobe option hda-intel dmic_detect=0 used to be the workaround to disable the digital microphone array (DMIC) and continue using audio whilst support for the DMIC was being patched
This option was replaced for kernel v5.8 or later with options snd-intel-dspcfg dsp_driver=1

But the internal DMIC is now patched and working if the latest packages can be obtained
so the modprobe option may not be needed

The SOF driver sof-hda-dsp driver is present and recognised in PulseAudio

System will need a recent kernel > v5.8. As this is very a new laptop it may need kernel v5.9

And it also needs a later version of PulseAudio (v13.99) patched to support sof-firmware
the simplest way to get that at the moment is to change to Manjaro testing branch

@BusinessOrc please do not encourage post bumping. just saying you can not help further is enough. but you could also post my username on an audio issue to have a look at it

Thank you so much. Any idea how I can see when I’m able to switch back to the stable branch. When I look up the version I of course see the version 13.99 because I’ve changed Manjaro to testing branch. I want to see version of pulseaudio in the stable branch.

Here you are.

I am not sure if PulseAudio v13.99 will be released to stable branch because it is a development version and might cause problems for some users. but if it does get released in stable branch soon you can switch back from testing to stable

PulseAudio v13.0 on stable branch is now over 12 months old.
v14.0 should have been released months ago but has been delayed by bug problems.
14.0 · Milestones · PulseAudio · GitLab
If that is released to stable branch you would not need to be on testing branch

PulseAudio v13.99 is included in latest stable branch update - [Stable Update] 2020-11-04

so changing branches is not needed now - just update all stable packages

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.