Sound not working after update to Linux kernel 5.7.14+/5.8.0+

Good evening,

For some unknown reason, my USB headset (Steelseries Arctis 5) is no longer detected at all by the Sound settings (Cinnamon DE). When I look in pavucontrol, it doesn’t detect it either. However, I am able to see it in alsamixer as a playback device – but nothing happens when I try to enable it from there.

When I grep for pulseaudio, it returns:

-rw-r–r-- 1 root root 2572 May 13 19:50 pulseaudio-alsa-1:1.2.2-2-x86_64.pkg.tar.zst

When I browse inxi, it displays:

System: Host: nychitman1-x570-custom Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
Desktop: Cinnamon 4.6.7 tk: GTK 3.24.22 info: plank dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Desktop System: Gigabyte product: X570 AORUS MASTER v: -CF serial: <superuser/root required>
Mobo: Gigabyte model: X570 AORUS MASTER v: x.x serial: <superuser/root required> UEFI: American Megatrends v: F20
date: 07/07/2020
CPU: Topology: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 182484
Speed: 2201 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 2263 2: 1899 3: 2199 4: 2199 5: 2477
6: 2149 7: 1985 8: 2043 9: 3715 10: 2035 11: 2200 12: 2192 13: 2032 14: 2193 15: 2196 16: 2196 17: 2195 18: 2057
19: 4052 20: 2043 21: 2202 22: 2199 23: 2195 24: 2198
Graphics: Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Gigabyte driver: nvidia v: 440.100 bus ID: 0c:00.0
chip ID: 10de:1e84
Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 2560x1440~144Hz s-dpi: 96
OpenGL: renderer: GeForce RTX 2070 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes
Audio: Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 0c:00.1 chip ID: 10de:10f8
Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 0e:00.4 chip ID: 1022:1487
Device-3: SteelSeries ApS Controller type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-6.3:7
chip ID: 1038:12aa serial: 00000000
Sound Server: ALSA v: k5.7.15-1-MANJARO
Network: Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 06:00.0 chip ID: 8086:2723
IF: wlp6s0 state: down mac: 1a:1b:d5:2b:f8:c9
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: 5.6.0-k port: e000 bus ID: 07:00.0
chip ID: 8086:1539
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:a3:55:d4
Device-3: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 08:00.0
chip ID: 10ec:8125
IF: enp8s0 state: down mac: b4:2e:99:a3:55:d3
Drives: Local Storage: total: 1.82 TiB used: 475.01 GiB (25.5%)
ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP600 size: 1.82 TiB speed: 63.2 Gb/s lanes: 4
serial: 20138230000128565075 rev: EGFM11.3 scheme: GPT
ID-2: /dev/nvme1n1 vendor: Sabrent model: Rocket 4.0 1TB size: 931.51 GiB speed: 63.2 Gb/s lanes: 4
serial: A5CD070102B301209183 rev: RKT401.2 scheme: GPT
ID-3: /dev/nvme2n1 vendor: Sabrent model: Rocket 4.0 1TB size: 931.51 GiB speed: 63.2 Gb/s lanes: 4
serial: A5CD07050DB303138693 rev: RKT401.2 scheme: GPT
Partition: ID-1: / size: 52.62 GiB used: 18.05 GiB (34.3%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /home size: 1.74 TiB used: 456.96 GiB (25.7%) fs: ext4 dev: /dev/nvme0n1p3
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 40.8 C mobo: N/A gpu: nvidia temp: 53 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info: Processes: 439 Uptime: 13h 42m Memory: 31.37 GiB used: 5.13 GiB (16.3%) Init: systemd v: 246 Compilers: gcc: 10.1.0
clang: 10.0.1 Packages: pacman: 1430 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

dmesg grep for snd:

[ 3.518232] snd_hda_intel 0000:0c:00.1: Disabling MSI
[ 3.518242] snd_hda_intel 0000:0c:00.1: Handle vga_switcheroo audio client
[ 3.518337] snd_hda_intel 0000:0e:00.4: enabling device (0000 -> 0002)
[ 3.648775] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC1220: line_outs=3 (0x1b/0x15/0x16/0x0/0x0) type:line
[ 3.648778] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.648780] snd_hda_codec_realtek hdaudioC1D0: hp_outs=1 (0x14/0x0/0x0/0x0/0x0)
[ 3.648781] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 3.648782] snd_hda_codec_realtek hdaudioC1D0: dig-out=0x1e/0x0
[ 3.648783] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 3.648784] snd_hda_codec_realtek hdaudioC1D0: Front Mic=0x19
[ 3.648785] snd_hda_codec_realtek hdaudioC1D0: Rear Mic=0x18
[ 3.648787] snd_hda_codec_realtek hdaudioC1D0: Line=0x1a
[ 7.074053] usbcore: registered new interface driver snd-usb-audio

pacmd dump:

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id=“0” name=“pci-0000_0c_00.1” card_name=“alsa_card.pci-0000_0c_00.1” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties=“module-udev-detect.discovered=1”
load-module module-alsa-card device_id=“1” name=“pci-0000_0e_00.4” card_name=“alsa_card.pci-0000_0e_00.4” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties=“module-udev-detect.discovered=1”
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0
load-module module-x11-xsmp display=:0 session_manager=local/nychitman1-x570-custom:@/tmp/.ICE-unix/1746,unix/nychitman1-x570-custom:/tmp/.ICE-unix/1746
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_0e_00.4.iec958-stereo 0x10000
set-sink-mute alsa_output.pci-0000_0e_00.4.iec958-stereo no
suspend-sink alsa_output.pci-0000_0e_00.4.iec958-stereo yes
set-sink-volume alsa_output.pci-0000_0c_00.1.hdmi-stereo 0x10000
set-sink-mute alsa_output.pci-0000_0c_00.1.hdmi-stereo no
suspend-sink alsa_output.pci-0000_0c_00.1.hdmi-stereo yes

set-source-volume alsa_output.pci-0000_0e_00.4.iec958-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_0e_00.4.iec958-stereo.monitor no
suspend-source alsa_output.pci-0000_0e_00.4.iec958-stereo.monitor yes
set-source-volume alsa_output.pci-0000_0c_00.1.hdmi-stereo.monitor 0xfffe
set-source-mute alsa_output.pci-0000_0c_00.1.hdmi-stereo.monitor no
suspend-source alsa_output.pci-0000_0c_00.1.hdmi-stereo.monitor yes

set-card-profile alsa_card.pci-0000_0c_00.1 output:hdmi-stereo
set-card-profile alsa_card.pci-0000_0e_00.4 output:iec958-stereo

set-default-sink alsa_output.pci-0000_0c_00.1.hdmi-stereo
set-default-source alsa_output.pci-0000_0c_00.1.hdmi-stereo.monitor


Is anyone else experiencing something similar? If so, have you fixed it? If you have fixed it, can you please provide some tips – I would greatly appreciate it.

Thanks in advance,
Josh aka NYCHitman1

Is it possible that pulseaudio configuration has been reset? I found this here:


By default, pulseaudio only enables the voice chat output. This profile enables the second (game) output and the udev rule makes sure this profile is used when plugging in the device.

If the mic works, but not the audio, then it could be this.

1 Like

If inxi -F shows audiodriver= snd-hda-intel then:

Open /etc/modprobe.d/alsa-base.conf and add the following line at the end:

options snd-hda-intel dmic_detect=0


pulseaudio -k && sudo alsa force-reload
1 Like

That file doesn’t exist on my system.

systemctl --user status pulseaudio.service

  • pulseaudio.service - Sound Service
    Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
    Active: active (running) since Thu 2020-08-20 06:41:18 EDT; 5min ago
    TriggeredBy: * pulseaudio.socket
    Main PID: 1848 (pulseaudio)
    CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
    |-1848 /usr/bin/pulseaudio --daemonize=no
    `-1954 /usr/lib/pulse/gsettings-helper

Aug 20 06:41:17 nychitman1-x570-custom systemd[1750]: Starting Sound Service…
Aug 20 06:41:18 nychitman1-x570-custom pulseaudio[1848]: E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
Aug 20 06:41:18 nychitman1-x570-custom pulseaudio[1848]: E: [pulseaudio] module.c: Failed to load module “module-alsa-card” (argument: "device_id=“2” name="usb-SteelSer>
Aug 20 06:41:18 nychitman1-x570-custom systemd[1750]: Started Sound Service.

You must create that file in /etc/modprobe.d/
(with the content :options snd-hda-intel dmic_detect=0)

When trying to force reload alsa, I get this error:

sudo: alsa: command not found

I have a slew of alsa packages installed, so I have no idea why it’s not finding the command.


I also got that error , but my soundcard was then detected anyway.

No dice here. No detection even after rebooting.

Strange , but possible.I don’t know any other solution.

Some sites say to put “options snd-hda-intel model=generic” or"options snd-hda-intel model=auto"
but I don’t think this will solve the problem
In most cases the solution in my first post solved the problem.
Because there are so many problems now with “dummy output” , I 'll think that in the next weeks it will be solved in an upgrade of Manjaro.

Well, the problem is that it’s not necessarily dummy output for me. It doesn’t detect my headset at all in the sound settings or in pavucontrol.

In both scenarios, previously, there would be a 3rd option for my headset to be selected (and mic for input).

can you check settings ?

Which settings would you like me to check?

in pavucontrol > setting
you will see list audio hardware ( video card audio , intel audio , usb audio , etc … )

My pavucontrol doesn’t have a settings menu. Do you mean the configuration tab?

have you this in settings

Yes, I do have this menu. See screenshot below.

sound motherboard card is missing
sound from any headset USB missing also

have you in your boot kernel ( see /etc/default/grub )

Yes, I know. That’s what we’re trying to get to the bottom of. It worked fine previously, but recently stopped after one of the updates – which of the specific updates, I cannot (unfortunately) recall.

many suggestions so far will not help, as they relate to Intel laptops
but you have an AMD desktop with audio codec [AMD] Starship/Matisse HD Audio

suggest check with pamac search to see if the specific pulseaudio configuration files needed for this headset are installed and present

$ pamac search -f steelseries-arctis-5
/usr/share/pulseaudio/alsa-mixer/paths/steelseries-arctis-5-output-chat.conf is owned by pulseaudio
/usr/share/pulseaudio/alsa-mixer/paths/steelseries-arctis-5-output-game.conf is owned by pulseaudio
/usr/share/pulseaudio/alsa-mixer/profile-sets/steelseries-arctis-5-usb-audio.conf is owned by pulseaudio

the 2 .conf files have an explanation about the unusual configuration of this headset with 2 playback subdevices and one capture subdevice

; Steelseries Arctis 5 USB headset stereo chat path. The headset has two
; output devices. The first one is meant for voice audio, and the second
; one meant for everything else. The purpose of this unusual design is to
; provide separate volume controls for voice and other audio, which can be
; useful in gaming.

1 Like