Some RAM Problem using kde plasma

Hello everyone, thanks a lot for this forum, it save a lot of time for me.
But i can`t find same problem as my, when im using the system, for some time, my ram was increase very fast(check screenshot after reboot and after ~10 minutes) i open the pycharm, dbeaver, telegram, chrome, pamac and close everythink and it increase ram +2G

ibb. co/q9JBCMq
ibb. co/3fKp5xd

Did some one have the same?

and when my ram was full on ~90% i got freezes

The increased RAM usage after booting is normal with KDE Plasma due to the Baloo file indexer running upon logging in. You can disable that, as you can see in the screenshot below. :arrow_down:

You should also be advised that a web browser — any web browser, but especially Chrome — uses up a lot of your RAM, and especially so if you have multiple tabs open.

Furthermore, it is perfectly normal for the memory usage to increase over time, because GNU/Linux makes use of caching in order to be able to open files and start applications faster. The RAM used for caching will normally decrease if more memory is needed by another application. The Linux kernel manages memory very dynamically and efficiently.

This is normal too, depending on whether you’ve created a swap partition (or alternatively, a swap file) or not, and how much RAM is in your machine.

On a machine with less than 8 GiB of RAM, I recommend creating a swap partition of about 10-12 GiB — if you ever plan on hibernating the machine, then you’re going to need that anyway. If your machine has 16 GiB or more and you don’t ever hibernate, then you don’t need swap. :arrow_down:

2 Likes

Thank you for your attention, i`m using 16G ram and 4G swap, but its not enought for me some times.
once my screen was freez when i see ~90 ram on system monitor. Only reboot solve that problem.
But when i check ram usage with ps_mem its not like 90% but anyway freezings

I would also highly suggest to check the dreaded baloo indexer, which gives more headaches as benefits imho.

balooctl status

Issue the command without any arguments to see what other options you can use…

1 Like

i check status now and its disable

Then next thing to check is what is using so much RAM while it increases before you get a freeze, eg. use the Applications tab inside system monitor which will show you this info per running app.

i attach screnshots, and they dont show anythink that can help to understand that

I’m talking about “Menu→Applications→System→System Monitor”

he is show same as htop

Attention: please follow the instructions linked below. a simple disable isn’t enough to kill this total nonsense, ugly and resource-wasting piece of crap

Disabling the indexer

To disable the Baloo file indexer:

$ balooctl suspend
$ balooctl disable

The indexer will be disabled on next login.

Alternatively, disable Enable File Search in System settings under Search > File search.

To permanently delete the index database, run:

$ balooctl purge

This will also resolve the following error message in file dialogs and other applications (KDE bug 437176):
Disabling the indexer

To disable the Baloo file indexer:

$ balooctl suspend
$ balooctl disable

The indexer will be disabled on next login.

Alternatively, disable Enable File Search in System settings under Search > File search.

To permanently delete the index database, run:

$ balooctl purge

This will also resolve the following error message in file dialogs and other applications (KDE bug 437176):

kf.kio.core: "Could not enter folder tags:/."
Disabling the indexer

To disable the Baloo file indexer:

$ balooctl suspend
$ balooctl disable

The indexer will be disabled on next login.

Alternatively, disable Enable File Search in System settings under Search > File search.

To permanently delete the index database, run:

$ balooctl purge

This will also resolve the following error message in file dialogs and other applications (KDE bug 437176):

kf.kio.core: "CoDisabling the indexer

To disable the Baloo file indexer:

$ balooctl suspend
$ balooctl disable

The indexer will be disabled on next login.

Alternatively, disable Enable File Search in System settings under Search > File search.

To permanently delete the index database, run:

$ balooctl purge

This will also resolve the following error message in file dialogs and other applications (KDE bug 437176):
Disabling the indexer

To disable the Baloo file indexer:

$ balooctl suspend
$ balooctl disable

The indexer will be disabled on next login.

Alternatively, disable Enable File Search in System settings under Search > File search.

To permanently delete the index database, run:

$ balooctl purgehttps://wiki.archlinux.org/title/Baloo#Disabling_the_indexer

This will also resolve the following error message in file dialogs and other applications (KDE bug 437176):

kf.kio.core: "Could not enter folder tags:/."

kf.kio.core: "Could not enter folder tags:/."
uld not enter folder tags:/."

kf.kio.core: "Could not enter folder tags:/."

https://wiki.archlinux.org/title/Baloo#Disabling_the_indexer

1 Like

So to recap, am i correct to say you are freezing after ~10 minutes while no process is using so much ram (~90%)? :thinking:
Because that would be something completely different…

But if it freezes when your RAM usage hit ~90%, it should be listed in that info you monitor…

not, on screens just a test, freezing when im using the system for 4 or more hours

TY man, im trying to do this instruction and answer for results

Anyway have some problem
i close every app and still 5.5G RAM usage

And according to that screenshot, you have 16GB RAM, so I don’t think you have anything to worry about. I also have about the same constant usage and I also have 16GB of RAM.

Linux is extremely efficient, or whatever you want to call it’s managing of RAM. See:

https://www.linuxatemyram.com/

But problem with freezes when ~90% RAM is still with me
I’m thinking about the fact that it’s plasma, but I can’t be sure for sure

Having plasma myself, fully updated to version 5.26.3 with absolutely 0 freezes myself, I’m thinking perhaps it’s something else then. Please provide the output of the following:

journalctl --boot=-1 --priority=3 --no-pager

Where:

  • The --boot= is the boot that previously had an occurrance of a hang. It can be adjusted to fit as neccessary. So -1 for the previous boot, -2 for the one before it, -3 for the one before that, and so on, and so forth;
  • The --priority=3 argument will limit the output to Errors and Warnings only;
  • The --no-pager argument will cause the output not to be scrollable, which is neccessary for providing it here.

Let’s try and rather find the cause of your system hanging, rather than speculate about what it might be, and when there’s nothing because the problem is somewhere else, you get frustrated.


I might not be the one to help, my day is about ending this side of the world, but the information would be required for anyone to be able to be of assistance.


:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

```
pasted text
```

This will just cause it to be rendered like this:

Sed
sollicitudin dolor
eget nisl elit id
condimentum
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:


:bangbang: Also, if your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

LC_ALL=C journalctl --boot=-3 --priority=3 --no-pager                                                                                                                                                 
Nov 23 03:26:16 junk-pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [^^^GPP0.PEGP], AE_NOT_FOUND (20210730/psargs-330)
Nov 23 03:26:16 junk-pc kernel: ACPI Error: Aborting method \_SB.PCI0.LPC0.EC0._QC6 due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Nov 23 03:26:16 junk-pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GP17.MP2], AE_NOT_FOUND (20210730/psargs-330)
Nov 23 03:26:16 junk-pc kernel: ACPI Error: Aborting method \_SB.GPIO._EVT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Nov 23 03:26:17 junk-pc bluetoothd[540]: src/plugin.c:plugin_init() Failed to init vcp plugin
Nov 23 03:26:17 junk-pc bluetoothd[540]: src/plugin.c:plugin_init() Failed to init mcp plugin
Nov 23 03:26:17 junk-pc bluetoothd[540]: src/plugin.c:plugin_init() Failed to init bap plugin
Nov 23 03:26:28 junk-pc kernel: rtw_8822ce 0000:01:00.0: failed to do dpk calibration
Nov 23 03:52:09 junk-pc systemd-coredump[3776]: Failed to connect to coredump service: Connection refused
Nov 23 03:52:09 junk-pc pulseaudio[1327]: Lost I/O connection in module "module-gsettings"
Nov 23 03:52:09 junk-pc pulseaudio[1327]: Error opening PCM device _ucm0003.hw:Generic_1: Нет такого устройства
Nov 23 03:52:09 junk-pc pulseaudio[1327]: Error opening PCM device _ucm0003.hw:acp: Нет такого устройства

Нет такого устройства = There is no such device