Some desktop effect animations not playing

I’m missing the animations for some, but apparently not all, desktop effects. In particular, animations for maximising, minimising, present windows, sliding popups (and probably others) are missing (they all just happen instantaneously). However, this isn’t a problem with the compositor just not running, because I can turn on wobbly widows and that works fine (not that I want it, but it works if I did). I also checked animation speed setting, which is in the middle of the slider.

Current settings:

Manjaro KDE
Nvidia 3070 Ti driver version: 470.63.01
Plasma version: 5.22.5
Frameworks version: 5.87.0
Qt version: 5.15.2
Kernel: 5.13.19-2-MANJARO (64-bit)

Things I’ve tried after searching around (to no avail):

  • Re-starting the compositor with Alt-Shift-F12
  • Changing the compositor backend
  • Turning off “allow animations to block compositing”

Hi @jmaargh, and welcome!

While I doubt I’ll be able to help you, please see How to provide good information as well as [HowTo] post screenshots and links

1 Like

I’ve edited it to follow the guidelines.

(incidentally, these weren’t linked from the welcome message we all receive, it might be a good idea to update this especially as it contains generic links about trust levels that are misleading because this forum has customised the settings)


  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=9aa1f23f-7c17-45b6-9c00-18ba5e2aa311 rw quiet udev.log_priority=3
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: B550I AORUS PRO AX v: N/A
  serial: <filter>
  Mobo: Gigabyte model: B550I AORUS PRO AX serial: <filter>
  UEFI: American Megatrends LLC. v: F14d date: 10/01/2021
  Device-1: hidpp_battery_0 model: Logitech Wireless Gaming Mouse
  serial: <filter> charge: 5% (should be ignored) rechargeable: yes
  status: Discharging
  RAM: total: 15.53 GiB used: 4.68 GiB (30.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
  family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201016 cache:
  L2: 3 MiB bogomips: 88668
  Speed: 3743 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz):
  1: 3743 2: 3125 3: 3003 4: 2906 5: 2881 6: 2970 7: 3122 8: 3084 9: 3701
  10: 2966 11: 3018 12: 2993
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
  cr8_legacy cx16 cx8 de decodeassists erms extapic extd_apicid f16c
  flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
  invpcid irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor
  movbe msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx ospke osvw
  overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core
  perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt pse pse36 rdpid rdpru
  rdrand rdseed rdt_a rdtscp rep_good sep sha_ni skinit smap smca smep ssbd
  sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
  topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vaes vgif vmcb_clean
  vme vmmcall vpclmulqdq wbnoinvd wdt x2apic xgetbv1 xsave xsavec xsaveerptr
  xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
  STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] driver: nvidia v: 470.63.01
  alternate: nouveau,nvidia_drm bus-ID: 09:00.0 chip-ID: 10de:2482
  class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 108 s-size: 1204x342mm (47.4x13.5")
  s-diag: 1252mm (49.3")
  Monitor-1: DP-0 res: 2560x1440 hz: 144 dpi: 109 size: 597x336mm (23.5x13.2")
  diag: 685mm (27")
  Monitor-2: DP-2 res: 2560x1440 hz: 60 dpi: 109 size: 597x336mm (23.5x13.2")
  diag: 685mm (27")
  OpenGL: renderer: NVIDIA GeForce RTX 3070 Ti/PCIe/SSE2
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
  Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel v: kernel
  bus-ID: 09:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
  driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
  class-ID: 0403
  Device-3: Kingston HyperX Cloud Stinger Core Wireless + 7.1 type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 0951:170b
  class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
  port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 08:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlp8s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-8:4
  chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.82 TiB used: 890.5 GiB (47.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: S5Z44106 temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 1B6Q scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
  used: 166.32 GiB (18.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 9aa1f23f-7c17-45b6-9c00-18ba5e2aa311
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  label: NO_LABEL uuid: 235A-A3A6
  ID-3: /run/media/john-mark/1c3efb1b-d3f1-4b9d-818f-0d8fa7f19de5
  raw-size: 465.76 GiB size: 457.44 GiB (98.22%) used: 274.42 GiB (60.0%)
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
  uuid: 1c3efb1b-d3f1-4b9d-818f-0d8fa7f19de5
  ID-4: /run/media/john-mark/Data raw-size: 465.75 GiB
  size: 465.75 GiB (100.00%) used: 449.75 GiB (96.6%) fs: ntfs dev: /dev/sda2
  maj-min: 8:2 label: Data uuid: 5FCA6AFE3C42D270
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 6.8 MiB (1.3%) priority: -2
  file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Kingston HyperX Cloud Stinger Core Wireless + 7.1
  type: Audio,HID driver: hid-generic,snd-usb-audio,usbhid interfaces: 4
  rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 0951:170b class-ID: 0300
  serial: <filter>
  Device-2: 1-3:5 info: Kingston HyperX Cloud Stinger Core Wireless + 7.1
  type: HID driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
  power: 500mA chip-ID: 0951:170d class-ID: 0300 serial: <filter>
  Device-3: 1-7:3 info: Integrated Express ITE Device type: HID
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 048d:5702 class-ID: 0300
  Device-4: 1-8:4 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
  class-ID: e001
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Logitech G413 Gaming Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 500mA chip-ID: 046d:c33a class-ID: 0300 serial: <filter>
  Device-2: 3-2:3 info: Logitech Cordless Mouse Receiver type: Mouse,HID
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 98mA chip-ID: 046d:c537 class-ID: 0300
  Device-3: 3-4:4 info: Valve Wireless Steam Controller type: Keyboard,HID
  driver: hid-steam,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 28de:1142 class-ID: 0300
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 48.9 C mobo: 16.8 C gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 309 Uptime: 6h 8m wakeups: 2 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: 1233 pacman: 1222 lib: 420 flatpak: 11
  Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Hi @jmaargh,

Should it happen again, try restarting the compositor fro m the Command line with the command:

kwin_x11 --replace  >/dev/null

I remember mine doing this as well in the past, now that I think about it. No idea why it stopped, though. It just did. Automagically.

@Mirdarthos Thanks for replying! Unfortunately it’s not “happening again”, the animations just never work, even on a fresh boot.

After the update to KDE Plasma 5.23, I have lost the exploding effect when closing a software window (like MacOS), but I have found it solved when I switch the system theme from (Manjaro remaded) Breath to KDE Breeze.

DE: KDE 5.87.0 / Plasma 5.23.1
WM: KWin
GTK Theme: Breeze [GTK2/3]
Icon Theme: breath2

The same as @omano 's solution, maybe the Breeze theme needs update.

Hi again @jmaargh,

Random thought: have you checked to see if it works with a Live ISO? Both the open-source and the proprietary drivers.

I never really noticed if these effects were working on my side, and despite being enabled, or disabled I wouldn’t see the difference, after messing around I found that disabling, rebooting, and enabling these effects again, and rebooting, made them work as intended. Then I went one tick up in the animation speed setting, just one, applied, and it broke the animations again. I think it may broke somewhere when mixing some settings, and probably some kind of corrupt cache is lying around and is cleared after disabling/rebooting, but then get corrupt again when changing some other settings.

This needs more tries and troubleshooting, but this is where I am now.

I found out that using Breeze for the Windows Decoration, fixes the animations issues. Same for GTK Application Style, went back to Breeze and it fixes it.

I’ve had no luck with chaning the theme(s) to breeze. Tried window decoration theme, application theme, and plasma theme

What about the previous post then?