Slow internet in fresh install


Few weeks ago i finally had enough of Windows (sorry for using the W-word, but i believe this helps to explain things) and decided to move to linux for good. I tested couple of ubuntu variants and finally found Manjaro. Compared to others, this one felt most like my system.

However after fresh install of manjaro, my internet speeds have dramatically slowed. I get some 20% of normal readings. Google gives hints that there is an issue with some peoples Realtek hardware, but all links to manjaro forums see old (or private, whatever that means). So now i just have to bug some of you people.

I have reason to believe that this is linked to ethernet driver.

Also i can’t see the 7in1 card reader anywhere. Sadly i’ve misplaced all memory cards it uses, so i can’t do further tests. mhwd seems to find some unknown devices. Not an issue to be bothered with unless this is somehow linked to my net issue.

Puter is Lenovo’s H50-50 tower with i5-4460 and it uses Realtek RTL8111GN for networking.

No. I can’t speak linux, not even english on level needed in this type of issue. I do manage to find the very basics but that’s it. So please, use enough words in answers.

To avoid some obvious questions:

  • cable is Cat6
  • all hardware worked in previous systems
  • iPv6 killed (game some speed, but not even near the normal)
  • almost everything else seems to work like dream

I tried to change to older kernel, since 5.6 seems to be latest Realtek says they support. Installed latest LTS(?) version and thought to have a test with it, but appears that i have no grub window available in booting. Getting one could be useful, but how?

I’d really like to stay in Manjaro, so it would be most appreciated if i could solve at least this net speed issue. If not, The Mother of all Croco…

…The Beast of North…


my wife starts to make sounds loud enough to force me towards another distro. Breaking her romance with Bill G was crime enough to drop the thermometer readings below the zero and now this…

Thanks in advance for your help in this.

Hi and welcome!

First it would be good to have clue what computer you have. Run this command in a terminal:

inxi -Fazy

and copy&paste it here as code. That means with ``` at the beginning and at the end.

My first guess is that the wrong module (driver) has been loaded.

linux56 is EOL (end of life). It would be good to use linux54 (LTS). Normally the grub menu is hidden by default. You need to hold SHIFT at boot to display the grub boot loader.

Could you also copy&paste the outputs of mhwd?

mhwd -l
mhwd -li
mhwd-kernel -li

Thank you! :wink:


I have checked the kernel git repo and the module is included, but since it is not open source, it have to be installed additionally.

If you are using linux54 (check it with uname -r), then you need this extra module:

pamac install linux54-r8168

and check with

inxi -Nazy

which driver has been loaded after rebooting.

It have to be the module for RTL8111 and RTL8168.

Good success :wink:

1 Like

Hello and thank you for answering.

…now let’s see if i manage with this forum system (button with “code” tags would be handy)

inxi -Fazy
  Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=65b8cd34-909c-4bb4-b473-633b4c7661eb rw quiet apparmor=1 
  security=apparmor resume=UUID=fe641759-c403-4f29-b590-01712ce7a878 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: LENOVO product: 90B60058MT v: Lenovo H50-50 
  serial: <filter> 
  Mobo: LENOVO model: SHARKBAY v: 31900058 STD serial: <filter> UEFI: LENOVO 
  v: IEKT30AUS date: 01/06/2015 
  Topology: Quad Core model: Intel Core i5-4460 socket: BGA1155 bits: 64 
  type: MCP arch: Haswell family: 6 model-id: 3C (60) stepping: 3 
  microcode: 1C L1 cache: 256 KiB L2 cache: 6144 KiB L3 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 25548 
  Speed: 1896 MHz min/max: 800/3400 MHz base/boost: 3200/3200 volts: 1.2 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 1896 2: 1897 3: 1894 4: 1896 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: ASUSTeK driver: nvidia 
  v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f82 
  Display: server: X.Org 1.20.8 driver: nvidia display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x318mm (20.0x12.5") 
  s-diag: 599mm (23.6") 
  Monitor-1: DVI-D-0 res: 1920x1200 hz: 60 dpi: 94 
  size: 518x324mm (20.4x12.8") diag: 611mm (24.1") 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:10fa 
  Device-3: Texas Instruments PCM2902 Audio Codec type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1.1:3 chip ID: 08bb:2902 
  Sound Server: ALSA v: k5.4.64-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 port: d000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lenovo 
  driver: rtl8723be v: kernel port: c000 bus ID: 04:00.0 chip ID: 10ec:b723 
  IF: wlp4s0 state: down mac: <filter> 
  Local Storage: total: 931.51 GiB used: 65.75 GiB (7.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST1000DX001-1CM162 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC62 scheme: GPT 
  ID-1: / raw size: 922.42 GiB size: 906.94 GiB (98.32%) 
  used: 65.75 GiB (7.3%) fs: ext4 block size: 4096 B dev: /dev/sda2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 30 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 26% 
  Processes: 203 Uptime: 4m Memory: 7.73 GiB used: 1.10 GiB (14.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1239 lib: 362 
  flatpak: 0 Shell: Bash (sudo) v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05

Makes me wonder, what does it mean with “Required tool smartctl not installed”. Guess i’ll need to install that one.

> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0300:10de:1f82) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-450xx            2019.10.25               false            PCI
    video-nvidia-440xx            2019.10.25               false            PCI
    video-nvidia-435xx            2019.10.25               false            PCI
    video-nvidia-430xx            2019.10.25               false            PCI
    video-nvidia-418xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-450xx            2019.10.25               false            PCI
         network-r8168            2016.04.20                true            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Starting with shift down brought grub visible, just like you told (i wonder why this kinda simple information was so hard to find for me and do i need to go see a doctor because of it).

mhwd-kernel -li
Currently running: 5.4.64-1-MANJARO (linux54)
The following kernels are installed in your system:
   * linux54
   * linux57
   * linux58

This alone didn’t however help in net speed.

Telling it to install driver gave answer “nothing to do here” in my language. So that driver from year 2016 apparently was the one there is available right now. I did install it earlier with that tool there is in preferences.

One strange thing is that if i choose “auto” in link negotiation, it drops ethernet speed to 100 instead of 1gig. I’d undestand if i had bad cable, but like i said, i have cat6 in here, so…

And now let’s see how i managed with this message ;D

Edit: not quite right, i see. I wonder if my terminal sends some kind of forms when copying?

Edit 2: Ah! Tag in it’s own line. Thanks for the gif also (it’ll be year 9077 when i know enough to use this puter to what it was planned to be used).

1 Like

Not bad for the first try @mulli, but please edit it again :slight_smile: I made a nice gif to show you how it have to be done:

Peek 2020-09-13 19-04

Thank you :bowing_man:


Done that. Thanks :smiley:

1 Like

I’ve set it to ignore, but you can set it manual. Sometimes automatic doesn’t work correctly or chose a lower speed, just in case.

Done that, but didn’t give me candy.

I have 100mb connection (which translated in Finnish business language means “5-35Mb average”) and i get speeds from 2ish to 7ish. In practice this puter has downloaded in between 20-30Mb until now.

Router is Huawei B525 (althou i believe that has little or no importance in this).

Must be something that i’ve missed in ethernet preferences. That, if my driver operates as it should be.

Did you reconnect after applying the new link negotiation ?

Everywhere it said that auto link negotiation solved the problem.

Maybe this problem happened here: (it is german)
Here is the translated solution:

By a cold start of your PC (disconnecting the power cable for 5 minutes and then switching it on again) possible faulty states of your network card are eliminated.

I even rebooted and for that i got the lowest score (1,3Mb) ever from speedtest.

Gotta try that cold start next.

Btw … it displays that it can 1Gig…

…aand after repainted my lungs with tar and release of some long-used coffee, connecting the power back gave me that 1ish meg in test.

I set Link negotiation to “auto”, then shutdown, pulled the plug and just normal start.

Is there a way to remove all network drivers just to make sure there isn’t some kinda leftovers from 1st install? Somekinda fresh install for just that one driver?

And yet it is back on 100Mb, when i check preferences.

A previous install? What do you mean?


Lets try another tool:

pamac install ethtool


ethtool enp3s0

then look at the infos and set it correctly:

ethtool -s enp3s0 speed 1000 duplex full
ethtool -s enp3s0 autoneg on


Maybe check also your Router in which mode it is operating.

Note: Forget that ethtool.

ipv6 could be problem with old drivers. Disable it.

ethtool enp3s0
netlink error: No such file or directory
Settings for enp3s0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  Not reported
	Advertised pause frame use: No
	Advertised auto-negotiation: No
	Advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Port: Twisted Pair
	Transceiver: internal
	Auto-negotiation: off
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000033 (51)
			       drv probe ifdown ifup
	Link detected: yes

Also same netlink error after both command lines. And appears that i already had ethtool installed.

ipv6 is already disabled.

Something strange in routers ethernet report though.

|Kesto:  |00:00:00| (duration)
|Yhteystila:  |Yhteys katkaistu| (Status disconnected)
|MAC-osoite:  |78:62:56:F4:43:98|
|Yhteystila:  |LAN-yhteys katkaistu| (LAN disconnected)
|IP-osoite:  |Tuntematon| (unknown)
|Aliverkon peite:  |Tuntematon| (subnet mask unknown)
|Oletusyhdyskäytävä:  |Tuntematon| (unknown)
|Ensisijainen DNS-palvelin:  |Tuntematon| 
|Toissijainen DNS-palvelin:  |Tuntematon|

What should i think of that? Now that i was in router, i set it to LAN only from auto. However nothing changed.

Cant read that :stuck_out_tongue: Start it with:

LANGUAGE=en_EN command

According to this: Network configuration/Ethernet - ArchWiki

Maybe try this module: r8169

rmmod r8168


modprobe r8169

To load this module at boot, blacklist r8168

sudo echo "blacklist r8168" > /etc/modprobe.d/blacklist.conf

Sorry. Forgot to answer to this.

I meant that when i installed Manjaro, the driver was somethin else. I’ve used that graphic installer app all the time and i’ve read somewhere that they may make mistakes that terminal’s don’t. Some problem in removing old or somekinda registry (we have one, or is it Win only thing?) issue. Can’t tell.

Like i said, i have practically no clue what’s going on deeper in Linux, althou i’ve used several.

1 Like

yeah understand. and no there is no registry. Modules (drivers) can be loaded instantly. There is a “prober” which detects the hardware and load the proper module. If that module is wrong you need to black list it, so that it chooses another one.

# Ethernet Status

| --- | --- |
|Connection status:|Disconnected|
|MAC Address:|78:62:56:F4:43:98|
|Connection mode:|LAN disconnected|
|IP address:|Unknown|
|Subnet mask:|Unknown|
|Default gateway:|Unknown|
|Primary DNS server:|Unknown|
|Secondary DNS server:|Unknown|
1 Like

Beside a nice summery for longtime users:

1 Like

I would suggest to blacklist the current driver and reboot.

Then check which driver has been loaded:

inxi -Nazy

What i have now, is computer running from USB stick. I believe i had no such thing as r8189 available.

Yes. Noob. I know ;D

Actually i got paid for using old Macs back in the fogs of history, then changed reluctantly to win when iAge hit Apple and everything was the same with Win but with prices x 10.

This doesn’t pain me (too much) and i like to learn. However i’d like to choose them moments when i have to learn myself and not decided by this poor excuse of a computer ;D

What i need now is some kinda network driver back to puter itself. After that i believe is time to return to other things.

1 Like