Dash to dock fails and default desktop view changed after the update

Thanks for suggestion, as a solution that’s a great alternative. I like it! But dash to dock is not working as old for me and that tend me to try some unstable solutions, as a result sometimes I even see some kind of vertical rectangle. Lol.

That rectangle also can change its color according to background :smile:

At the end, I removed whole gnome40 implementations of dash-to-dock ext and installed with pamac from the database again. It’s looking fine than the unknown rectangle but still can not use my configs. Whole dock is looking like inside of an high opacity rectangle and I think that’s the default with some broken options.

By the way, there are some conflicts in Layouts app and Extensions.

I had run into an error with no output while trying GNOME. Dash to dock completely was not able to run and other layouts (except Manjaro and Manjaro Legacy).

I noticed that there’s a Night Theme Switcher Extension. It’s cool but after using that, losing the theme options. Like mine, I’m using Matcha Light Azul and wanted to try the night theme but after disabling it, didn’t return to the theme. It stayed at same, dark / night theme.

Mine was in /usr/share/gnome-shell/extensions/dash-to-dock@micgx.gmail.com. After I removed the schemas folder I do not get this error message in the extensions app anymore.

2 Likes

I deleted that entire directory and still the extensions dialog doesn’t work.

I’ve just tried this solution, now I’m able to access the options but dash-to-dock is still faulty. Opacity is not working as expected, at first it works with a vertical rectangle that I mentioned in my last comment.


And a few actions later it denies the opacity.

But sizing properties are working, they’re able to change.

eventually give this one try:
rename /home/(user)/.config/user to for example user.bak
and reboot quickly.
The effekt is that Manjaro is set to default Gnome…
Returning is possible, but keep a backup of the file “user” anyway.

I can confirm that after doing following, I can open settings window without any issues:

cd /usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/
sudo mv schemas schemas-bak

And then in the settings switching to using built-in themes under Appearance tab made it look good again :wink:

13 Likes

Sorry, forgot to mention that I did a reboot after removing the folder. Not sure if that helps…

Also worked for me.

That worked for me as well. I moved the schemas file, rebooted and then I was able to open the settings window and finally disable the mounted volumes and trash icons, which I don’t like.

I’ve got the same issues after the update, have you solved this problem?

Nope but I’m getting used to :smile:

OK, I’ll get used to :joy:

1 Like

Please test gnome-shell-extension-dash-to-dock 69+14+g302c693-4 69+14+g302c693-5, I think I may have found the issue.

How can I install this version? I guess “69+14+g302c693-4” is the version name.

Check for updates using Add/Remove Software. If you’re not seeing the update, your mirror hasn’t synced yet. See Pacman-mirrors - Manjaro

1 Like

I switched dash-to-dock to dash-to-panel.
dash-to-panel supports Gnome 40 and Wayland. Its setting looks good for me, I do not need the dock.

You can disable overview of workspace at startup.
https://extensions.gnome.org/extension/4099/no-overview/

or

https://extensions.gnome.org/extension/3843/just-perfection/
You can change Overview to Desktop in “Startup status” .

2 Likes
Packages (1) gnome-shell-extension-dash-to-dock-69+14+g302c693-4

Total Download Size:   0.19 MiB
Total Installed Size:  0.84 MiB
Net Upgrade Size:      0.00 MiB

And I’ve just installed, it looks fine for now.

Thanks.

But there are 2 problems here. The first one is actually not’s a real problem anymore, I’m getting used to but why is the first start-up place is workspaces / activity?

And the second one is, switching between workspaces does not display previews.

Oh, that looks like a solution thanks but before trying that, I think Manjaro Team may change or add to settings as a native option.

I think that overview of workspace starts up by default, if it has at least 2 workspaces.