Shutdown takes much longer

Recently Manjaro takes much longer to shut down(feels like minutes sometimes, but i did not time it), and just before it does, for a second there is red and white text on the screen.

$ inxi --full --verbosity=7 --filter --no-host

inxi --full --verbosity=7 --filter --no-host
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB:en_US",
        LC_ALL = (unset),
        LC_ADDRESS = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MONETARY = "de_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_TIME = "io_001.UTF-8",
        LC_COLLATE = "de_DE.UTF-8",
        LC_NUMERIC = "de_DE.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
System:    Kernel: 5.4.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MEDIONPC model: MS-7728 v: 2.0 serial: <filter> BIOS: American Megatrends v: E7728MLN.209 
           date: 12/22/2011 
Memory:    RAM: total: 15.62 GiB used: 5.35 GiB (34.2%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i5-2320 bits: 64 type: MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
           bogomips: 23953 
           Speed: 1946 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1946 2: 2057 3: 2136 4: 1899 
           Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 
           dtherm dts epb ept est flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx monitor msr 
           mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good 
           sep ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid 
           xsave xsaveopt xtopology xtpr 
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: ASUSTeK driver: nvidia v: 450.66 bus ID: 01:00.0 
           chip ID: 10de:1380 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia resolution: 1: 1920x1080~60Hz 
           2: 1280x1024~60Hz s-dpi: 101 
           OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fbc 
           Device-3: Thesycon System & Consulting type: USB driver: snd-usb-audio bus ID: 3-1.1:3 chip ID: 152a:8750 
           Sound Server: ALSA v: k5.4.67-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: d000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: IMC Networks Mediao 802.11n WLAN [Realtek RTL8191SU] type: USB driver: r8712u bus ID: 3-1.6:6 
           chip ID: 13d3:3306 serial: <filter> 
           IF: wlp0s29u1u6 state: down mac: <filter> 
           WAN IP: <filter> 
Drives:    Local Storage: total: 1.36 TiB used: 1.09 TiB (79.6%) 
           ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB speed: 3.0 Gb/s serial: <filter> rev: 023 
           scheme: MBR 
           ID-2: /dev/sdb vendor: Western Digital model: WD5000AAKX-00ERMA0 size: 465.76 GiB speed: 3.0 Gb/s serial: <filter> 
           rev: 1H15 scheme: MBR 
           Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SH-216AB rev: MD00 dev-links: cdrom 
           Features: speed: 48 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 898.98 GiB used: 829.13 GiB (92.2%) fs: ext4 dev: /dev/sda1 label: N/A 
           uuid: c9c07722-f3ef-4038-a3ef-f4803e917bde 
           ID-2: /run/media/jan/4AD42B71D42B5E87 size: 194.72 GiB used: 166.82 GiB (85.7%) fs: ntfs dev: /dev/sdb2 label: N/A 
           uuid: 4AD42B71D42B5E87 
           ID-3: /run/media/jan/Daten size: 270.45 GiB used: 115.67 GiB (42.8%) fs: ntfs dev: /dev/sdb4 label: Daten 
           uuid: 18DCF506DCF4DF46 
           ID-4: /run/media/jan/System-reserviert size: 100.0 MiB used: 65.4 MiB (65.4%) fs: ntfs dev: /dev/sdb1 
           label: System-reserviert uuid: E48225DD8225B4C8 
Swap:      ID-1: swap-1 type: partition size: 17.19 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 label: N/A 
           uuid: e055263f-df22-4160-9468-005831f77676 
Unmounted: ID-1: /dev/sdb3 size: 510.0 MiB fs: ntfs label: N/A uuid: 3AA6701FA66FDA41 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024 
           Device-1: 1-1.2:3 info: Holtek type: Keyboard,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
           chip ID: 04d9:0356 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024 
           Device-1: 3-1.1:3 info: Thesycon System & Consulting type: Audio driver: snd-usb-audio interfaces: 3 rev: 2.0 
           speed: 480 Mb/s chip ID: 152a:8750 
           Device-2: 3-1.2:4 info: Logitech G600 Gaming Mouse type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 046d:c24a serial: <filter> 
           Device-3: 3-1.5:5 info: Realtek RTS5182 Card Reader type: Mass Storage driver: ums-realtek interfaces: 1 rev: 2.0 
           speed: 480 Mb/s chip ID: 0bda:0184 serial: <filter> 
           Device-4: 3-1.6:6 info: IMC Networks Mediao 802.11n WLAN [Realtek RTL8191SU] type: Network driver: r8712u 
           interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 13d3:3306 serial: <filter> 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 34 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 6% 
Info:      Processes: 219 Uptime: 10m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1442 Shell: Bash v: 5.0.18 
           running in: yakuake inxi: 3.1.05

$ journalctl -p3 -b -1

blk_update_request: I/O error, dev sr0, sector 0 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 0, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 1 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 1, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 2 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 2, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 3 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 3, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 4 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 4, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 5 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 5, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 6 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 6, async page read
Oct 08 22:26:42 jan-manjaro kernel: blk_update_request: I/O error, dev sr0, sector 7 op 0x0:(READ) flags 0x0 phys_seg 2 prio class 0
Oct 08 22:26:42 jan-manjaro kernel: Buffer I/O error on dev sr0, logical block 7, async page read

Are you certain that you have locale settings defined in Manjaro settings Manager-Locale settings? An update some time back erased my settings and I had to set them manually.

Under Local everything has a value, i think that is a left over from solving a bug with kde sometime ago. Do you think that is actually the reason?

Do you have a CD/DVD in the drive? If so, eject it and try to power off again.

I don’t have one in the drive.

sr0 is usually an optical drive, that’s why I asked. Your journal only shows errors concerning sr0.

Try jurnalctl -b-1 (without -p3).

I have windows on a second harddrive, could that be the reason?

EDIT: That is 11245 lines is there an easy way to copy all this, i don’t seem to be able to copy it all in one go?

Try journalctl -xe -b-1. If it is too long use pastebin.

journalctl -xe -b-1
░░ The job identifier is 11860.
Oct 12 05:23:05 jan-manjaro audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-reboot comm="systemd" exe="/usr/lib/systemd/systemd" hos>
Oct 12 05:23:05 jan-manjaro audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-reboot comm="systemd" exe="/usr/lib/systemd/systemd" host>
Oct 12 05:23:05 jan-manjaro systemd[1]: Reached target Reboot.
░░ Subject: A start job for unit reboot.target has finished successfully
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░  
░░ A start job for unit reboot.target has finished successfully.
░░  
░░ The job identifier is 11859.
Oct 12 05:23:05 jan-manjaro systemd[1]: Shutting down.
Oct 12 05:23:05 jan-manjaro systemd[1]: Hardware watchdog 'iTCO_wdt', version 0
Oct 12 05:23:05 jan-manjaro kernel: watchdog: watchdog0: watchdog did not stop!
Oct 12 05:23:05 jan-manjaro systemd[1]: Set hardware watchdog to 10min.
Oct 12 05:23:05 jan-manjaro systemd-shutdown[1]: Syncing filesystems and block devices.
Oct 12 05:23:05 jan-manjaro systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Oct 12 05:23:05 jan-manjaro haveged[263]: haveged: Stopping due to signal 15
Oct 12 05:23:05 jan-manjaro haveged[263]: haveged starting up
Oct 12 05:23:05 jan-manjaro systemd-journald[265]: Journal stopped
░░ Subject: The journal has been stopped
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░  
░░ The system journal process has shut down and closed all currently
░░ active journal files.
lines 2183-2208/2208 (END)

EDIT: I also managed to make a photo of the error on shutdown

So … uh … whats that ‘oldroot’ directory thats mounted and seems to not want to unmount?
(its not standard … so its something particular to you)

1 Like

I think thats something from the live image…

Try to disable watchdog. Upon boot press e at the grub menu entry, then go to the end of the linux line and write nmi_watchdog=0. Here’s how mine looks for an example (ignore the other parameters I have there):

linux   /vmlinuz-5.4-x86_64 root=/dev/mapper/vgManjaro-lvol0 rw  resume=/dev/vgSwap/lvol0 quiet scsi_mod.use_blk_mq=1 zswap.enabled=1 zswap.max_pool_percent=13 zswap.compressor=lz4 zswap.zpool=z3fold nmi_watchdog=0 mitigations=off

The press F10 (I think) to continue booting and then test it.

It would be good to clarify this. Do you mount it manually or what?

I don’t have it on my current system, but i remember having seen it when using the live medium.

I have no idea waht oldroot is, but i found this in the archived manjaro forum:

Is that the line where i should add nmi_watchdog=0 it looks quiet a bit different compared to yours.

When i “installed”/connected my windows drive it, i booted it in manjaro and ran sudo update-grub after that at launch i get a screen where i can choose. I don’t think that counts as manually.

Yes, navigate to the line starting with linux, click END, SPACE and type nmi_watchdog=0 then press F10.

It’s system specific and I have some personal settings there. That’s why it is so different.

I’m not sure I understand this. You can choose what and where? And, is Windows on an external drive also? Or have you removed it with fear of overwriting it when installing Majnaro?

I can select the os i want to boot here. Yes Windows is on a seperate hard drive, but it is internal not external. I Removed it in case i broke something and installed Manjaro on a fresh SSD. After the installation i connected it again.

Adding nmi_watchdog=0 solved the issue and i no longer get the error message. My Shutdown time is also back to normal.

EDIT: Thank you for the help

1 Like

Ok, to make it permanent edit /etc/default/grub and add it to end of the line starting with GRUB_CMDLINE_LINUX_DEFAULT=, like this (ignore the rest of my personal parameters):

[mbb@mocho-desktop ~]$ cat /etc/default/grub
[...]
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/vgSwap/lvol0 quiet scsi_mod.use_blk_mq=1 zswap.enabled=1 zswap.max_pool_percent=13 zswap.compressor=lz4 zswap.zpool=z3fold nmi_watchdog=0 mitigations=off"
[...]

You can see these are the parameters appearing in the linux line edited above.

Save your changes and then issue sudo update-grub to make it permanent.

Out of curiosity, do you know what actually caused it? Did i break something?

No, everything is fine. Watchdog is a kernel component which makes sure the system is responsive. Sometimes it just doesn’t stop on shutdown/reboot, or can’t stop a certain process from executing. I always disable watchdog on my systems. This is more useful for remote systems needing constant uptime.