Failed to unmount /oldroot: Device or resource busy

Hi, when i shut down system, my motherboard logo shows up for about 2 mins. Then those messages shows up for second.

[ 4044.873100] sd-umount[8299]: Failed to unmount /oldroot: Device or resource busy
[ 4044.839977] sd-umount[8300]: Failed to unmount /oldroot/sys: Device or resource busy
[ 4044.290367] shutdown[1]: Failed to finalize file systems, ignoring.
[ 4046.29036] xhdi_hdc 0000:07:00.3: Host halt failed. -110

Theres video i recorded when this happening: youtu be/hOPp30SmxvY (please add dot, i cant add link to post)

Im not sure but i think it’s showing up since i typed pacman -S linux59-headers in terminal because there was problem with my VMware Workstation and found this command as solution.

My motherboard is Aorus B450 Elite. Os is Manjaro and Windows 10, both installed in same ssd disk. Thanks in advance.

I found this about the issue Failed to unmount /oldroot on shutdown - #13 by cluster - Kernel & Hardware - EndeavourOS it can maybe help to fix it.

Welcome to the forum :wave:

I’ve seen the failed to umount /oldroot etc before, my issue with the message (I don’t have the boot delay) is solved by adding shutdown to /etc/mkinitcpio.conf. It probably is one of the solutions you run into when searching for the error. The xhdi_hdc error might be worth exploring further for. That seems to stop the halt process.

Some more old links that might be pointers to solutions.

It seems that showdown issues are not that common as say startup issues and even less solved/posted about.

Is this a system with Nvidia drivers?

it’s very common,reported years ago(yet not fixed),apparently cosmetic and nothing to worry about.
“the Arch-dev says that the shutdown hook is a deprecated method and shouldn’t be used”.
it happens to me too most of the time when shutting down.
i do think it’s related to my intel nvidia laptop and which one i choose to run .

Hi every one. Thanks for replies.

@omano @Hanzel So i repeated those steps:

HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck"
HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck shutdown"


but that didn’t help.

@openminded Yes, it is

@linub Sure, but it takes to 3 mins, that’s a lot of time if i want only to change operating system. And of course its annoying.

Do you have any more ideas? I’ve checked those links send by @Hanzel and @linub but i can’t find that, what should help me, excluding adding GRUB_CMDLINE_LINUX_DEFAULT=" " lane to /etc/default/grub but i don’t know what values should i put in " " and whether should i add it.

Another idea might be a solution from a stable release thread

Possible 2 Min delay on shutdown with Gnome

If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

ExecStart=/usr/lib/gnome-session-ctl --restart-dbus

Click this link For more information

I’m using KDE plasma :confused:

The solution is listed as specific to gnome so that is not the solution.

There are some examples of users with nvidia who have long shutdowns. @openminded refered to this in the post above. and @linub posted this link: "Failed to unmount /oldroot/..." when shutting down / Newbie Corner / Arch Linux Forums . there is a lot to check and followup in that post.

If you could just restart desktop enviroment…

Maybe better process manager, which shows which kernel services which process uses would be nice.

Maybe there something like cat from proc, that lets you know this, after grep, and then you can unmount it…

But I recommend unmount -f because it’s probably virus, that stores itself on your harddrive.

Yes linux is full of viruses and little kids can hack it.

Unfortunately there’s no other known way to solve this if it’s caused by Nvidia except removing this driver.
I did it once and it helped to get rid of /oldroot messages.

1 Like

I’m seeing this with kernel panic on a macbook 4,1 with the isight firmware loaded with isight firmware tools. Running zoom & recording. On Gnome Desktop.

Lily Shutdown Crash

Last time I looked into this issue (last year) it was something that should have been fixed in systemd 246 (I remember of an issue on github and the “milestone 246” had been added to it iirc). Looking at google it seems this has been fixed multiple times, it seems to have multiple possible cause this is really frustrating because nobody seems to know for sure what causes the issue.

This wasn’t fixed, what Lennart said was like “we don’t know what causes this but it’s not our bug, deal with your distro maintainers”.

UPD: Systemd 248 kinda solved this issue on my laptop at least.

Is this the answer or fools gold?

it seems to work now!

sudo nano /etc/mkinitcpio.conf

HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck"
HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck shutdown"

sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg

sudo systemctl restart systemd-coredump.socket
sudo systemctl reset-failed
1 Like

Try and see, as said this bug seems to have multiple possible causes. Anything at this point could help you.

1 Like

Still failing with a KP…

Another macbook 4,1 without Plymouth (if it matters) freezes on power off with:

hub 6-0:1.0 hub_ext_port_status failed (err = 110)

Tested video recording on a Lenovo G560 with the native webcam driver provided by the distro & there are no shutdown issues. My guess it has something to do with drivers installed after the initial installation causing the issue…

fixed in one of my machine with the issues with today update on unstable, i guess systemd 248-1