Screen Artifacts after resuming from sleep

Hi everyone,

So recently, after updating to video-hybrid-intel-nvidia-440x-prime, I’ve been getting strange screen artifacts every time the computer resumes from suspend. This was never an issue while using any of the bumblebee drivers. Nvidia drivers losing background images during context switches is apparently a known issue, but one that should have been solved with Qt5.13 and Plasma 5.16.

The issue is not only with chrome, but also with icons in latte dock, and also in the settings application. Usually hovering over the icons in the dock, and restarting chrome will get rid of the issue, but there has to be a better solution than that.

I’ve searched around for solutions to the problem, but the only advice I’ve found was to downgrade from the 450 drivers to the 440 drivers (which I’ve already tried) and to upgrade to Qt5.13 and Plasma 5.16 (but I’m already on Qt5.15 and Plasma 5.19). I’ve also tried to look at the logs, but I don’t see anything that’s relevant.

Any help with the issue would be much appreciated.

`inxi --admin --verbosity=7 --filter --no-host`
System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=af13e3d4-aed2-4f67-8b23-f4c706c9b786 rw quiet 
           resume=UUID=e5bb7d1c-ba23-4d28-b944-a0958a1194ec 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH serial: <filter> Chassis: type: 10 
           v: Lenovo Legion Y530-15ICH serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: 8JCN52WW date: 06/14/2019 
Battery:   ID-1: BAT0 charge: 20.7 Wh condition: 44.0/52.5 Wh (84%) volts: 12.0/11.2 model: SMP L17M3PG1 type: Li-poly 
           serial: <filter> status: Charging 
Memory:    RAM: total: 7.65 GiB used: 3.86 GiB (50.4%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: D6 L2 cache: 8192 KiB bogomips: 36812 
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms est f16c flush_l1d fma 
           fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
           mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs 
           pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
           sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave xsavec xsaveopt xsaves 
           xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo driver: nvidia v: 440.100 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8d 
           Device-3: Lite-On Integrated Camera type: USB driver: uvcvideo bus ID: 1-6:3 chip ID: 04ca:7070 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting,nvidia display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlp0s20f3 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: noprefixroute scope: link 
           IF-ID-1: br-97cba58c03c0 state: down mac: <filter> 
           IP v4: <filter> scope: global broadcast: <filter> 
           IF-ID-2: br-d8ceec48f030 state: up speed: 10000 Mbps duplex: unknown mac: <filter> 
           IP v4: <filter> scope: global broadcast: <filter> 
           IP v6: <filter> scope: link 
           IF-ID-3: docker0 state: down mac: <filter> 
           IP v4: <filter> scope: global broadcast: <filter> 
           IF-ID-4: veth35da179 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-5: veth9e10df4 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-6: veth9fc319c state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-7: vethc4ef9fa state: up speed: 10000 Mbps duplex: full mac: <filter> 
           WAN IP: <filter> 
Drives:    Local Storage: total: 1.36 TiB used: 685.64 GiB (49.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXE7 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: LXM3 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 175.00 GiB size: 171.25 GiB (97.86%) used: 94.76 GiB (55.3%) fs: ext4 dev: /dev/nvme0n1p6 
           label: Manjaro Root uuid: af13e3d4-aed2-4f67-8b23-f4c706c9b786 
           ID-2: /boot/efi raw size: 260.0 MiB size: 256.0 MiB (98.46%) used: 34.0 MiB (13.3%) fs: vfat dev: /dev/nvme0n1p2 
           label: N/A uuid: 5BA3-DC22 
           ID-3: /mnt/Data raw size: 600.00 GiB size: 600.00 GiB (100.00%) used: 590.84 GiB (98.5%) fs: ntfs dev: /dev/sda3 
           label: Data uuid: 88EA748CEA7477F0 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7 label: swap 
           uuid: e5bb7d1c-ba23-4d28-b944-a0958a1194ec 
Unmounted: ID-1: /dev/nvme0n1p1 size: 1000.0 MiB fs: ntfs label: WINRE_DRV uuid: 9C56BEBD56BE978A 
           ID-2: /dev/nvme0n1p3 size: 16.0 MiB fs: <superuser/root required> label: N/A uuid: N/A 
           ID-3: /dev/nvme0n1p4 size: 275.00 GiB fs: ntfs label: Windows uuid: BE2ABD3B2ABCF18F 
           ID-4: /dev/nvme0n1p5 size: 526.0 MiB fs: ntfs label: N/A uuid: 94C421C2C421A806 
           ID-5: /dev/sda1 size: 100.00 GiB fs: ext4 label: Backup uuid: d29a7f34-e2c3-45c3-a364-6a74a7ec1cfb 
           ID-6: /dev/sda7 size: 10.00 GiB fs: <superuser/root required> label: N/A uuid: N/A 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-1:2 info: Realtek 4-Port USB 2.0 Hub ports: 4 rev: 2.1 speed: 480 Mb/s chip ID: 0bda:5409 
           Device-1: 1-1.2:4 info: N/A type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
           chip ID: 3938:1032 
           Device-2: 1-1.3:6 info: HP Elite Keyboard type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
           speed: 1.5 Mb/s chip ID: 03f0:034a 
           Device-3: 1-6:3 info: Lite-On Integrated Camera type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
           chip ID: 04ca:7070 
           Device-4: 1-14:5 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: Bluetooth driver: btusb interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aaa 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 2-1:2 info: Realtek 4-Port USB 3.0 Hub ports: 2 rev: 3.1 speed: 5 Gb/s chip ID: 0bda:0409 
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A gpu: nvidia temp: 48 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 327 Uptime: 31m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1677 pacman: 1669 lib: 438 
           flatpak: 8 Shell: Zsh v: 5.8 default: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

Having the same problem after sleep and additionally I frequently loose sound after which I have to fiddle with pulse ro get it back. Unfortunately the 1 October update didn’t fix anything.

I’m also on the nvidia 450 drivers and the 5.8.11-1 kernel, Qt5.15 and Plasma 5.19

I have followed up on various suggestions that I came across but zero results so far.

I found this thread with a similar problem. I also get the Black bar on settings when resuming from suspend, but unlike that thread, going back to the 440 drivers didn’t solve the issue.

I’m on the 440 series pure nVidia, no Intel and don’t have any of these issues…

Also, what are your nVidia OpenGL settings?

2020-10-04_16-58

They are identical to yours, except the G-Sync part

Edit: Also, If it makes any difference, I switched from using bumblebee to optimus manager when I updated to the 440 drivers.

1 Like