RX Vega 64 only supports MPEG2

I am trying to get video acceleration working in Firefox, but about:support shows that my hardware doesn’t support any hardware acceleration what so ever.

My system
Manjaro Linux x86_64 with 6.5.5-1-MANJARO kernel
Plasma 5.27.8 Wayland session
AMD Ryzen 5 3600
16 GB of ram
AMD ATI Radeon RX Vega 64

According to Archlinux wiki’s Hardware video acceleration page, the Vega 64 should support h264, h265 and AV1, but when I run vainfo I get

$ vainfo
Trying display: wayland
vainfo: VA-API version: 1.20 (libva 2.20.0)
vainfo: Driver version: Mesa Gallium driver 23.1.8-manjaro1.1 for AMD Radeon RX Vega (vega10, LLVM 16.0.6, DRM 3.54, 6.5.5-1-MANJARO)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc

As far as I know, my hardware is not broken. I have installed all the relevant packages and my system is fully upgraded. Please ask for more info, I do not know what is relevant here.

This is expected since Manjaro, unlike Arch, does not support hardware acceleration for most video codecs on AMD.



That page explained nothing. What is it?

If you use the search function of the forum you will find a lot of other threads.

See the “Notable Package Updates” section in the first post.

Welcome to the forum. I can help with that:

Enjoy your visit. Cheers.

Thank you all for your replies. That is a really unfortunate state of things, but I do understand. I believe my problem is then solved. (Well, resolved)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.