| SSL certificate problem: certificate has expired

Hello! I was a Windows user but wanted to change my OS and I got recommended Manjaro from a friend. I’m new in this type of systems.
I tried to update the system before I could make some changes on it but the Konsole shows me an error called: SSL certificate problem. Apparently it’s expired and can’t retrieve files: core.db, extra.db and community.db, how can I fix this? Thanks

You used an installation medium more than a month old. If you just installed/booted for the first time, it will be easier (for you and us) to reinstall using the newest manjaro image.
Otherwise, you have to search the wiki for “resolving errors about keys” and then search the forum/wiki about how to deal with .pacnew files and change the community repo…

Wow. I downloaded the ISO image from the official site just 2 days ago but yesterday I installed the OS.

Well yeah, the iso from the webpage is manjaro-kde-22.1.3-230529-linux61.iso… It’s from may. :open_mouth:
I just took kde, no idea about the others though.

I just downloaded the latest kde iso, and it still contains the community repo in pacman.conf.

@iGazs I’m sorry you got this reaction in the forum on your first post!!

Let me welcome you to Manjaro, hope you stay!

You have the latest iso from the website, but they are apparently old as well if the repos are actually copied from there and not created from online, I simply don’t know.

I know there are newer isos at Releases · manjaro/release-review · GitHub but should that really be nessesary here??

1 Like

I didn’t mean to be rude but it’s a bit stupid that the first experience is “how to fix it, because it’s broken (out of the box :man_facepalming:)”.
On the other hand, if you want the crash course on fixing manjaro, go for it.



@ Manjaro Team: one should have tought of putting new iso-s on the site, after merging community repo and after the key expiration at the beginning of July. Broken out of the box isn’t a good onboarding for beginners. Maybe point the links in the download page of the site to automatically point at the latest release here - Releases · manjaro/release-review · GitHub , but then not split the is into smaller bits. Or maybe github won’t allow such traffic… maybe some automated script to upload the latest release from github to the CDN every few days.

@iGazs to be absolutely sure, you DID install it before running the update in console, or did you try to update before you installed it?

Just so we know what we are working with here so we can help you.

Thank you! I’ll try my best here hehe.

@Teo Nah, don’t worry. I wouldn’t mind solving any problems that comes to me, if so I would’ve stayed with Windows tbh.

@bedna That was after the installation but it’s solved apparently.
I saw this post (Could not read db 'community') and after using the commands that are there, apparently, the problem was solved.

Thanks, for your time!

Just for our sanity, what is the output of cat /etc/pacman.conf | tail -30

This is the output:

I thought so, you did not actually fix it, well, maybe you did but one thing you did not fix and that might come back and bite you in the behind when they actually remove the repo… Community is still there.

You need to use run pacdiff -s

But for your own sanity, I would install meld instead of using vim.

set meld as your default diffprog by adding DIFFPROG=/usr/bin/meld to /etc/environment

I specifically asked this question in following post to be able to use as reference. xD
Read the whole thread, explains almost everything about it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.