Removing nvidia-390xx-utils breaks dependency 'nvidia-utils=390.157' required by nvidia-390xx-dkms

Hello. I wanted to install proprietary nvidia drivers. But neither the settings manager nor mhwd worked. They both gave this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-390xx-utils breaks dependency 'nvidia-utils=390.157' required by nvidia-390xx-dkms
Error: pacman failed!
Error: script failed!

Can anyone help me? I tried to fix it with the similar problems but none worked.

Hi @PYL29 and welcome to the Manjaro community.

I do not have a solution to your apparent issue, however, I have some information for you, which will allow others to help more effectively.

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.


Your system information can be generated using:

inxi --admin --verbosity=8 --filter --no-host --width

Welcome to the forum! :wave:

If you already have nvidia-390xx-dkms installed, then it seems you already do.

Either way, currently, MHWD does not support DKMS modules. If you want to use the precompiled modules (linuxXX-nvidia-390xx), then first remove nvidia-390xx-dkms that you apparently installed manually. One would only need the DKMS version if one was using a third-party kernel.

Please post your system information as outline here as well as mhwd --listinstalled

Hello. When i first installed Manjaro, I used appimage that didn’t even worked so i dont know how i installed it. I didn’t touch it since i have a fine intel integrated graphics. I don’t want my system to brick so can you give me how to remove it Thanks!
Here is my mhwd --listinstalled:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

What AppImage? As far as I know, there are no drivers packaged that way and never should be.

When you paste terminal output, please format it properly as mentioned above:

Please edit :pencil2: your reply above accordingly.

EDIT: Thank you for doing that. :+1:

You also forgot the following… :wink:

oops, sorry.
Here is inxi -v8azy:

  Kernel: 6.5.13-4-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=82833e3b-955c-46b1-8232-26fad3f5a391 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland with: krunner tools: avail: budgie-screensaver
    vt: 1 dm: 1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: Manjaro
    base: Arch Linux
  Type: Laptop System: MONSTER product: ABRA A5 V20.2 v: Standard
    serial: <superuser required>
  Mobo: MONSTER model: ABRA A5 V20.2 v: Standard serial: <superuser required>
    part-nu: A5V202GM5PG5E uuid: <superuser required> UEFI: American Megatrends
    LLC. v: N.1.13MON07 date: 01/11/2024
  ID-1: BAT0 charge: 62.3 Wh (100.0%) condition: 62.3/62.3 Wh (100.0%)
    volts: 17.0 min: 15.2 model: standard type: Li-ion serial: <filter>
    status: full
  System RAM: total: 32 GiB available: 31.09 GiB used: 11.73 GiB (37.7%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 64 GiB slots: 2 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: Controller0-ChannelA-DIMM0 type: DDR4 detail: synchronous
    size: 16 GiB speed: 3200 MT/s volts: note: check curr: 1 min: 1 max: 1
    width (bits): data: 64 total: 64 manufacturer: Samsung
    part-no: M471A2G43CB2-CWE serial: <filter>
  Device-2: Controller1-ChannelA-DIMM0 type: DDR4 detail: synchronous
    size: 16 GiB speed: 3200 MT/s volts: note: check curr: 1 min: 1 max: 1
    width (bits): data: 64 total: 64 manufacturer: Samsung
    part-no: M471A2G43CB2-CWE serial: <filter>
PCI Slots:
  Permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 13th Gen Intel Core i5-13500H bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
    microcode: 0x411C
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB L2: 9 MiB
    desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 709 high: 800 min/max: 400/4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 727 2: 629 3: 677 4: 400
    5: 712 6: 663 7: 750 8: 400 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800
    15: 800 16: 800 bogomips: 102016
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep smx split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid
    waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: Tongfang Hongkong
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:a7a0
    class-ID: 0300
  Device-2: NVIDIA AD107M [GeForce RTX 4050 Max-Q / Mobile]
    vendor: Tongfang Hongkong driver: N/A alternate: nouveau non-free: 550.xx+
    status: current (as of 2024-04) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:28a1 class-ID: 0300
  Device-3: Kingcome HD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 2b7e:b680
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (RPL-P)
    device-ID: 8086:a7a0 memory: 30.36 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 9 device: 0 type: integrated-gpu
    name: Intel Graphics (RPL-P) driver: mesa intel v: 24.0.2-manjaro1.1
    device-ID: 8086:a7a0 surfaces: xcb,xlib,wayland
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51ca class-ID: 0403
  Device-2: NVIDIA vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be
    class-ID: 0403
  Device-3: JMTek LLC. USB PnP Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-2:5 chip-ID: 0c76:161f class-ID: 0300
  API: ALSA v: k6.5.13-4-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f1 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Tongfang Hongkong RTL8111/8168/8411 driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: vpn0 state: down mac: N/A
  IP v6: <filter> virtual: stable-privacy proto kernel_ll scope: link
  Info: services: mld, NetworkManager, systemd-timesyncd, wpa_supplicant
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 289.29 GiB (30.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: solidgm model: SSDPFKNU010TZ
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 30.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 659.52 GiB size: 648.09 GiB (98.27%)
    used: 289.27 GiB (44.6%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
    label: N/A uuid: 82833e3b-955c-46b1-8232-26fad3f5a391
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.3 MiB (26.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 200B-685D
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 293.7 GiB fs: ntfs label: N/A
    uuid: ACC40EE5C40EB19E
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 547 MiB fs: ntfs label: N/A
    uuid: DEDEA4A5DEA47783
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-1:2 info: Areson Corp 2.4G Receiver type: keyboard,mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
  Device-2: 1-2:5 info: JMTek LLC. USB PnP Audio Device type: audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 0c76:161f class-ID: 0300
  Device-3: 1-5:3 info: Kingcome HD Webcam type: video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 2b7e:b680 class-ID: 0e02 serial: <filter>
  Device-4: 1-10:4 info: Intel AX201 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0026 class-ID: e001
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Packages: 2042 pm: pacman pkgs: 2020 libs: 501 tools: pamac,yay pm: flatpak
    pkgs: 22
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  CPU top: 5 of 421
  1: cpu: 40.9% command: firefox pid: 2290 mem: 562.1 MiB (1.7%)
  2: cpu: 24.2% command: firefox pid: 2639 mem: 1107.8 MiB (3.4%)
  3: cpu: 17.3% command: firefox pid: 2645 mem: 852.7 MiB (2.6%)
  4: cpu: 13.7% command: kwin_wayland pid: 955 mem: 421.0 MiB (1.3%)
  5: cpu: 7.8% command: firefox pid: 2821 mem: 152.7 MiB (0.4%)
  Memory top: 5 of 421
  1: mem: 1107.8 MiB (3.4%) command: firefox pid: 2639 cpu: 24.2%
  2: mem: 852.7 MiB (2.6%) command: firefox pid: 2645 cpu: 17.3%
  3: mem: 562.1 MiB (1.7%) command: firefox pid: 2290 cpu: 40.9%
  4: mem: 517.4 MiB (1.6%) command: plasmashell pid: 1136 cpu: 2.2%
  5: mem: 421.0 MiB (1.3%) command: kwin_wayland pid: 955 cpu: 13.7%
  Processes: 421 Power: uptime: 4h 41m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 2 hibernate: platform avail: shutdown, reboot, suspend,
    test_resume image: 12.43 GiB services: org_kde_powerdevil,upowerd
    Init: systemd v: 255 default: graphical tool: systemctl
  Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: konsole inxi: 3.3.34

Also, you’re right. It was a .run. It prompted me to stop X server. I basically gave up there.

I see from your mhwd and inxi output above, you have an Intel+NVIDIA hybrid laptop with no detected proprietary NVIDIA driver installed.

Before attempting to remove or install anything, what NVIDIA packages do you already have installed?

pacman -Qs nvidia
local/egl-wayland 2:1.1.13-1
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.5-2
    Nvidia VDPAU library
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/mhwd-nvidia 550.67-1
    MHWD module-ids for nvidia 550.67
local/mhwd-nvidia-390xx 390.157-9
    MHWD module-ids for nvidia 390.157
local/mhwd-nvidia-470xx 470.239.06-1
    MHWD module-ids for nvidia 470.239.06
local/nvidia-390xx-dkms 390.157-9
    NVIDIA drivers - module sources
local/nvidia-390xx-utils 390.157-9
    NVIDIA drivers utilities
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

Remove the DKMS package, then MHWD should be able to install the proper drivers using the video-hybrid-intel-nvidia-prime profile:

sudo pacman -Rdd nvidia-390xx-dkms

Once that finishes, then let MHWD do it’s magic:

sudo mhwd -a pci nonfree 0300

…and of course reboot after if it’s successful.

1 Like

ı think it’s a dumb repository list error(from my mistakes), but:

error: target not found: linux65-nvidia
Error: pacman failed!
Error: script failed!

The 6.5 kernel has been EOL (End Of Life) for quite awhile now and is no longer in the repos.

Do you have any other kernels installed?

mhwd-kernel --listinstalled

Please install a supported kernel if necessary. I recommend an LTS kernel like 6.6, 6.1 or 5.15. Once you’ve installed a supported kernel and rebooted into it, then remove linux65.

❯ mhwd-kernel --list
available kernels:
   * linux419
   * linux510
   * linux515
   * linux54
   * linux61
   * linux66
   * linux68
   * linux69
   * linux61-rt
   * linux66-rt
   * linux67-rt

I installed 6.6 but there is no uninstall 6.5.
mhwd-kernel --listinstalled

Currently running: 6.5.13-4-MANJARO (linux65)
The following kernels are installed in your system:
   * linux65
   * linux66

Working after restart. It’s removed.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.