Remove HDMI/DP 1 DP 2 etc from System Sound Menu?

To keep short. I have fixed my sound output and system microphone input by adding this to alsa-base.conf

options snd-hda-intel dmic_detect=1

How on earth do I disable or remove these HDMI sound output from the menu? It’s just a little clunky to have when I will never use them and get in the way of easy access of the master sound and microphone volume. Thank you.

Pulseaudio detects them as input devices? “Smart Sound Technology Audio Controller”

Smart Sound Technology Audio Controller is the built-in digital microphone array (DMIC)

if you have kernel v5.7 or later, suggest you check system with

sudo dmesg | grep snd

response will probably show a message that the option dmic_detect=1 has been deprecated

dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

If you wish to keep internal DMIC disabled, change the file /etc/modprobe.d/alsa.base.conf to this

options snd-intel-dspcfg dsp_driver=1
1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.