Microphone not working after reinstall

Hi, after I reinstalled my laptop, I had no sound, what I have fixed by adding snd_hda_intel.dmic_detect=0 to my /etc/default/grub

But the mic is not working.

inxi -Fzxxxa                                                                                                    ✔ 
System:    Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 root=UUID=815eb538-d7c1-4807-b992-6770ab70852b rw quiet splash
           apparmor=1 security=apparmor udev.log_priority=3 snd_hda_intel.dmic_detect=0
           Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.0 Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Dell G15 5510 v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: Dell model: 0983D5 v: A00 serial: <filter> UEFI: Dell v: 1.5.0 date: 07/02/2021
Battery:   ID-1: BAT0 charge: 54.9 Wh (100.0%) condition: 54.9/54.9 Wh (100.0%) volts: 12.6 min: 11.4
           model: BYD DELL DVG8M14 type: Li-poly serial: <filter> status: Full
CPU:       Info: Quad Core model: Intel Core i5-10200H bits: 64 type: MT MCP arch: Comet Lake family: 6 model-id: A5 (165)
           stepping: 2 microcode: EA cache: L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38408
           Speed: 901 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 901 2: 900 3: 900 4: 900 5: 899 6: 900 7: 900 8: 900
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9ba4 class-ID: 0300
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell driver: nvidia v: 470.63.01
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:565c
           class-ID: 0e02 serial: <filter>
           Display: x11 server: X.org 1.20.13 compositor: gnome-shell driver: loaded: modesetting,nvidia
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
           alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0401
           Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
           Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0
           class-ID: 0280
           IF: wlp0s20f3 state: down mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 3000
           bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 36.83 GiB (7.7%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 NVMe WDC 512GB size: 476.94 GiB
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 21112012
           temp: 41.9 C scheme: GPT
Partition: ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 36.83 GiB (7.9%) fs: ext4 dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
           ID-1: swap-1 type: file size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A gpu: nvidia temp: 54 C
           Fan Speeds (RPM): N/A
Info:      Processes: 282 Uptime: 9m wakeups: 1237 Memory: 7.55 GiB used: 2.04 GiB (27.1%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1223 lib: 316 flatpak: 0 Shell: Zsh v: 5.8
           running-in: gnome-terminal inxi: 3.3.08

Emm, dose the microphone work fine on win 10?

Modprobe option snd_hda_intel.dmic_detect=0 was used on earlier Linux kernels to disable the internal digital microphone array (dmic) and use legacy audio driver snd_hda_intel
But this option was deprecated and replaced last year from kernel v5.7

Remove HDMI/DP 1 DP 2 etc from System Sound Menu?

dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

But kernel v5.14 has new driver snd_sof_pci_intel_cnl that should support the internal dmic without causing problems for the other analog and digital inputs and outputs

Manjaro dual boot no sound
But disabling the dmic might no longer be necessary
Kernel v5.14 has new Sound Open Firmware drivers that should now support the internal dmic

So I would suggest you first remove the deprecated option from GRUB configuration and check if all audio, including the dmic, is working OK

If that is not working for you, use this command to add the new modprobe option to disable the dmic and revert to legacy driver snd_hda_intel

echo 'options snd-intel-dspcfg dsp_driver=1' | sudo tee -a /etc/modprobe.d/alsa-legacy.conf

System data is also showing 2 incompatible sound servers running – PulseAudio and Pipewire

See this post for how to disable PipeWire or replace PulseAudio

@kearney - the dmic has to work on the proprietary OS to support digital assistant surveillance software (C***tana)

Thank you.

I removed the snd_hda_intel.dmic_detect=0 part form grub, disabled PipeWire and created alsa-legacy.conf file with the content above.

built in speakers ok
built in mic does not show anything in the settings/audio

If I plug in a headset: speakers are ok
At the input device I see 2 options built in mic and headset mic but non of them seems to be working. The feedback line does not move when I speak and simplescreenrecorder does not record any sound.

I have no idea. Did not use windows for many years. But the hardware is fine for sure.

I pluged in an external USB Blue SnowBall mic and it is working like a charm.

The modprobe option is intended to disable the 2 internal digital microphones if the Sound Open Firmware driver snd_sof_pci_intel_cnl is not working

The Linux SOF drivers have been buggy and unreliable for about 18 months and have only been working OK for many users since the release of kernel v5.14
The current drivers only support the dmic and there is no support yet for the onboard audio processing. So microphone audio on Linux is unlikely to work very well compared to a proprietary OS that has support for audio processing

A Blue Snowball microphone will deliver better quality audio than the 2 tiny internal microphones could manage

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.