Quizas fallo en timeshift?

buenos dias a todos

Despues de esta ultima actualizacion tengo un fallo en timeshift al intentar hacer la instantanea, despues de comprobar que en modo grafico no se creaba pero si que ocupaba espacio fisico me decidi a salir a una terminal y comprobar desde alli:


[sudo] contraseña para manyaro: 

/dev/sda3 is mounted at: /run/timeshift/backup, options: rw,relatime

------------------------------------------------------------------------------
Creating new snapshot...(RSYNC)
Saving to device: /dev/sda3, mounted at path: /run/timeshift/backup
Linking from snapshot: 2022-04-16_16-28-06
Synching files with rsync...
                                          
E: rsync returned an error
E: Failed to create new snapshot
Failed to create snapshot
------------------------------------------------------------------------------
Removing snapshots (incomplete):
------------------------------------------------------------------------------
Removing '2022-05-13_15-20-38'...
                                                                                 
Removed '2022-05-13_15-20-38'
------------------------------------------------------------------------------

a alguien mas le ocurre esto?..alguna idea ?..he probado reinstalacion, desistalacion de timeshift y rsync sin resultado,tampoco funciona el paquete del AUR…algo relacionado con los permisos quizas de la particion backup?, en otro disco tengo manjaro con cinnamon y sin actualizar todavia y funciona sin problemas, algun archivo de configuracion corrupto del timeshift?

enfin…como no parece tener nadie mas el problema, en espera de averiguar que sucedio…gracias a todos por adelantado y buen dia

No uso (ni he usado nunca) Timeshift, pero te diría que el principal sospechoso para mi sería la partición backup de destino. ¿Qué permisos tiene? ¿Tiene espacio suficiente?

¿Hay algún dato más en los logs del sistema? Para ver los logs del sistema:

journalctl

resuelto por “omano” en el post de actualizaciones… gracias de todas formas y que tengas buen dia

¡Vaya! No vi la parte que decía “después de la última actualización” :smiley:

1 Like

buenos dias a todos…solo por aclarar un poco el asunto, ya que suelo leer que la degradación del paquete no es segura (no me refiero aquí, que a unos si funciona y otros no).

en el enlace: Lanzamiento de la versión 3.2.4 de Rsync

https://rsync.samba.org/

Otro lanzamiento típico con correcciones de errores y algunas mejoras. También contiene un solución de seguridad para el paquete zlib 1.2.8, que puede o no usarse en su configuración de compilación particular.

es decir esa actualización de seguridad es para ese paquete solo por lo que leo?, si es asi entonces segun:

pamac info zlib
Nombre                    : zlib
Versión                   : 1:1.2.12-2
Descripción               : Compression library implementing the deflate
                            compression method found in gzip and PKZIP
URL                       : https://www.zlib.net/
Licencias                 : custom
Repositorio               : core
Tamaño de la Instalación  : 345,7 kB
Grupos                    : --
Depende de                : glibc
Dependencias opcionales   : --
Requerido por             : binutils boost-libs btrfs-progs cairo clucene
                            cracklib curl exiv2 ffmpeg ffmpeg4.4 file freetype2
                            geoip ghostscript git glib2 gnupg gnutls handbrake
                            handbrake-cli js78 kmod lib32-zlib libarchive
                            libavif libelf libetonyek libfontenc libid3tag
                            libisofs libodfgen libpng libssh libssh2 libsynctex
                            libtar libtiff libunwind libwpd libxml2 llvm-libs
                            man-db minizip mpv neon nmap nodejs-lts-dubnium nss
                            openexr openjpeg2 openmpi openssh ostree pcre pcre2
                            protobuf python qpdf raptor rsync rtmpdump sqlite
                            squashfs-tools sudo taglib tcl thunderbird
                            webkit2gtk webkit2gtk-4.1 wget wxgtk-common
                            xapian-core zstd zziplib
Opcional para             : --
Provee                    : --
Reemplaza                 : --
Entra en conflicto con    : --
Empaquetador              : Evangelos Foutras <foutrelis@archlinux.org>
Fecha de creación         : dom 24 abr 2022 08:19:33
Fecha de instalación      : vie 13 may 2022 09:40:51
Motivo de instalación     : Instalado como dependencia para otro paquete
Validado por              : Signature
Respaldar archivos        : --
aquí

no esta afectado y si seria seguro degradar de momento?..es solo una pregunta y feliz dia Cfinnberg

aparte de eso en arch linux:(la estable actual)misma versión que nosotros, pienso que algunos aqui, usan la versión nueva por moverse en versiones de pruebas, y por eso funciona rsync alli?

in rsync say:

avsegrsync

If your rsync is configured to use the bundled zlib, you should upgrade to 3.2.4 which contains the official zlib fix for a memory corruption bug that was detailed in CVE-2018-25032. While you’re at it, be sure to update your system’s zlib.

editado:
new problem when downgrading on my other disk with manjaro cinnamon…when trying to download the package it tells me that the signatures are invalid,so just download the package and downgrade from “downloads” folder open terminal here and…

sudo pacman -U rsync-3.2.3-4-x86_64.pkg.tar.zst

:point_up:

1 Like

I was just trying to explain…read about the zlib version so you can understand me.

thank you maycne.sonahoz y feliz dia por alla

:wink:

Creo que deberías degradar a rsyn 3.2.3 sin problemas. Parece que el problema del zlib es en ocasiones muy raras.

Por otro lado, no se si el rsync de Arch/Manjaro usa el zlib del sistema o el interno, pero como digo, creo que solo afecta en situaciones muy concretas y debería funcionarte bien, como te ha funcionado hasta ahora.

1 Like

la degradacion ya estaba hecho desde el principio y funciono,comprendes?, trataba de explicar porque algunos hablan de que la degradacion es insegura y no la recomiendan…pero yo prefiero que me funcione timeshift a que no funcione.
Aparte de que el paquete que rsync dice que corrige es zlib 1.2.8version que no tenemos nosotros instalada y que ellos mismos dicen que hay que instalar conjuntamente con la version nueva de rsync " Lanzamiento de la versión 3.2.4 de Rsync"

bueno, lo dejo ya que os estoy mareando… :rofl: