Problems creating Bootable USB's for testing

I follow this simple rule of thumb: balenaEtcher for Linux isos, Rufus for Windows. Rufus always had issues with Linux isos in my experience, or was unreliable at best. You’re better off usign Etcher, never had a single problem with it, you can find it in the repos.


Hi ya omano,

thanks so much again for all your efforts but no luck still…
I managed to get Ventoy to work with several other distros but couldn’t get it to work with Manjaro…as soon as I put it on it corrupted the USB again :frowning:

ummm! sorry…I think I left out an important thing from what I’m seeing from the help I think everyone thinks I’m using a Linux distro already but no I’m on W10 still and wanting to move to Linux so testing several out of all the versions available and I’m really liking Manjaro alot but I can’t get it to install which is frustrating as I really want to use it so much…

Hi ya tralph3,

thanks for your help, got all excited as I thought balenaEtcher did the trick…but same issues again…

starting to think there is more to the issue but it’s weird that 2 different size USB’s are failing when they worked on other Linux iso’s…

I would recommend Etcher, never had a problem with it. It is available for Windows


hi ya NGr…

thanks for this…yeah it looked like Etcher was going to work but again it corrupts the usb type of thing with both USB’s showing the same info but both different sizes…


And if error is not usb but secure boot uefi ? it’s necessary to disable the secure boot with manjaro

i use a single large capacity USB stick and install ventoy.

with ventoy everything becomes easier. you have as many iso you can and simply copy them to the usb stick [from whatever environment you are… example windows / linux / mac].
boot of the usb to show up ventoy listing the iso you wish to boot off from.

i have multiple iso on single usb stick. hope this helps.
advantage is you dont need to do dd OR use rufus or any third party to created bootable usb. you just download and copy to the usb which shows up as you plugin and then reboot from that ventoy stick which lists the different ISOs

Rufus is a typical Windows tool - and the resulting USB is confusing for the vast majority of Windows users.

Mostly there is nothing wrong - but the complete lack of files - except for the EFI (4mb) partition - drive Windows users to edge of insanity - until they realize or ask like you do - the primary partition is unreadable by Windows because it is formatted using ext4.

This may be the case for you too :slight_smile:

1 Like

Have you tried booting from the USB’s you’ve made or are you just examining them in Windows?

1 Like

Did you check the downloaded Manjaro to verify that it is a clean download?

In comparison,i recommend Rufus because it is available for Windows more than Etcher.

How is it more available for Windows, I see downloads for Windows and Linux.

I have not tried Etcher, but if it is good and works well for both systems, that is a good reason to use Etcher, since you don’t need different software for Windows and Manjaro.

Listing 2 methods for creating manjaro bootable usb I found here.
Rufus is powerful, so you might as well try it again. If you still fail, you can try another method below (UUByte LiteBoot). It has received a lot of praise from customers.

Hi CryptoA,

I would suggest to try dd in a terminal. (I understand you are working in window$, so perhaps ask somebody with a GNU/Linux distro that let you run the command below, the whole process takes less than 10min I think; or maybe look for a power$hell alternative -I believe there is one, but never tried it-. Proceed with care if you try this in someone else’s machine.)

I recently had the same problem and eventually followed the instructions in the wiki for Burn an ISO file, using the command line. The command is the following:
$ sudo dd bs=4M if=manjaro-gnome-20.1.2-201019-linux58.iso of=/dev/sdY status=progress oflag=sync
(“Y” in /dev/sdY stands for the particular device assigned to the USB stick… see the wiki for details). After a few attempts I realized I was trying to use a partition of the USB stick in the command above instead of the device (I was using something like /dev/sdc1 instead of /dev/sdc). That was causing the same problem you describe. Once I specified the device (and not a partition) it worked just fine.

I hope this comment is helpful. Cheers,


I have the same issue. I tried different ways. I used Rufus, Etcher, and Linux command line method. Nothing worked. I tried with the GNOME version and XFCE. Tried with another USB drive. I couldn’t do it. :worried: :worried:I am disappointed with it.


Hello @datiswous,

I made a separate Question for my problem

The actual problem was the bootable USB. I had not disabled the Secure Boot of my laptop. That’s why I could not boot my laptop with Manjaro bootable USB.

Thank you.

1 Like

Anyone tried Win32diskimager to install Manjaro; not sure it works or not?

The only way of creating a bootable USB with Manjaro ISO is one of the following options

  1. Using dd on any GNU/Linux distribution
  2. Using Popsicle on any GNU/Linux distribution
  3. Using Rufus on Windows
  4. Using Etcher on Windows Or Linux

No matter your choice the important thing to know is

  • Manjaro ISO is a ISO9660 filesystem with embedded boot
  • Manjaro ISO must be written one-to-one on the target medium
  • Manjaro ISO must be written as-is to the medium - with no alteration what-so-ever
  • Manjaro ISO cannot be unpacked and the content written to a bootable USB
  • Manjaro ISO cannot be unpacked and written to a Windows Formatted USB stick