Problems creating Bootable USB's for testing

Hi ya,

I was hoping somebody could help with an issue I’m having with making bootable Manjaro versions for testing please?..
I’ve made other bootable versions of Linux and never had these issues before so a little confused on what to do next…

I’m using Rufus to create the bootable versions and every time I create them the USB seems to get corrupted and I reset it again and try again and the same problem repeats…

Set up the USB’s 3 different times for each with both ISO’s on a 8GB and a 16GB usb’s….every time I create them it converts both usb’s to the same size of a 4GB USB (though it says 3.82MB free of 3.97MB after conversion)…

The ISO’s downloaded are both from the main site, used both Normal download and Torrent download but both having the same issues…

The 2 ISO downloads are: manjaro-kde-20.1-200911-linux58.iso and manjaro-gnome-20.1-200911-linux58.iso …

If someone could help please it would be much appreciated…


Follow the official instructions. Manjaro - First Steps

Use DD as copy option in Rufus, or else you will not be able to boot and will have a terminal console instead, I think with Grub error.

Wiki says to use Ventoy to make a USB bootable though.

1 Like

I have used the program that is installed, the suse based one and never had a issue with creating bootable usb’s. It easy and does the job.


Hi ya omano, yawanathan,

Thank you both for your help much appreciated :slight_smile:

Sorry not very computer literate but…
omano is DD is that direct download from Manjaro site, if so tried that but no luck as giving the same issue…
yawanathan what is “used the program that is installed, the suse based one”
Sorry guys if both are silly basic questions :frowning:

Thank you both for your help

And for me ventoy is the best : only copy .iso files in “ventoy” usb
is in manjaro repo; install with pacman/pamac and create usb “ventoy -i ...” (-g for uefi)


Thanks papajoke

will give that a try as omano mentioned above also so hopefully that will work :slight_smile:


No, DD is literally an option at the moment you create your USB bootable key within Rufus.
If you don’t see the DD option for the copy in Rufus, either because you don’t find it or because it is removed now, then don’t waste your time use Ventoy.

Also this one (Suse Image Writer) works great, drop the iso, select your USB and go :slight_smile:

//EDIT: also I found this DD mode gone in version 3? · Issue #1148 · pbatard/rufus · GitHub


for ventoy & gpt this is
“sudo ventoy -i -g /dev/sdX”


I follow this simple rule of thumb: balenaEtcher for Linux isos, Rufus for Windows. Rufus always had issues with Linux isos in my experience, or was unreliable at best. You’re better off usign Etcher, never had a single problem with it, you can find it in the repos.


Hi ya omano,

thanks so much again for all your efforts but no luck still…
I managed to get Ventoy to work with several other distros but couldn’t get it to work with Manjaro…as soon as I put it on it corrupted the USB again :frowning:

ummm! sorry…I think I left out an important thing from what I’m seeing from the help I think everyone thinks I’m using a Linux distro already but no I’m on W10 still and wanting to move to Linux so testing several out of all the versions available and I’m really liking Manjaro alot but I can’t get it to install which is frustrating as I really want to use it so much…

Hi ya tralph3,

thanks for your help, got all excited as I thought balenaEtcher did the trick…but same issues again…

starting to think there is more to the issue but it’s weird that 2 different size USB’s are failing when they worked on other Linux iso’s…

I would recommend Etcher, never had a problem with it. It is available for Windows


hi ya NGr…

thanks for this…yeah it looked like Etcher was going to work but again it corrupts the usb type of thing with both USB’s showing the same info but both different sizes…


And if error is not usb but secure boot uefi ? it’s necessary to disable the secure boot with manjaro

i use a single large capacity USB stick and install ventoy.

with ventoy everything becomes easier. you have as many iso you can and simply copy them to the usb stick [from whatever environment you are… example windows / linux / mac].
boot of the usb to show up ventoy listing the iso you wish to boot off from.

i have multiple iso on single usb stick. hope this helps.
advantage is you dont need to do dd OR use rufus or any third party to created bootable usb. you just download and copy to the usb which shows up as you plugin and then reboot from that ventoy stick which lists the different ISOs

Rufus is a typical Windows tool - and the resulting USB is confusing for the vast majority of Windows users.

Mostly there is nothing wrong - but the complete lack of files - except for the EFI (4mb) partition - drive Windows users to edge of insanity - until they realize or ask like you do - the primary partition is unreadable by Windows because it is formatted using ext4.

This may be the case for you too :slight_smile:

1 Like

Have you tried booting from the USB’s you’ve made or are you just examining them in Windows?

1 Like

Did you check the downloaded Manjaro to verify that it is a clean download?

In comparison,i recommend Rufus because it is available for Windows more than Etcher.

How is it more available for Windows, I see downloads for Windows and Linux.

I have not tried Etcher, but if it is good and works well for both systems, that is a good reason to use Etcher, since you don’t need different software for Windows and Manjaro.