Make a bootable USB with Manjaro


I am trying to make a bootable USB with Manjaro XFCE. I tried several times. couldn’t do it yet.

I used Rufus, Etcher, and Terminal(sudo dd bs=4M if=/path/to/manjaro.iso of=/dev/sd[drive letter] status=progress oflag=sync). I tried with GNOME iso file too. I also tried with a different USB. What can be the problem?

Thank you.


Use imagewriter from repos and make sure your downloaded ISO is not corrupted.

Maybe your stick or USB port are too slow. In this case you need to reduce the block size.

Thank you. Iso file seems good. (checksum(sha1sum) for my downloaded iso file is 8a356d8eea25bce25d381c8d79fa9fc7a71142fd. That is exactly the same value here: Manjaro - XFCE)

Quite hard to imagine what is not working: is the making of the USB media? Booting from it at all from BIOS, it gets stuck after grub menu?
Make sure you connect it to a USB2 port when booting from it.

You can try also ventoy from repos, and once you create the USB with it you just copy whatever ISO there and should be available in the ventoy menu at boot.
See more about it here Ventoy

Thank you.

used bs=1M

I get 8a356d8eea25bce25d381c8d79fa9fc7a71142fd. for the checksum. It is correct with the manjaro website

Still, it doesn’t work.

A few days ago, I successfully used the same USB port to boot ubuntu 20.04.

I tried Manjaro USB with another laptop too. Not working. :worried:

What exactly is the issue, what is not working? You never described it in detail.

This is the problem: My Manjaro bootable USB doesn’t boot my laptop.

I plug this Manjao bootable USB to my laptop. I restart it, press F1, go to the Boot menu, and select this USB. I want to boot my laptop with Manjaro, but it doesn’t. As usual, it boots with Ubuntu 18.04 which is my current OS.

A few days ago, I made a Ubuntu 20.04 bootable USB and I could boot my laptop Ubuntu 20.04. I used the same steps as I do with Manjaro. Therefore, I think the problem is in my Manjaro bootable USB.

What does this mean, blank screen, error messages, nothing happening at all? The more precise you explain your issue the more likely we can help you. Just to say it does not work is useless…

Are you on Windows, on Ubuntu, Debian, Mint, or Vista and older?

1 Like

I use Ubuntu 18.04 64. Thank you

You are right. I should explain it well. Thank you.

First of all I want to tell that my guess was wrong. Bootable Manjaro USB works. I could boot another computer from it.

I am going to explain everything again to give you a clear idea about what happened.

I have Thinkpad E490s laptop. (Core i5-8265U CPU, 8Gb memory, 512GB SSD) Currently, It has Ubuntu 18.04.05 64bit operating system. THE original OS was a Windows 10. Later I installed Ubuntu 18.04 alongside Windows. After a few months, I erased Windows and now it has only Ubuntu 18.04.05. The laptop hard disc has 3 partitions other than Ubuntu installed partition(4 partitions total).

I want to install Manjaro. I made a bootable Manjaro USB, plugged it to my laptop, restarted my laptop, pressed F1, went to the boot order menu, moved the USB to the top, and waited.

Laptop didn’t boot with Manjaro, It came to the grub boot loader of Ubuntu 18.04 and did boot with my existing Ubuntu 18.04. Nothing happened at all due to Manjaro. No error message, nothing unusual compare to a normal TURN ON process of my laptop. Looks like my laptop doesn’t recognize Manjaro USB as a bootable media. That is the problem.

I tried exactly the above process with a bootable Ubuntu 20.04 USB. My laptop did boot with Ubuntu 20.04. It came to the grub boot loader of Ubuntu 20.04 and did boot with Ubuntu 20.04 bootable USB.

Then I guessed my problem as a problem of bootable Manjaro USB and made this question on this forum. I thank everybody for spending valuable time on my problem.

Today morning I tested Manjaro USB with another computer and it did boot that computer with Manjaro. So I conclude, it is not a problem of Manjaro bootable USB. The problem is in between my laptop and Manjaro USB.

I should also say this. I tested this Manjaro USB with another laptop(Thinkpad T14 gen1, windows and Ubuntu 20.04 dual boot) yesterday. That laptop doesn’t have a list to select boot order. I had to select the desired bootable media with the mouse pointer. When I select Manjaro USB, It goes to a totally black screen and quickly goes back to the previous menu(the place where I have to select a bootable media). I clicked Manjaro USB a couple of times. I could not see anything except a totaly black screen. It goes back to the previous menu within a second and let me select a bootble media.

I can summarize my problem as follows,


  1. My laptop recognizes other Linux bootable USBs (I tested Ubuntu 20.04)
  2. My Manjaro bootable USB is recognized by another computer

Problem: My laptop doesn’t recognize Manjaro bootable USB

Others managed to boot and install on such machines

What ISO are you using?

Might need a custom kernel boot parameter.
See here:

First of all thank you for the detailed description @DulithaJaya.

Is Secure Boot disabled in your firmware? Ubuntu does not have a problem with Secure Boot but Manjaro does. It must be disabled.

1 Like

You’ve already tried UNETBootin’? You can also try: Dual booting WIndows and install manjaro with rufus, or making a VM that, is possible to conect with your actual Pen drive with windows 7 x32 bits, or, x64… Actually it needs WIndows 7 and up

Thank you so much @Wollie . That was the exact reason.

This is what I did. I pressed F1 at the start and went to the Security menu. Then Under Secure Boot, I had the option to select “Enable” or “Disable” the Secure Boot. It was selected as “Enable”. I changed it to “Disable”.

It solved my problem. I could boot my Thinkpad E490s from my Manjaro bootable USB.

Thank you again. :slightly_smiling_face:


Thank you @bogdancovaciu valuable suggestions. I could fix my problem by disabling Secure Boot as @Wollie suggested. Thank you for your help.

Thank you @NicoBR333. Actually, the problem was not the bootable USB. It was my wrong guess. I had not disabled Secure Boot. That’s why my laptop didn’t boot with the Manjaro bootable USB. Thanks.

Oh, I forgot to say about that… I had the same problem one day, but the problem was that I needed to make secure boot to ON and OFF, every time I make a linux installation when I switch from Windows