Problems after update

Are you using a certain theme?

Breath Dark, which I believe is a default theme.

I dont know what this means.

The little UI tool for kernel updates is gone! I have to do it from the commandline now.

pacman says “There is nothing to do”, so I assume it up-to-date. Interestingly, I do not have the pacdiff command.

My foreign packages are just some stuff I installed that should be fine:

1password 8.10.6-27
clang15 15.0.7-2
compiler-rt15 15.0.7-1
coz 0.2.2-2
khotkeys 5.27.11-1
khtml 5.115.0-1
kjs 5.115.0-1
kpeoplevcard 0.1-2
kquickcharts5 5.115.0-1
krunner5 5.115.0-1
lib32-libwrap 7.6.31-4
libsidplay 1.36.59-10
libwrap 7.6.31-4
llvm15-libs 15.0.7-1
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
manjaro-hotfixes 2024.1-2
ncurses5-compat-libs 6.3-1
noto-fonts-compat 20151217-1
plasma-simplemenu 1.0.12-1
pyside2 5.15.12-1
pyside2-tools 5.15.12-1
python-manjaro-sdk 1:0.1.1-1
python-pep517 0.13.0-1
python-shiboken2 5.15.12-1
systemd-fsck-silent 239-1
systemd-kcm 1.2.1-8
tracy 0.9.1-1
unityhub 3.3.0-2
web-installer-url-handler 2.3-1
webots-bin 2023b-1
whatsdesk-bin 0.3.9-2
zoom 5.17.5-1

There are no breath icon themes in the repos that I can find.
Plasma6 icon theme handles icons everywhere, including what was previously provided by the desktop theme.
Please select a compatible and up to date icon theme.
Breeze is the plasma default. I use papirus.
Or more specifically my fork.

Do you mean pamac or manjaro-settings-manager ?
Or maybe pamac-tray-icon-plasma ?

It was split from pacman into pacman-contrib. Install the package for pacdiff.

A bunch of deprecated plasma5 stuff.

Again deprecated packages you should not have

There may be more. But those stood out.

I am try some of the other stuff you mentioned still, but regarding:

Do you mean pamac or manjaro-settings-manager ?
Or maybe pamac-tray-icon-plasma ?

I mean I used to update my kernel by using the GUI tool that came with Manjaro (at least up until this update). It showed which kernels were installed and which one was active in a GUI. Manjaro still notifies my that “a unsupported kernel is installed on your system”, but I cannot remove it without resorting to the commandline now. If it was removed on purpose, then disregard, but I feel like it should still be there.

The notifier is just the notifier.
mhwd-kernel is what is handling the kernel install or removal in any case.
The GUI frontend for that is manjaro-settings-manager.

Also note that the terminology can be tricky … you arent ‘updating’ your kernel there.
You install a series (like 6.6) or remove a series (like 6.4).
But the updating is done along with all packages, as with anything else, while using pacman or pamac.

So you are saying MSM does not work for you?

Hold on, I found it by navigating manjaro-settings-manager. I guess what confused me is that it no longer appears when I just type in “kernel” in the Plasma home search bar thing.

Thats just a quirk of what terms are attached.
And/or there is also the fact that System Settings was reworked in plasma6.
Which also lost the MSM kcm (like a plugin) for SystemSettings, that would previously have conveniently allowed for interaction with MSM there in a subwindow, much like how you choose your themes.
You may have previously been searching/starting the kcm, which is no longer present.

Extra note:
I dont know if there are plans to rewrite the MSM kcm for Plasma 6.

Alright, thanks for the help! I removed the old packages you mentioned just in case. I am still working through some settings and investigating the zsh konsole issue, I’ll let you know if I get it working.

Sure thing.
I use bash so I am less helpful with whatever the zsh implementation is.
But do check your profile and/or the default one (which is read-only, so it should be somewhat resilient).

Think of Plasma 6 upgrade as the next best thing to a complete reinstall.

Clean it up.

I’m using Breeze-Round-Chameleon icons… and they look great :wink:

The problems and issues upgrading to Plasma 6 are less about KDE being a mess (and boy, did we have fun with some of the Plasma 5 updates last year) but about $USER data.

It took me a week to iron out issues with my config - deleting stuff and re-importing some stuff from snapshots.

No, only Breeze theme and icons are fully supported by KDE, try with a new clean user account.

@cscs: ok, I did what you suggested, but … got error for “kbuildsycoca6 --noincremental”.
WiFi is still not possible/available.
Kernel update GUI doesn’t work (I read that someone changed the kernel and that fixed it for them).

Any further suggestions are much appreciated.

Really? Are you sure?
Or is it the same as … well … just a few posts above you?

So … are you actually saying MSM does not work?
Or just that you cannot find it in System Settings (expected)?

I guess I just cannot post any of these links too many times. So heres another one

You need to install or use a font that has “Nerd” in its name, like Noto Sans Mono Nerd.

As for the icons, switch to a different icon theme and back, and then hover the mouse over the “missing” icons. They will reappear. However, be advised that this is a bug in Plasma 6.0.x, and that you’ll have to do this again every time you log in.


I dont have to do this. So it makes me wonder about the status of the systems experiencing it (or the resources they are using).

Then again. I also have a pretty sparse panel with only a few system tray icons.

If its a known bug please share the linkies.

1 Like

I don’t know whether it’s a known bug, but I believe that it would definitely be a bug, given that it’s reproducible, and always with the same icon — specifically, the notifications icon.

Originally, it also happened with a few other icons — widgets on my top panel — but at present time it’s only the notifications icon anymore than looks odd — just a generic 2D-ish “file” icon — until I repeat the steps as I outlined them above.

I also do have a problem that I cannot seem to fix with the look of the trashcan icon on my lower panel. It’s not the normal stylish macOS-like 3D icon anymore, but just a sketchy monochrome 2D icon now. :man_shrugging:

It’s also not related to the Plasma style, by the way. It looks the same in the upstream-supplied Breeze style.

Are you sure its not the icon theme?
I really do not have this issue.

(I use these: MACE / Icons / Papirus Mace Icon Theme · GitLab)

Of course not. Most everything comes from the icon theme now in plasma6.
Icons that previously sourced from your desktop theme (like on the panel) are sourced from your selected icon theme.

1 Like

Yes, because it’s the same icon theme as I was using before. I am using the WhiteSur icon theme.

How does that matter?
Icons and paths changed in Plasma6.

Looking at the source…I am not sure. Looks kinda old with some minor updates last month or so.

Compare to something like upstream papirus, and note the explicit plasma6 changes…

1 Like

I did not install it from the AUR, but only within my home directory, so it should be using the paths where knewstuff puts it. :man_shrugging:

No … I mean like … theres a whole new paradigm for calling *-symbolic for example.
A number of previously used names/paths are different now for various things.

Also installing in home can have unintended consequences like SDDM not being able to source them.