Panel icons disappears after hovering

I am using live usb and with properitery hardwares. when I gone on bottom pannel to click the firefox button, it disappered, but the button was actually there so on clicking firefox opened. Similarly happed with other icons in the panel and the application menu. The button exists and clickable, but icon is not visible

# dmesg | grep -i nvidia
[   16.784023] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/in
[   16.784082] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input16
[   16.784140] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/in
[   16.784204] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input18
[   56.394030] nvidia: loading out-of-tree module taints kernel.
[   56.394038] nvidia: module license 'NVIDIA' taints kernel.
[   56.409420] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   56.702995] nvidia-nvlink: Nvlink Core is being initialized, major device number 509
[   56.703925] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[   56.704091] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[   56.747474] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  525.85.05  Sat Jan 14 00:49:50 UTC 2023
[   56.822518] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  525.85.05  Sat Ja
n 14 00:40:03 UTC 2023
[   56.872978] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   56.872996] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
inxi -Fazzy                                                                                    ✔️  System:
  Kernel: 6.1.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDEM_2201 quiet
    systemd.show_status=1 splash driver=nonfree nouveau.modeset=0
    i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM

    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX505GT v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX505GT.311 date: 02/08/2021
  ID-1: BAT0 charge: 32.4 Wh (97.9%) condition: 33.1/48.1 Wh (68.9%)
    volts: 12.3 min: 11.7 model: Simplo SDI ICR18650 type: Li-ion
    serial: <filter> status: not charging cycles: 41
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2450 high: 2600 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2600 2: 800 3: 2600
    4: 2600 5: 2600 6: 2600 7: 2600 8: 2600 9: 2600 10: 2600 11: 2600 12: 2600
    bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:3e9b
    class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 525.85.05 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1f91
    class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-11:2 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-1-0 pos: right res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: eDP-1 pos: primary,left res: 1920x1080 hz: 120 dpi: 142
    size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: Mesa Intel UHD Graphics 630 (CFL
    GT2) direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver:
snd_hda_intel v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound API: ALSA v: k6.1.7-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.64 running: no
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.4 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200V MTFDHBA512TCK
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s

    lanes: 4 type: SSD serial: <filter> rev: P1MA0V4 temp: 24.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-11Z10T0
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A01 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: HP model: x740w
    size: 28.88 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 44.0 C pch: 44.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2400
  Processes: 273 Uptime: 3m wakeups: 7802 Memory: 15.48 GiB
  used: 3.4 GiB (22.0%) Init: systemd v: 252 default: graphical tool: systemctl
  Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman pkgs: 1103
  libs: 308 tools: pamac Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.24

In the live session of GRUB, before booting, press e to edit the kernel boot line, and right after quiet add the ibt=off and then press F10 to save and continue booting. If that will improve the desktop experience, then you will have to add that same kernel boot parameter to your installed system.


It dint work out for me. also tried with open source drivers. The best I can do right now is to use gnome version. KDE never worked for me with manjaro on my hardware (actually kde works, I am currently using kubuntu).

I have same trouble nvidia+intel gpu in X11 sesion

Now your have 4 “solution”

  1. Choose main and external monitor same framerate


  1. Downgrade kscreen and libkscreen to 5.25.5<= or Install Plasma LTSC ( include kscreen and libkscreen to 5.25.1<= )
sudo DOWNGRADE_FROM_ALA=1 downgrade kscreen libkscreen

affter reboot add kscreen libkscreen to ignore update

  1. Not per-moment - When your log on in plasma, try to upload new desktop wallper, after refresh all to be normal ( after logout, need do it again )

  2. Change session to Plasma Wayland.


sudo pacman -S plasma-wayland-session

Log out and choose plasma (wayland)

Why this happens?

It only occurs on X11 when connecting an external monitor with a different framerate. When forcing the main monitor to match the external one’s framerate, the problem disappears. The problem also disappears when using Wayland so that’s what I’ve done now.

Thanks, for the solution. but I need a solution to test this in live. I will only install KDE (which I want to do, currenly compromising with Gnome) if I can find the fix for this.
Also I checked when I tried booting ISO in the virtual box it is working fine but causing problem when I tried live usb. It is not clear to me

The easiest way to fix it:

  1. Go to system settings \display and monitor \ set same Refresh rate to all monitor
  2. use KDE Wayland

The next two more complicated options are
3.Downgrade kscreen and libkscreen to 5.25.5<= and ignore update
4.install optimus-manager and switch gpu to nvidia \ intel only

5.When your log on in plasma, try to upload new desktop wallper, after refresh all to be normal ( after logout, need do it again ) :grinning:

I will try in different system, not the main. But thankx

The same issue here today. :confused:

Can you try this fix for me? Panel icons disappears after hovering - #4 by AspidovSS

Let me know if it fixes, I will change to KDE

Go to system settings \display and monitor \ set same Refresh rate to all monitor and restart your pc

The refresh rates in primary monitor are: {120.04, 59.97, 59.96, 59.93, 48.1} and secondary monitor are {75, 60, 59.94, 50}

which one do you recommend, bold ones are curently selected

Your need force setting in config.

  1. In NVIDIA XServer Settings, disable OpenGL flipping, then set ForceCompositionPipeline=On for both displays (Display Configuration → Advanced… will need to save to configuration file).
  2. open Kosnsole and show xrandr

enter same
xrandr --output DP-1 --mode 1920x1080 --rate 60
or config your xorg.conf

1 Like

Where I can find these settings

$ find / -iname xorg.conf 2> /dev/null
# returns nothing

Also, currently I am running gnome I tried changing to plasma from greeter session, but my display is freezing so had to fallback to the gnome for now. Can i do the changes (except xrandr) using gnome.

So what I found is when I boot the system with external monitor attached, this issue happens. But when I attach the external monitor after login through sddm greeter, it works even I have different refresh rates of the monitors

1 Like