Pamac shows there is an update, but does not update it

When I check for updates in pamac, it shows that there is an update for openblas-cblas-git. But it does not actually update it. I tried using yay to update it from the terminal but it did not work. And somehow it is causing trouble when I am trying to install Julia.
What should I do?

julia requires openblas which conflicts with openblas-cblas-git from AUR. Remove the AUR package if you want to install julia. Also that package is on version 1-1 and there haven’t been any updates to it ever.


Arch Linux - julia 2:1.7.2-1 (x86_64)

AUR (en) - openblas-cblas-git

What does happen from the terminal?

pamac update -a

When I try to remove openblas-cblas-git , it says it fails to remove it because of a lot of dependencies. Should I try to force remove it?

Yes. Do yay -Rdd openblas-cblas-git and then try to install julia.

It may be better to replace it with openblas. The following should ask you to uninstall the conflicting package, thus keeping the dependency for other packages:

sudo pacman -S openblas
1 Like

I initially tried doing that. pacman asked me if I want to remove the openblas-cblas-git. I said yes. But then it refused to do that! I then deleted openblas-cblas-git using the -Rdd option.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.