Pamac practically unusable after latest upgrade

It is difficult to say - but yes there is something else in play.

It appears you are not using a default Manjaro system.

You have customized your system and then any attempt to troubleshoot is very difficult.

Maybe you are using deepin? which makes it harder as deepin has been notoriously difficult.

I’m on gnome. the deepin packages you see are related to deepin-wine, a fork of ordinary wine.
Are there any pamac logs I can look into? It appears this is not an isolated issue as two of my systems are showing the same problem.

Also this problem only started to pop up following the most recent pamac update. Maybe the culprit might be in something that was changed in the new version? :thinking:

is a problem with only one aur package ? in pamac you can view where pamac “stop”

And you can also use yay “only for aur” : yay -Sua

It has nothing to do with any particular aur package. the problem is that searching for updates (with aur updates enabled) in pamac causes the app to load to 90% before hanging indefinitely. Pamac becomes unresponsive and often the only way to stop it is with taskkill. In fact this occurs even when pacman and yay tell me no updates are available.

From my side it appears that yay is operating normally, not sure if this is an issue with pamac or the aur.

I missed something:
how everybody decided that the user has latest pamac and libpamac versions
how the case was recognized/categorized/classified as version-independent.

Do you have any problems if you check for AUR updates with pamac in CLI ?

pamac update --aur

Okay I’ve noticed several interesting things.
Pamac CLI works with no problems:

Cloning nordic-polar-theme-git build files...
Generating nordic-polar-theme-git information...
Checking nordic-polar-theme-git dependencies...
Cloning adapta-gtk-theme-colorpack-joshaby-git build files...
Generating adapta-gtk-theme-colorpack-joshaby-git information...
Checking adapta-gtk-theme-colorpack-joshaby-git dependencies...
Checking google-chrome dependencies...
Cloning highway-git build files...
Generating highway-git information...
Checking highway-git dependencies...
Checking visual-studio-code-bin dependencies...
Synchronizing package databases...
Warning: gnome-shell-extension-nightthemeswitcher: local (52-1) is newer than community (51-2)
Warning: manjaro-hello: local (0.6.7-2) is newer than extra (0.6.6-9)
Resolving dependencies...
Checking inter-conflicts...

To build (5):
  adapta-gtk-theme-colorpack-joshaby-git  1.202101191000.r3.g942015c-1  (1.202101191000.r1.g54837dc-1)  AUR
  google-chrome                           95.0.4638.54-1                (94.0.4606.81-1)                AUR
  highway-git                             0.14.2.r48.gc90067e-1         (0.14.2.r42.g79126ad-1)         AUR
  nordic-polar-theme-git                  v1.9.0.r38.gdb4a671-1         (v1.9.0.r37.g24ef67c-1)         AUR
  visual-studio-code-bin                  1.61.2-1                      (1.61.1-1)                      AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] 

These packages are also reflected in the pamac update indicator extension.

clicking into pamac to actually check the updates though causes it to hang at this screen:

yay, on the other hand, tells me I only have two updates instead of five:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: gnome-shell-extension-nightthemeswitcher: local (52-1) is newer than community (51-2)
warning: manjaro-hello: local (0.6.7-2) is newer than extra (0.6.6-9)
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 -> gnome-shell-extension-nightthemeswitcher: local (52-1) is newer than community (51-2)
 -> manjaro-hello: local (0.6.7-2) is newer than extra (0.6.6-9)
 -> cpu-x: local (4.2.0.r179.gadaba75-1) is newer than AUR (4.2.0-1)
 -> libcpuid: local (0.5.1.r10.g7a580fd-1) is newer than AUR (0.5.1-1)
 -> python2-decorator: local (4.4.2-3) is newer than AUR (4.4.2-1)
 -> python2-gobject2: local (2.28.7-7) is newer than AUR (2.28.7-6)
 -> python2-pickleshare: local (0.7.5-5) is newer than AUR (0.7.5-1)
 -> Missing AUR Packages:  gnome-getting-started-docs  gnome-shell-extension-nightshellswitcher  js60  lib32-libnm-glib  libnm-glib  libopenaptx  linux-latest  linux-latest-virtualbox-host-modules  plank-theme-numix
 -> Orphaned AUR Packages:  deepin-wine-helper-full  ipython2  python2-backports.shutil_get_terminal_size  python2-pathlib  python2-prompt_toolkit1  python2-traitlets
 -> Flagged Out Of Date AUR Packages:  pop-gtk-theme
:: 2 Packages to upgrade.
2  aur/google-chrome           94.0.4606.81-1 -> 95.0.4638.54-1
1  aur/visual-studio-code-bin  1.61.1-1       -> 1.61.2-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)

So now we have two problems: pamac gui stalling and yay disagreeing with pamac CLI. Coincidence?
EDIT: on my other device disabling dev package update checks in pamac gui causes pamac cli to report I have two aur updates, but disabling it causes it to report none.
Now I’m really confused…someone please help. :tired_face:


Pamac is re-downloading sources for each -git package when you search for updates. That can be terribly slow if you have many -git packages.

Do not use yay and pamac for -git package updates at the same time. yay has it’s internal database to store -git package metadata.

1 Like

say that 50% of my aur packages were installed through pamac and 50% were through yay. How do I correctly update?

Github commit for pamac shows function of checking AUR for updates in pamac-manager GUI has been removed

But pamac CLI is working with no problems for me too, so there is a workaround for no GUI updates

I don’t use yay but it appears to be unable to see updates for *.git packages in AUR

EDIT for post#16: I would consider using either pamac or yay for 100% of AUR updates would be
better than using both

Not sure if this is a bug, but having aur settings still visible in pamac GUI and the app stalling when they are toggled sounds kind of…conflicting?

I use yay most of the time, but right now pamac cli is seeing more updates than yay and I’m not sure how to solve this without breaking things.

Wasn’t that only for the searching of packages? Updates should still work I’d assume.

I’d just use yay -Syu --devel for everything. That will check for repo/AUR + -git packlage updates.

If you want to stick to pamac GUI, you should disable the “check for development package updates”. But then you need to take care of the -git packages some other way, e.g. yay

I ran yay -Syu --devel and it told me I have a total of nine upgradeable packages (the five showed in pamac cli + four other *git packages I don’t remember updating in a long time).

If you want to use yay for the -git packages, you should probably run yay --gendb once.
That makes sure the yay db is up-to-date with what is installed…
Because it might think that some -git packages are out of date (if they have been updated with some other package manager in-between)

Just did that. still nine upgradeable packages.

I guess this solves yay and pamac CLI giving conflicting results then? I’m still not sure if pamac GUI stalling is a bug or a problem on my side :tired_face:

Just not implemented very well.
Again, if you disable the “check for development updates” (or whatever it’s called in the pamac settings) it should not get stuck… (actually it does not really get stuck, just wait 10 minutes or so, it will complete eventually).
However, if you do that, you will not receive -git package updates with pamac. If that is ok for you, so be it. If not, you might want to switch to yay (at least for the -git / devel packages).
Another question you should probably ask yourself: Do I really need the -git version of those packages at all…


Actually there is an issue report about this as well:

Wow…that is an old bug.
Also now I’m curious as to why pamac GUI, pamac cli and yay seem to disagree with everything.

Even though Pamac is a fine AUR helper - remind you that AUR is unsupported - therefor disable all your AUR update searches.

If you really need to be up-front with AUR script updates - please create an account on AUR and signup for notification when your favorite script is updated.

While Pamac has the option - AUR is for Arch Linux and therefore unsupported on Manjaro.

A post was split to a new topic: If AUR is unsupported what is the point in Pamac