Pamac not opening

If you don’t mind me asking how do I install gnome-software ?

I think that gnome-software did the same flatpak upgrade that you performed on CLI. However, i’m on Manjaro Gnome, so i just added gnome-software by

sudo pacman -S gnome-software

If you use Kde, maybe that’s not the best choice for you. In Kde you could install discover instead to manage your flatpak, i guess.

Yeah I am on KDE so your method did not work for me. Discover is crap from what I heard… Plus giving me errors… I guess after all day issue still not solved I will keep flatpak plugin disabled… When a solution appears I shall enable again…

I faced the same issue and package manger was opening only after removing flatpak plugin.
sudo pacman -R pamac-flatpak-plugin

So, I resolved the issue by removing plugin, and ran the below command to reinstall flatpak and plugin.
sudo pacman -S flatpak
sudo pacman -S pamac-flatpak-plugin

You can try this workaround as it resolved the issue for me and is working perfect now.


This worked for me too.

I installed fresh did not have issue until this morning. Those worked for me too, just enabling Flatpak Plugin breaks it again, we need a working fix xD

Even I faced the issue today morning. Make sure you reinstall flatpak and than install the plugin and enable flatpak support from preferences. I did this same thing in more than 15 pc’s and is working flawlessly now.

@nisargp I did exactly as mentioned in previous post. As soon as I re-enable Plugin it breaks again xD

Try refreshing Databases and see if it still opens…

Yeah, I installed/uninstalled some apps from flatpak and also ran some commands like flatpak repair / flatpak update. It is working and not giving any issues whatsoever I do now.

Well, I rebooted twice and fix seems to persist now. Weird… I made a Timeshift backup just in case. Also weird is that in pamac GUI no updates but when I ran flatpak update it saw an update for org.freedesktop.Platform.GL.nvidia-455-45-01 package xD

Same here, I haven’t noted the exact package name but there were 3 packages named ‘org.freedesktop’ updated when I ran that command and it doesn’t show in the pamac.

@nisargp That’s very odd behaviour indeed. Seems there are updates getting stuck in pipeline causing pamac-manager to break… Am by no means an expert just my assumption xD

@nisargp Update… Still randomly stops n have to do your steps every time it happens so it’s not a permanent fix. It’s happening on every fresh install…

This solve the problem on Gnome
I had the same issue, but is something in the pamac
The only way is removing the flatpak plugin.
I use 2 or 3 flatpak’s, so is needed
Linux 5.9.12-1-MANJARO x86_64 20.2 Nibia

Message error before remove plugin:
~ >>> pamac-manager
** Message: 11:21:44.193: flatpak_plugin.vala:125: last flathub appstream refresh is older than 6
** Message: 11:21:44.193: flatpak_plugin.vala:126: refreshing flathub appstream data

(pamac-manager:3549): GLib-GIO-CRITICAL **: 11:21:44.512: g_application_run: assertion ‘acquired_context’ failed

Solution provided by @nisargp works for a while… Then it happens again… So Again I removed plugin and I use flatpak update command in terminal until it’s fixed for good…

Yeah, that is true. It happens again and we need to run those commands to fix it. Hope this gets fixed permanently soon.

Similar topics:

Worked for me too. Thanks

I am trying to install pamac-flatpak-plugin with the command sudo pacman -S pamac-flatpak-plugin
not working

resolving dependencies…
looking for conflicting packages…
:: pamac-cli-dev and pamac-cli are in conflict. Remove pamac-cli? [y/N]

manjaro kde

successfully installed with pamac update) (pamac v. 10.0.1-1.0)