[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

These two bugs are already fixed for stable branch :

KDE Window Decorations UI with Drag&Drop broken
KDE Plasma shows visual graphical errors


Hello, Thank you for your amazing work! I got the following problems since the update:

  • The wifi connection is unstable (driver iwlwifi driverversion=5.10.89-1-MANJARO)
  • Sudo password promts take a minute to appear
  • GDM did not work, had to install lightdm

Looks like the update breaks sane with some HP devices supported by hplip requiring a plugin.

hp-plugin -i is needed.

I use a laptop with a dock with two screens with optimus-manager. After update the screen was blank.

Fixed by
sudo pamac remove optimus-manager
sudo pamac install optimus-manager


I have a big problem. I made the last updates (2022-01-02) on Manjaro Cinnamon version. Now, the system starts but the vendor logo blinks many times and nothings happens. I must reboot with the CTRL+ALT+Del keys. I have the last 5.10 and 5.4 kernel installed but It doesn’t work even if I’m in falling back mode. I tried to switch to console mode but it doesn’t recognize my login. What can I do ? I’m desperate. Is there a way with the usb live of Manjaro to solve the issue ? What’s wrong ?

Note: I’ve got a laptop with Optimus technology. Optimus-manager is installed.

Thank you very much for your help.

Maybe try to boot with live media, and use it to chroot to your system.
Rolling back the optimus-manager seems to help.

I just noticed that the program notify-send does not work anymore, after the update 2 days ago. I know it worked a few days ago, so it is probably something after the update. When I run the command notify-send "hello" in the terminal in example it should work, but it waits as if it would wait for input and never stops, until I control-c. Any idea how to troubleshoot and if this is related to the update? Some related info:

pamac search --files -q notify-send
1 Like

I’ve just installed the update on my main machine and from what I can tell it went well for the most part.
Only thing I immediately noticed was that my mouse feels kind of “sluggish” now. When I move it smoothly, the cursor seems to lag/stutter ever so slightly. When I click and drag to select multiple files in my file manager (Thunar), the selection area most of the time does not appear immediately but only after one second or so. Anyone got any ideas?
I’m on XFCE (xorg) on a GTX 980Ti with proprietary drivers.

Edit: This persisted across reboots as well, however, strangely, after disconnecting and reconnecting the mouse the issue seems to be gone (for now). After a reboot it’s also still fine. Really weird :face_with_raised_eyebrow:

Regular update (with pamac) seemed fine (no apparent errors).

But after reading:

I followed the instruction and got 3 python 3.9 packages installed from the AUR. I checked one of them (auto-cpufreq) and I got an error. Therefore, I proceeded with the proposed solution to rebuild them all:

I didn’t got any errors while doing so. Everything seems to work fine.

Hi all and best wishes for the new year!

Unfortunately after this update both blender 3.0 and blender 2.93.7 3D Viewport flashes while resizing. This is very annoying and probably has to do with the new mesa (or the new KDE). I tried deleting ~./cache* and Trolltech.conf file, but nothing changed. Same bug

The bug is easy to reproduce. Just try resizing the main window by dragging it. It happens on my laptop with nvidia graphics and on my desktop with integrated intel graphics.

Both computers running KDE Plasma

Any ideas ?

Since this update, my mic stops working as soon as I start an application that uses it like Discord or OBS. I then have to reboot if I want it to work again.

I know that my mic works before starting those applications because I can see activity when looking at the volume mixer and I don’t see any activity once I start one of those application.

Downgrading pipewire to 3.40-1 fixes the issue.

Edit: Looks like an issue is already opened with pipewire : https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1892

i’ll have to dig deeper what’s the cause, but after updating the cpu-load is very high and temperatures are at around 80°C while using the PC in the same manner as before.

I think I’ve got a problem with kernel 5.10 and the last updates. If I can chroot the system, I will upgrade to the kernel to 5.15.

pip (python package manager) was missing after update; (SOLVED)

Parts of the previous pip (for python3.9) was still present after the update not functioning (“no package owns /usr/lib/python3.9”), and pip3.10 was not automatically instsalled.

i’m using pip on a weekly basis, so it was most probably there before the update.

After reboot I reinstalled pip3.10 via the package manager (gui), because I wasn’t sure about the package’s name (python3-pip? python-pip3? python3-pip3? python3.10-pip?)

I install python-pip.
(i don’t know with manjaro whether it’s better to use the packange manager or install pip manually. Since this update wasn’t smooth, I’ll try to stick with the package-manager system; i think the previous was manually installed via getpip.py).

There was a real mess with previous pip3.9 executables litter (under ~/.local/bin/, in /usr/bin, multiple symlinks, real files, and stubs),
So I had to manually delete every pip* executable + remains.

then symlink /usr/bon/pip3.10 as /usr/bin/pip

pip now works again.

I attempted to follow the instructions for updating python / AUR - as suggested, I:

  • ran pamac upgrade in the terminal (all successful)
  • ran pamac build $(pacman -Qoq /usr/lib/python3.9)`(all successful)
  • run pamac upgrade --aur

this is where I had a problem - in the output, I received the following:

> Could not find all required packages:
	python2-py (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-atomicwrites (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-wcwidth (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-pathlib2 (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-setuptools-scm (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-pluggy (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-attrs (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-more-itertools (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-funcsigs (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-importlib-metadata (Wanted by: python2-beautifulsoup4 -> python2-pytest)

Is this because I have some even older python packages installed? Can I have any advice on what to do about this? I’m rather over my head at this point!

(Edit: I did some googling and doing pacman -o on these, it looks like python2-beautifulsoup4 was installed as a dependency of another package, but is listed as “required by: none” - I am guessing that it is no longer needed but nervous about deleting it and causing a problem… Am I correct in thinking that this is the package that is causing the problem? I don’t seem to have python2-pytest installed… It looks like I have a few python2 packages from the AUR, and also listed as orphans…)

Many thanks!

Sorry for lateness of reply.
I wrote the wiki-post item about pip.
Later I moved it to this separate post.
Later again, I realized that the whole idea (that I got from somewhere else) was flawed.
Now it uses ‘pip list’, and you don’t need to do it before the main upgrade.
So if you still have questions, and/or didn’t do it yet, please read that post again.

Please see this post.

1 Like

The git page says: “Update gui to use wxFormBuilder 3.10” on Oct 20th.
So the GUI is wxWidgets, and that’s probably where the problem comes from.

Anyway It’s not a Manjaro issue - check the issues at facelessuser Rummage github.

It’s normal that the old “site-packages” (and maybe some other stuff) is still there after the update.
Nothing there can work because the old python executable is gone.

The new python executable uses the new site-packages directory.

Now that you have installed ‘python-pip’ via the package manager,
you can expect it to be updated automatically next time.

that was a temporary (and unrelated) issue with the manjaro sway database. should be fixed now though?