Opera always opens with small window

No matter what I do, it always starts in small window in middle of KDE desktop. Maximizing it and closing does nothing, creating Window rules doesn’t seem to affect it at all since it’s apparently using some different window system as window control buttons look different than the rest from KDE. Really annoying problem and KDE version of Manjaro seems to be plagued by this constantly. Firefox also just randomly decides to not remember window size/positioning and I have to force it with Window rules. Why can’t this be consistent, it’s like the very basic thing about OS operation. Like, THE very basic thing.

Let me assure you that i use almost all browsers on daily basis and none act as you describe. I’m 100% sure is not a Manjaro thing, rather something locally on your end.
Did you tried with a TEST user, with fresh start configs and check if you notice those inconsistencies?

In principle all applications will follow the general “rule” you set in Window Behavior Settings. I prefer to disable the Allow apps to remember the positions of their own windows.

Then the rules are just for some minor things i want to act in particular way. For instance for Opera i use this rule because i want it to open only in a specific Activity, and i prefer to use the KDE Plasma Title Bar, so for that is the last option there. I know is somehow counter intuitive and comes as would be a double negation, but that is how it works …


It’s literally a clean system install. I know how to apply these rules for windows because Firefox also randomly gets problems remembering to open maximized on start, but none of these rules even affect Opera. So, yeah it’s something up with Manjaro (or KDE part of it) because it constantly has these dumb problems with remembering damn windows sizes and positions.

On your end.
I can’t reproduce neither in VM install, and i never had such issues on my native install.
Random reports also got into being not conclusive enough

Others have a clear explanation:

Older discussion with some hints:

No it is not a issue with Manjaro. Opera does this on ALL Arch based distros and thus most likely ALL versions of Linux and their respective Spins. Just launch Opera, place you mouse at the end of it’s tabbar, press Alt+F3, From the context menu that pops up select more actions, configure special application settings, doulbeclick detect window properties, from the dialog box presented scroll and select size, enter your monitors dimensions in the appropriate boxes, apply, ok.

I’ve used “remember” option and it did nothing. I don’t want it to be forced maximized. I want it to bloody remember my damn window selection. If I left it tiny, I want it start that way next time. If I had it maximized, I want it maximized. With these settings, it’ll ALWAYS be maximized.

Also, I want actually maximized window, not just windowed, but fitting desktop to the edges. Firefox did this crap randomly on Manjaro and it drove me insane until I set the rules for it to remember size and positioning.

I’ve even set remember option to ALL windows, ignoring targeting and it didn’t work either. It’s just so weird and inconsistent and it always goes sideways the moment I’m starting to like the experience. Been using Manjaro KDE for months now and suddenly Firefox started behaving wonky with window sizes. And trying Opera, that one too apparently.

Every window on your screen is controlled by KDE, the buttons looking different doesn’t affect this. Have you tried using the “Detect Window Properties” button when editing window rules to find the exact name of the window?

It’s not the name of window that’s a problem, it’s settings you pick not doing anything.

“Ignore requested geometry” and setting it to “Remember” works correctly for Firefox, but doesn’t for Opera for whatever reason. Using “opera” as window name works when I manually set it to start maximized vertically and horizontally, but it always does Just f**king start maximized, jesus.

It seems some rules are just ignored while others are applied. It’s really inconsistent and annoying.

Explain me this tho. Installed Opera from repo, in settings I’ve reset it to default settings (Update & Recovery menu in Opera). Then just start it, maximize it and close it. Open it again and it’ll be maximized as it should be. Close it again and open it up. It’ll be windowed now. Or sometimes it takes two starts, but when it goes windowed, it never ever goes maximized ever again. If you maximize it, it’ll work once or twice and then flip to windowed again and remain in that size forever afterwards. This makes absolutely no sense why it would work twice and then stop remembering window positioning/size. For what reason?

Again this is a Opera issue NOT a Manjaro or KDE issue. Go to the Opera forums.

1 Like

I have to say I have never experienced this kind of problem, other than after some update to a part of KDE. I just grab a corner or edge with the mouse and drag to the size/shape I want. Subsequent start ups always remember the settings.
Like other replies, I can only surmise the problem is at your end and not KDE/Plasma. Forum would be awash with complaints otherwise.

I completely agree. I can only add that it might be worth trying a combination Win + arrow up/down to change size)

Thread cleaned. :broom:

Please be excellent to each other. :guitar: