Only Dummy Sound Output

my problem: I only get the Dummy Audio Output with the Internal SoundCard. With external SoundCard (my USB Hub has a 3.5mm jack) is it all fine. The System dosn’t detect the internal SoundCard. It isn’t listed in ALSA. But with “lspci” i see my SoundCard. And also the SoundCard workes fine under Ubuntu 20.04 and Windows.
I am completly new at Arch based Distributions.

Thanks in advance

If you need it, I am using:
Manjaro with KDE (Software is up to date)
Lenovo Yoga C740 (SSD UEFI encrypted, but without encyption it also dosn’t work)

Please provide better information so that someone can help:

For the bgeinning this could help:

inxi -Axza

Hello haschdag_baum,
could you try
arecord -l
in a terminal to see if it shows up as a sound card there?

For me it is
[julius@Pinebook ~]$ arecord -l **** Liste der Hardware-Geräte (CAPTURE) **** Karte 0: rockchipes8316c [rockchip,es8316-codec], Gerät 0: ff890000.i2s-ES8316 HiFi ES8316 HiFi-0 [ff890000.i2s-ES8316 HiFi ES8316 HiFi-0] Sub-Geräte: 1/1 Sub-Gerät #0: subdevice #0

found the command here

Best Regards, Julius

Okay, here the missing informations:

arecord -l
**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 0: Device [USB PnP Audio Device], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
[marian@Computer ~]$ inxi -Axza
  Device-1: Intel vendor: Lenovo driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.6.15-1-MANJARO

inxi -Fxza
  Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=0da83ece-4abf-4bb8-b87e-e2f54cf76748 rw quiet apparmor=1 
  security=apparmor resume=UUID=bc646a16-ac8a-40a6-8f40-a0c9836cc68e 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Convertible System: LENOVO product: 81TD 
  v: Lenovo Yoga C740-15IML serial: <filter> Chassis: type: 31 
  v: Lenovo Yoga C740-15IML serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <filter> 
  UEFI: LENOVO v: BNCN35WW date: 11/18/2019 
  ID-1: BAT0 charge: 60.6 Wh condition: 60.6/60.3 Wh (101%) 
  volts: 13.1/11.5 model: Sunwoda L18D3PF2 type: Li-poly serial: <filter> 
  status: Full cycles: 11 
  Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: CA L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33615 
  Speed: 1000 MHz min/max: 400/1600 MHz Core speeds (MHz): 1: 995 2: 996 
  3: 997 4: 993 5: 978 6: 994 7: 973 8: 989 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9b41 
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-7:3 chip ID: 174f:2426 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 
  size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.5 
  direct render: Yes 
  Device-1: Intel vendor: Lenovo driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
  Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 3000 
  bus ID: 00:14.3 chip ID: 8086:02f0 
  IF: wlp0s20f3 state: down mac: <filter> 
  Local Storage: total: 476.94 GiB used: 11.18 GiB (2.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN730 SDBPNTY-512G-1101 size: 476.94 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 11130001 scheme: GPT 
  ID-1: / raw size: 459.76 GiB size: 451.54 GiB (98.21%) 
  used: 11.18 GiB (2.5%) fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.89 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 258 Uptime: 50m Memory: 15.35 GiB used: 2.44 GiB (15.9%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: 1223 pacman: 1219 
  lib: 329 flatpak: 0 snap: 4 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05

arecord -l
arecord: device_list:274: keine Soundkarten gefunden ...

In English: “No SoundCard Detected”

Thank you

Hello, thanks for the info.

is your USB Dac, I believe. Please correct me if I’m wrong

It doesn’t seem to show up, unfortunately.

  • Do you know from what vendor your sound card is from? Maybe some are experiencing similar issues with this.
  • lspci makes it show up, so it should be connected to the computer. Following this guide, you could try sudo alsa force-reload, exit with Ctrl+C (oder Strg+C für die mit einer deutschen Tastatur), and reboot.
    The guide also shows other methods and I would recommend that you look at it since most should work even if the guide was written for ubuntu, originally.
    Best Regards, Julius

Duplicate threads:
Please also see

yes, that is my USB Hub.

I tried “your” guide and the fifth point (for the Lenovo Carbon X1) worked.
I created there the file and reboote.
Now I have sound.

Thank you a lot

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.