Online videos sometimes only play first frame and video freezes

I have a laptop connected via HDMI to a 27 inch 2560 x 1440 monitor.
I use it as Single Display being the monitor only.
There are times when I play online videos that the video does not go further than the 1st frame, and then it freezes.

I cannot completely tell when this occurs, but it is quite random. If I reboot the system the problem goes away.

I suspect this has to do with the HDMI connection and graphics card, but that is just a vague guess.

No matter the server, i.e. youtube, vimeo, etc
It happens both with Chrome and Firefox
Note: I’m having this problem right now for instance.

$ inxi -Fxza --no-host
  Kernel: 5.10.96-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=75a0eed1-3787-4451-9020-fbb5e4209954 rw quiet apparmor=1
    security=apparmor resume=UUID=1f35139c-62ba-45f9-afb4-8158f370195d
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20N2S1PE00 v: ThinkPad T490
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20N2S1PE00 v: SDK0R32862 WIN
    serial: <superuser required> UEFI: LENOVO v: N2IET75W (1.53 )
    date: 08/21/2019
  ID-1: BAT0 charge: 15.4 Wh (34.7%) condition: 44.4/50.5 Wh (87.9%)
    volts: 11.0 min: 11.5 model: SMP 02DL008 type: Li-poly serial: <filter>
    status: Discharging cycles: 404
  Info: model: Intel Core i7-8565U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 728 high: 800 min/max: 400/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 702 2: 800 3: 799 4: 700
    5: 727 6: 700 7: 699 8: 700 bogomips: 32012
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort status: Not affected
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Lenovo
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Chicony ThinkPad T490 Webcam type: USB driver: uvcvideo
    bus-ID: 1-8:3 chip-ID: 04f2:b681 class-ID: 0e02 serial: <filter>
  Display: x11 server: compositor: gnome-shell driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.96-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
    v: kernel bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15be class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 476.94 GiB used: 387.86 GiB (81.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB512HBJQ-000L7 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 4M2QEXF7 temp: 32.9 C scheme: GPT
  ID-1: / raw-size: 451.05 GiB size: 442.97 GiB (98.21%)
    used: 387.86 GiB (87.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 25.59 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 39.0 C pch: 43.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 310 Uptime: 6h 2m wakeups: 39 Memory: 23.15 GiB
  used: 7.75 GiB (33.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1803 lib: 455 flatpak: 0
  Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.12

Have you tried another kernel like 5.15 ?

I think 5.15 it is still in unstable branch, and I’m in stable, sorry.

Are there any ideas?

This is an odd one.

For me, I had a similar issue (almost like you described), but it was because of PulseAudio.

Just to rule it out, restart the puleaudio service when this happens, and see if it “continues” to play the video or unfreeze.

systemctl --user restart pulseaudio

In my case, only the video was affected. The rest of my system was fine (no crash, no hang, no freeze).

Other than that, you can also do two other things, even both at once:

  1. Remove the xf86-video-intel package and any custom .conf files you might have created under /etc/X11/
  2. Install and boot into LTS kernel 5.15
1 Like

provide also:
mhwd -l && mhwd -li

Restarting PulseAudio works but… why? Some conflict with Pipewire perhaps? Is there a more permanent fix for this?

try to install pipewire with this package: manjaro-pipewire, it will give you dependency issues, so uninstall them, then install it again, and reboot, and check
if it doesnt work, install this package: manjaro-pulse, it will remove pipewire, reboot and check


My hunch was correct. :wink:

It appears as a video / GPU issue on the surface, but it likely has something to do with the player refusing to “resume” if there is no proper audio output. By forcing the pulseaudio service to restart, you temporarily correct this issue, and thus the video player will “resume” like normal.

I noticed this with a recent update, and as alluded by @brahma above, it may in fact be due to a conflict between PipeWire and PulseAudio.

My “daily driver” laptop does not have this issue (KDE), however, my secondary laptop (Xfce) continues to suffer from this issue, of which I just do the service restart “trick” to be able to watch videos like normal.

I haven’t yet discovered a permanent fix for this (yet) on my Xfce system.

You might try @brahma’s above steps, while in the meantime use the systemctl --user restart pulseaudio trick I shared above if you need to be able to watch videos in a jiffy-type situation. :woozy_face:

EDIT: Wait a minute! You pulled a switcheroo on me! :rofl: I just realized the original poster @David5 did not reply with their results yet.

But glad the “trick” worked for your case in the meantime, which makes me wonder if @David5’s issue overlaps with ours? :thinking:

I noticed you’re both using GNOME, and the “problematic” system of mine is on Xfce. However, the “no problems” system of mine is KDE.

1 Like

Thanks for the suggestion, @brahma. The dependencies were going back a bit too far, trying to get me to uninstall Gnome components and all that. I’m not handy enough to use pamac properly so found this solution to get ride of PulseAudio and install Pipewire instead:

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-pa pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire

Solved it for me.

1 Like

Did you think, or did you try ?

Kernel 5.15 is LTS and is in Stable branch, but Kernel is not your problem.

This problem is Pulse Audio and you need to install Pipewire.

Thank you @winnie , truly. Let me show you the result:

systemctl --user restart pulseaudio

So, two things:

  1. This solution seems to fix only the current youtube video. If you try to open another video in another tab, the same problem appears.

  2. This solution seems to disable the audio of the video.

So that’s why my original hunch (which still stands) is that this is not a video / decoding / driver issue. That’s why restarting pulseaudio allows the video to continue playing. (It’s not really that your video “freezes”, it’s just that there’s a “hard pause” on the video until an audio output is “available”.

You might try the workarounds that others in this thread have shared (about installing/reinstalling the relevant packages.)

@brahma Thank you. Just to avoid confusion:

Here it is:

$ mhwd -l && mhwd -li
> 0000:00:02.0 (0300:8086:3ea0) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

if you have pulse issues, install pipewire, reboot and test… there are more people who had audio issue after update and this solved them…

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-pa pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire


@brahma @ShishKebabsMin Thank you both.

I’m afraid I get this error:

error: target not found: pulseaudio-pa

so install this:
sudo pacman -S manjaro-pipewire
it will give you dependency issues, so uninstall them first, then run again the pipewire command, then reboot and test

Thank you, but I need to understand what I’m doing. What is the reason for this error and why does it appear when I try to remove that package?

youre uninstalling pulse audio, and its dependencies and installing pipewire instead… the target not found is you dont have installed pulseaudio-pa
this is the same command but without the pulseaudio-pa:

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire