Online videos sometimes only play first frame and video freezes

Ok, thank you. I’m afraid I get all this:

$ sudo pacman -S manjaro-pipewire
[sudo] password for david: 
resolving dependencies...
looking for conflicting packages...
:: manjaro-pipewire and manjaro-pulse are in conflict. Remove manjaro-pulse? [y/N] y
:: manjaro-pipewire and pulseaudio-zeroconf are in conflict. Remove pulseaudio-zeroconf? [y/N] y
:: pipewire-pulse and pulseaudio are in conflict. Remove pulseaudio? [y/N] y
:: pipewire-pulse and pulseaudio-bluetooth are in conflict. Remove pulseaudio-bluetooth? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-4' required by pulseaudio-equalizer
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-4' required by pulseaudio-jack
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-4' required by pulseaudio-lirc
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-4' required by pulseaudio-rtp

run this command, it will take care of the dependencies, and also the pulseaudio-pa is removed from it, so you wont get target not found error:

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire

reboot

@brahma Thank you. I’ve done that:

(including reboot) but the problem still appears.

@brahma @winnie Thank you both so much for your help. Here are some updates: After trying this:

After reboot the problem is solved but then quite randomly the problem still keeps appearing (only after a reboot the problem disappears) but then after a while it appears again and so on…
Are there any possible updates on this?
Many thanks

try a newer kernel, according to your post above youre using tje 5.10, so install the 5.15 LTS, reboot and test

@brahma Thanks but according to @TheReaperUK I believe the problem is not in the Kernel.

And I wonder why is this still occurring quite randomly

the only thing i can think about is to change the kernel… you have nothing to lose by doing that

well sometimes it’s just a missing codec. you’re running the intel gpu, please check if “libva-intel-driver” is installed. this is a package of the “extra”. there are still some more codecs that you can install for intel-uhd. they will improve the performance and add extra-codecs that might be needed.

When the problem appears (for instance, just now) I can see the following:

$ pipewire
[E][28493.824517] mod.protocol-native | [module-protocol-:  708 lock_socket()] server 0x55ce6e732870: unable to lock lockfile '/run/user/1000/pipewire-0.lock': Resource temporarily unavailable (maybe another daemon is running)
[E][28493.824928] pw.conf      | [          conf.c:  560 load_module()] 0x55ce6e6f5270: could not load mandatory module "libpipewire-module-protocol-native": Resource temporarily unavailable
[E][28493.825247] default      | [      pipewire.c:  125 main()] failed to create context: Resource temporarily unavailable
$ ps ax | grep pipewire
   1571 ?        S<sl   4:25 /usr/bin/pipewire
   1572 ?        Ssl    0:00 /usr/bin/pipewire-media-session
   1573 ?        S<Lsl   6:06 /usr/bin/pipewire-pulse
  22473 pts/2    S+     0:00 grep --colour=auto pipewire
  • a) So pipewire seems to be running but there is a Resource temporarily unavailable message as can be seen in the first print ?
$ inxi -Faz | grep "Sound"
  Sound Server-1: ALSA v: k5.10.117-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  • b) Why is PulseAudio still there if it was removed?

hard to say from thousands of miles away but i wouldn’t focus to pipewire or any audio-service. if your video-output crashes and the audio-signals interrupt because of that it is imho only a failure that depends of the missing video. so said just the failure that is caused of a previous failure. did you check to add missing/additional codecs ?

Neither video nor application is crashing.

The video is hard “pausing” without continuing the playback. Forcing the audio service to restart (and make audio outputs present again) makes the video continue to “play”.

yes but I thought we left pusleaudio behind…
Also, we saw that:
systemctl --user restart pulseaudio

try a newer kernel, according to your post above youre using tje 5.10, so install the 5.15 LTS, reboot and test

In case you wonder why there are still pulse-audio packages installed; when pipewire is installed it uses some of the old pulse-audio packages, so there is nothing wrong with that.

What often seems to go wrong is that some of the pipewire default settings seem not to fit all hardware. The actual audio/video symptoms vary, I had issues with stuck audio players when pausing mid-track.

What helped a few people is to go through this tutorial resetting pipewire defaults to more suitable and stable values. Takes less than 10 min and it solved my issue:

Update: The problem still exists…

but I’ve managed to narrow down the problem
and have discovered that whenever this problem happens,

if I turn down the volume of the video (volume of the youtube video, twitter video, etc; i.e. not the system’s volume on the top right bar),

then what I see is that the video runs to the second frame onwards and it plays smoothly all the way (however, without sound…)

so when you completely mute it, it works? does it also works only when you lower it? does it also works when you first mute it and than unmute it?
does it happen also with different browsers: brave/firefox?
also post output from this:
pacman -Qs 'pulse|pipewire|wireplumber'
to check for pulse leftovers

@brahma

See this quite explanatory video:
(the super low quality is because I’ve reduced colors and resolution to keep it less than 1 MB in order to be able to post it here)

test_freeze_short_compressed_2

it happens frequently with chrome and firefox.

$ pacman -Qs 'pulse|pipewire|wireplumber'
local/gst-plugin-pipewire 1:0.3.57-1
    Multimedia graph framework - pipewire plugin
local/lib32-libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification
    (32-bit)
local/lib32-libpulse 16.1-1
    A featureful, general-purpose sound server (32-bit client libraries)
local/libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification
local/libpulse 16.1-1
    A featureful, general-purpose sound server (client library)
local/manjaro-pipewire 20220217-2
    Manjaro meta package for complete PipeWire support.
local/pipewire 1:0.3.57-1
    Low-latency audio/video router and processor
local/pipewire-alsa 1:0.3.57-1.0
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-media-session 1:0.4.1-2
    Example session manager for PipeWire
local/pipewire-pulse 1:0.3.57-1.0
    Low-latency audio/video router and processor - PulseAudio replacement
local/pipewire-zeroconf 1:0.3.57-1
    Low-latency audio/video router and processor - Zeroconf support
local/pulseaudio-alsa 1:1.2.7.1-1
    ALSA Configuration for PulseAudio
local/python-pulsectl 22.3.2-2
    Python high-level interface and ctypes-based bindings for PulseAudio
    (libpulse)

so you dont have installed wireplumber, install it:
pamac install wireplumber
it will replace media-session, reboot and test if it helped
also install the 5.15 kernel and try with it, if you alredy didnt do it