Audio not working after system upgrade

Hey guys, my audio stopped working after system upgrade today, I don’t know which information I could give to solve this problem.

I tried to search for this problem here in the forum and used some commands there I found, the command systemctl --user restart pulseaudio gives me no message, so I think the command is working, but there’s no sound. I also tried systemctl --user start pulseaudio.service also, no message. I’ve been using pulse-effects-legacy from AUR since today, tried to reinstall but the problem persist. When I boot my computer me sound works for about 10 seconds and stop working and I can’t make it work again, I tried to change the device output or increase/decrease volume, tried also restart pulseaudio after kill pulseeffects in system monitor. Here are some informations of my computer spec

inxi -Fxz                                                        ✔ 
  Kernel: 5.15.38-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: GNOME v: 42.1 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2006
    date: 11/13/2019
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    rev: 2 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1484 high: 1867 min/max: 1550/3400 boost: enabled
    cores: 1: 1450 2: 1349 3: 1374 4: 1485 5: 1539 6: 1547 7: 1867 8: 1331
    9: 1407 10: 1546 11: 1376 12: 1546 bogomips: 81469
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 08:00.0
  Device-2: A4Tech REDRAGON Live Camera type: USB driver: uvcvideo
    bus-ID: 3-2:2
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon gpu: amdgpu
    resolution: 1920x1080~70Hz
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 08:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3
  Device-3: A4Tech REDRAGON Live Camera type: USB driver: uvcvideo
    bus-ID: 3-2:2
  Device-4: FIFINE Microphones K670 Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:3
  Sound Server-1: ALSA v: k5.15.38-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 447.13 GiB used: 254.31 GiB (56.9%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-1: / size: 58.76 GiB used: 30.99 GiB (52.7%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 196.9 MiB used: 274 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 379.8 GiB used: 223.32 GiB (58.8%) fs: ext4
    dev: /dev/sda3
  ID-1: swap-1 type: file size: 1024 MiB used: 0 KiB (0.0%) file: /swapfile1
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 50.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1112
  Processes: 346 Uptime: 46m Memory: 15.62 GiB used: 3.29 GiB (21.1%)
  Init: systemd Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1387
  Shell: Zsh v: 5.8.1 inxi: 3.3.15

sudo dmesg | grep -E 'ALSA|HDA|snd|sound|hda'                    ✔ 
[sudo] password for denielton: 
[    3.940113] snd_hda_intel 0000:08:00.1: Force to non-snoop mode
[    3.940343] snd_hda_intel 0000:0a:00.3: enabling device (0000 -> 0002)
[    3.960619] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.1/0000:08:00.1/sound/card0/input4
[    3.971378] input: HDA ATI HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.1/0000:08:00.1/sound/card0/input5
[    3.971450] input: HDA ATI HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.1/0000:08:00.1/sound/card0/input6
[    3.971827] input: HDA ATI HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.1/0000:08:00.1/sound/card0/input7
[    3.971874] input: HDA ATI HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.1/0000:08:00.1/sound/card0/input8
[    3.971935] input: HDA ATI HDMI HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:03.1/0000:08:00.1/sound/card0/input9
[    4.005371] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[    4.005376] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.005378] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    4.005380] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    4.005381] snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x11/0x0
[    4.005382] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    4.005383] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[    4.005385] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[    4.005386] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[    4.040697] input: HD-Audio Generic Front Mic as /devices/pci0000:00/0000:00:08.1/0000:0a:00.3/sound/card1/input10
[    4.040754] input: HD-Audio Generic Rear Mic as /devices/pci0000:00/0000:00:08.1/0000:0a:00.3/sound/card1/input11
[    4.040835] input: HD-Audio Generic Line as /devices/pci0000:00/0000:00:08.1/0000:0a:00.3/sound/card1/input12
[    4.040876] input: HD-Audio Generic Line Out as /devices/pci0000:00/0000:00:08.1/0000:0a:00.3/sound/card1/input13
[    4.040923] input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:08.1/0000:0a:00.3/sound/card1/input14
[    4.056943] snd_hda_intel 0000:08:00.1: bound 0000:08:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    4.524297] usbcore: registered new interface driver snd-usb-audio

Gnome 4.2 no longer works for Audio if you are not using Pipewire as i found out after the Update, you need to install “manjaro-pipewire” and i must thank @brahma for this info:

this looks like it could possibly be a pulse/pipewire issue, so install pipewire with manjaro-pipewire package… if you get dependencies issues, uninstall them first, then install pipewire, reboot and check

I also installed the Pipewire Lib32 files as well.

1 Like

Gonna try this right now, thanks for your help

Still no sound, my devices disappeared too :frowning_with_open_mouth:

Tried to follow this instructions What is the correct way to install package “manjaro-pipewire”? - #7 by kagetora13

this solved my problem


All i did was open terminal and typed “sudo pacman -S manjaro-pipewire” (without quotes) which after a few seconds gave me some dependencies issues with pulseaudio-jack and 2 other pulseaudio-*** then failed to install.
I then used Pamac GUI to remove those dependencies issues (pulseaudio-jack + other 2) then re-run the terminal command “sudo pacman -S manjaro-pipewire”, once it was done i then went back to Pamac GUI and install the lib32-pipewire stuff, once that was done i rebooted, and after reboot i had working audio again.

I DID NOT install “EasyEffects” or “pulseeffects” (as far as i know this is now EasyEffects for Pipewire)

1 Like

pulseaudio stack seems to break dependency on gnome-settings-daemon gnome-control-center etc. Safe to remove all ??

I don’t know. I just uninstalled pulseaudio as said in the links, used pipewire for some hours, have the same problem with pipewire so I removed pipewire and tried to install pulseaudio again, now it’s working fine. Maybe the solution is to uninstall all pulseaudio and install again, this solved my problem, maybe it solves yours too.

Don’t remove all of pulseaudio, run this from terminal first:

sudo pacman -S manjaro-pipewire

And see what dependencies it fails to remove, then just remove/uninstall those, then run sudo pacman -S manjaro-pipewire again and it will remove and install as needed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.