Okular reader turns to light theme after the update

My Okular reader turns to light theme after the update. Not sure know how to switch it back or there is a bug.

Maybe just go to Settings > Color Scheme and set it to Default.

The color scheme is already in default.

Btw my DE is Gnome

Ah, so are you using Kvantum, Qt5/Qt6 Settings (qt5ct) or Gnome Platform for Qt applications? It might be related to your /etc/environment … This should help:

I think it is Gnome Platform as I don’t have Kvantum and qt5ct installed.

Following the post you mentioned I set QT_QPA_PLATFORMTHEME and QT_STYLE_OVERRIDE in /etc/environment but it has no effect to Okular.

Other QT based apps like Telegram, QDBusViewer are still respecting dark theme after this stable update.

Here’s my current /etc/environment:

#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#

# https://doc.qt.io/qt-5/highdpi.html#high-dpi-support-in-qt
QT_AUTO_SCREEN_SCALE_FACTOR=1

# Available options: gtk2, gnome, kde, qt5ct, xcb
QT_QPA_PLATFORMTHEME=gnome

# Available styles: HighContrastInverse, HighContrast, Adwaita-HighContrastInverse,
# Adwaita-HighContrast, Adwaita-Dark, Adwaita, kvantum-dark, kvantum, qt5ct-style,
# Windows, Fusion
QT_STYLE_OVERRIDE=Adwaita-Dark

EDITOR=/usr/bin/nano

and what’re being updated today:

[2022-09-13T09:58:39+0200] [ALPM] upgraded yt-dlp (2022.07.18-1 -> 2022.09.01-1)
[2022-09-13T09:58:39+0200] [ALPM] upgraded wireless-regdb (2022.06.06-1 -> 2022.08.12-1)
[2022-09-13T09:58:39+0200] [ALPM] upgraded webkit2gtk-4.1 (2.36.6-1 -> 2.36.7-1)
[2022-09-13T09:58:39+0200] [ALPM] upgraded webapp-manager (1.2.4-1 -> 1.2.5-1)
[2022-09-13T09:58:39+0200] [ALPM] upgraded vivaldi-ffmpeg-codecs (104.0.5112.79-1 -> 104.0.5112.101-1)
[2022-09-13T09:58:39+0200] [ALPM] upgraded virtualbox (6.1.36-1 -> 6.1.38-1)
[2022-09-13T09:58:38+0200] [ALPM] upgraded telegram-desktop (4.1.0-1 -> 4.1.1-1)
[2022-09-13T09:58:38+0200] [ALPM] upgraded taglib (1.12-1 -> 1.12-2)
[2022-09-13T09:58:38+0200] [ALPM] upgraded sof-firmware (2.2-1 -> 2.2.1-1)
[2022-09-13T09:58:38+0200] [ALPM] upgraded snapd-glib (1.60-1 -> 1.63-1)
[2022-09-13T09:58:38+0200] [ALPM] upgraded snapd (2.57.1-1 -> 2.57.1-2)
[2022-09-13T09:58:38+0200] [ALPM] upgraded signal-desktop (5.54.0-1 -> 5.57.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded rsync (3.2.5pre2-1 -> 3.2.5-2)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-desktop (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-virtiofsd (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-vhost-user-gpu (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-spice-app (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-sdl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded sdl2_image (2.6.1-1 -> 2.6.2-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-gtk (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-egl-headless (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-dbus (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-curses (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-tools (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-system-x86 (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded seabios (1.16.0-2 -> 1.16.0-3)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-pr-helper (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-img (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-usb-smartcard (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-usb-redirect (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-usb-host (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-s390x-virtio-gpu-ccw (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-virtio-vga-gl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-virtio-vga (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-virtio-gpu-pci-gl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-virtio-gpu-pci (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-virtio-gpu-gl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-virtio-gpu (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-hw-display-qxl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-chardev-spice (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-block-ssh (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-block-nfs (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-block-dmg (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-block-curl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-spice (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-spice-core (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-ui-opengl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-sdl (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-pa (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-oss (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-jack (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-dbus (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-audio-alsa (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded qemu-common (7.0.0-10 -> 7.0.0-12)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-systemd (234-11 -> 235-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-setproctitle (1.2.3-1 -> 1.3.1-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-keyring (23.4.0-1 -> 23.9.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-secretstorage (3.3.2-1 -> 3.3.3-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-importlib-metadata (4.8.1-3 -> 4.8.3-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-google-api-python-client (2.56.0-1 -> 2.57.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-protobuf (21.4-1 -> 21.5-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-six (1.16.0-5 -> 1.16.0-6)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-google-auth (1.34.0-4 -> 1.35.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-gnupg (0.4.9-1 -> 0.5.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-filelock (3.6.0-1 -> 3.8.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded python-bcrypt (3.2.2-1 -> 4.0.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded plymouth-theme-manjaro (2.1-2 -> 2.2-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded plymouth (22.02.122-4 -> 22.02.122-10)
[2022-09-13T09:58:37+0200] [ALPM] upgraded perl-alien-build (2.51-1 -> 2.53-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded okular (22.04.3-1 -> 22.08.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded purpose (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded threadweaver (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded poppler-qt5 (22.08.0-1 -> 22.09.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded npm (8.17.0-1 -> 8.19.1-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded nodejs-nopt (5.0.0-2 -> 6.0.0-1)
[2022-09-13T09:58:37+0200] [ALPM] upgraded nodejs (18.7.0-1 -> 18.8.0-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded networkmanager-openvpn (1.8.18-2 -> 1.10.0-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded networkmanager (1.38.4-1 -> 1.40.0-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded slang (2.3.2-2 -> 2.3.3-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded nerd-fonts-noto-sans-mono (2.1.0-1 -> 2.2.2-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded nautilus-admin (1.1.9+5+ga51885e-1 -> 1.1.9+5+ga51885e-2)
[2022-09-13T09:58:36+0200] [ALPM] upgraded osinfo-db (20220727-1 -> 20220830-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded poppler-glib (22.08.0-1 -> 22.09.0-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded manjaro-settings-manager-notifier (0.5.7-6 -> 0.5.7-9)
[2022-09-13T09:58:36+0200] [ALPM] upgraded manjaro-settings-manager (0.5.7-6 -> 0.5.7-9)
[2022-09-13T09:58:36+0200] [ALPM] upgraded manjaro-release (21.3.7-1 -> 22.0.0pre2-1)
[2022-09-13T09:58:36+0200] [ALPM] upgraded lollypop (1.4.34-1 -> 1.4.35-2)
[2022-09-13T09:58:28+0200] [ALPM] upgraded linux515-virtualbox-host-modules (6.1.36-8 -> 6.1.38-2)
[2022-09-13T09:58:19+0200] [ALPM] upgraded linux515-nvidia (515.65.01-2 -> 515.65.01-8)
[2022-09-13T09:58:19+0200] [ALPM] upgraded linux515 (5.15.60-1 -> 5.15.65-1)
[2022-09-13T09:58:18+0200] [ALPM] upgraded linux-firmware (20220708.be7798e-1 -> 20220815.8413c63-1)
[2022-09-13T09:58:18+0200] [ALPM] upgraded linux-firmware-whence (20220708.be7798e-1 -> 20220815.8413c63-1)
[2022-09-13T09:58:18+0200] [ALPM] upgraded libvirt (1:8.6.0-2 -> 1:8.7.0-1)
[2022-09-13T09:58:17+0200] [ALPM] upgraded libvips (8.13.0-1 -> 8.13.1-1)
[2022-09-13T09:58:17+0200] [ALPM] upgraded libreoffice-fresh (7.3.5-3 -> 7.4.0-3)
[2022-09-13T09:58:16+0200] [ALPM] upgraded xmlsec (1.2.34-1 -> 1.2.34-2)
[2022-09-13T09:58:16+0200] [ALPM] upgraded libnm (1.38.4-1 -> 1.40.0-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded liblouis (3.22.0-1 -> 3.23.0-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded libkexiv2 (22.04.3-1 -> 22.08.0-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded libgnomekbd (1:3.26.1+r5+g54da436-1 -> 1:3.28.1-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded libatomic_ops (7.6.12-1 -> 7.6.14-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded lib32-mesa (22.1.6-1 -> 22.1.7-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded lib32-libxml2 (2.9.14-1 -> 2.10.2-2)
[2022-09-13T09:58:16+0200] [ALPM] upgraded lib32-curl (7.84.0-1 -> 7.85.0-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded lib32-krb5 (1.19.3-2 -> 1.20-1)
[2022-09-13T09:58:16+0200] [ALPM] upgraded lib32-gcc-libs (12.1.1-4 -> 12.2.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded less (1:590-1 -> 1:608-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kpty (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kparts (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kjs (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kitemmodels (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kirigami2 (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded qt5-quickcontrols2 (5.15.5+kde+r5-1 -> 5.15.5+kde+r6-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kactivities (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kaccounts-integration (22.04.3-1 -> 22.08.0-2)
[2022-09-13T09:58:15+0200] [ALPM] upgraded libaccounts-glib (1.25-7 -> 1.26-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded signon-kwallet-extension (22.04.3-1 -> 22.08.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kcmutils (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kdeclarative (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kpackage (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kio (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kded (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded ktextwidgets (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded sonnet (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kcompletion (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kwallet (5.96.0-1 -> 5.97.0-4)
[2022-09-13T09:58:15+0200] [ALPM] installed qca-qt5 (2.3.4-3)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kservice (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded knotifications (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kbookmarks (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kxmlgui (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kiconthemes (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded karchive (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kitemviews (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kconfigwidgets (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded ki18n (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kguiaddons (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kcodecs (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kauth (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kglobalaccel (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kcrash (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:15+0200] [ALPM] upgraded kwindowsystem (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded kconfig (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded kdbusaddons (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded kjobwidgets (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded kwidgetsaddons (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded kcoreaddons (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded solid (5.96.0-1 -> 5.97.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded xfsprogs (5.18.0-1 -> 5.19.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded liburcu (0.13.1-1 -> 0.13.2-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded ndctl (73-1 -> 74-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded qt5-base (5.15.5+kde+r174-1 -> 5.15.5+kde+r182-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded js91 (91.12.0-1 -> 91.13.0-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded inetutils (2.2-1 -> 2.3-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded ibus (1.5.26-2 -> 1.5.27-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded libibus (1.5.26-2 -> 1.5.27-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded hunspell (1.7.0-4 -> 1.7.1-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded gvim (9.0.0135-1 -> 9.0.0354-1)
[2022-09-13T09:58:14+0200] [ALPM] upgraded vim-runtime (9.0.0135-1 -> 9.0.0354-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded gtksourceview-pkgbuild (4+1+g69f930f-2 -> 5-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded grilo-plugins (1:0.3.14-1 -> 1:0.3.15-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded webkit2gtk (2.36.6-1 -> 2.36.7-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded libwpe (1.12.2-1 -> 1.12.3-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded imagemagick (7.1.0.45-1 -> 7.1.0.47-2)
[2022-09-13T09:58:13+0200] [ALPM] upgraded neon (0.32.2-1 -> 0.32.3-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded libopenmpt (0.6.4-1 -> 0.6.5-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded libltc (1.3.1-3 -> 1.3.2-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded libdmapsharing (2.9.41-1 -> 2.9.41-2)
[2022-09-13T09:58:13+0200] [ALPM] upgraded grilo (0.3.14-1 -> 0.3.15-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded gnome-bluetooth-3.0 (42.2-1 -> 42.4-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded gnome-appfolders-manager (0.4.5-2 -> 0.4.6-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-setuptools (1:61.3.1-1 -> 1:62.3.4-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-validate-pyproject (0.9-1 -> 0.10.1-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-trove-classifiers (2022.8.7-1 -> 2022.8.31-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-ordered-set (4.0.2-6 -> 4.1.0-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-nspektr (0.4.0-1 -> 0.4.0-2)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-jaraco.text (3.8.1-1 -> 3.9.1-1)
[2022-09-13T09:58:13+0200] [ALPM] installed python-inflect (6.0.0-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-pydantic (1.9.2-1 -> 1.10.2-1)
[2022-09-13T09:58:13+0200] [ALPM] installed python-autocommand (2.2.1-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-jaraco.context (4.1.1-2 -> 4.1.2-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded python-appdirs (1.4.4-6 -> 1.4.4-7)
[2022-09-13T09:58:13+0200] [ALPM] upgraded gmime3 (3.2.12-1 -> 3.2.13-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded gmic (3.1.5-1 -> 3.1.6-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded openmpi (4.1.4-1 -> 4.1.4-2)
[2022-09-13T09:58:13+0200] [ALPM] upgraded openpmix (4.1.2-1 -> 4.2.0-1)
[2022-09-13T09:58:13+0200] [ALPM] upgraded opencv (4.6.0-3 -> 4.6.0-4)
[2022-09-13T09:58:13+0200] [ALPM] upgraded libheif (1.12.0-3 -> 1.13.0-2)
[2022-09-13T09:58:13+0200] [ALPM] upgraded graphicsmagick (1.3.38-3 -> 1.3.38-4)
[2022-09-13T09:58:12+0200] [ALPM] upgraded libtool (2.4.7-3 -> 2.4.7-5)
[2022-09-13T09:58:12+0200] [ALPM] upgraded git (2.37.2-1 -> 2.37.3-1)
[2022-09-13T09:58:12+0200] [ALPM] upgraded gcc (12.1.1-4 -> 12.2.0-1)
[2022-09-13T09:58:12+0200] [ALPM] upgraded fwupd (1.8.3-1 -> 1.8.4-1)
[2022-09-13T09:58:12+0200] [ALPM] upgraded protobuf (21.4-1 -> 21.5-1)
[2022-09-13T09:58:12+0200] [ALPM] upgraded flatpak (1:1.12.7-1 -> 1:1.14.0-1)
[2022-09-13T09:58:12+0200] [ALPM] upgraded ldns (1.8.1-1 -> 1.8.3-1)
[2022-09-13T09:58:11+0200] [ALPM] upgraded libadwaita (1:1.1.4-1 -> 1:1.1.5-1)
[2022-09-13T09:58:11+0200] [ALPM] upgraded gtk4 (1:4.6.6-1 -> 1:4.6.7-1)
[2022-09-13T09:58:11+0200] [ALPM] upgraded pipewire (1:0.3.56-1 -> 1:0.3.57-1)
[2022-09-13T09:58:11+0200] [ALPM] installed appstream (0.15.5-1)
[2022-09-13T09:58:11+0200] [ALPM] upgraded ostree (2022.5-2 -> 2022.5-4)
[2022-09-13T09:58:11+0200] [ALPM] upgraded firefox (103.0.2-1 -> 104.0.2-1)
[2022-09-13T09:58:11+0200] [ALPM] upgraded exa (0.10.1-5 -> 0.10.1-6)
[2022-09-13T09:58:11+0200] [ALPM] upgraded electron19 (19.0.10-1 -> 19.0.13-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded libxslt (1.1.35-1 -> 1.1.37-2)
[2022-09-13T09:58:10+0200] [ALPM] upgraded edk2-ovmf (202205-2 -> 202208-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded cython (0.29.32-1 -> 0.29.32-2)
[2022-09-13T09:58:10+0200] [ALPM] upgraded cups-pk-helper (0.2.6-5 -> 0.2.7-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded cups-filters (1.28.15-2 -> 1.28.16-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded poppler (22.08.0-1 -> 22.09.0-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded nss (3.81-1 -> 3.82-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded chromaprint (1.5.1-3 -> 1.5.1-4)
[2022-09-13T09:58:10+0200] [ALPM] upgraded ffmpeg (2:5.0.1-3 -> 2:5.1.1-3)
[2022-09-13T09:58:10+0200] [ALPM] upgraded lib32-glibc (2.36-2 -> 2.36-3)
[2022-09-13T09:58:10+0200] [ALPM] upgraded svt-av1 (1.1.0-1 -> 1.2.1-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded sdl2 (2.0.22-2 -> 2.24.0-1)
[2022-09-13T09:58:10+0200] [ALPM] installed ocl-icd (2.3.1-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded x264 (3:0.164.r3081.19856cc-2 -> 3:0.164.r3095.baee400-4)
[2022-09-13T09:58:10+0200] [ALPM] upgraded libva (2.15.0-1 -> 2.15.0-6)
[2022-09-13T09:58:10+0200] [ALPM] upgraded libssh (0.9.6-1 -> 0.10.3-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded rav1e (0.4.1-2 -> 0.5.1-2)
[2022-09-13T09:58:10+0200] [ALPM] upgraded btrfs-progs (5.18.1-1 -> 5.19-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded bolt (0.9.2-1 -> 0.9.3-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded bmenu (0.18-1 -> 0.20-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded mhwd-nvidia (515.65.01-2 -> 515.65.01-3)
[2022-09-13T09:58:10+0200] [ALPM] upgraded mesa (22.1.6-1 -> 22.1.7-1)
[2022-09-13T09:58:10+0200] [ALPM] upgraded nvidia-utils (515.65.01-2 -> 515.65.01-3)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libxfont2 (2.0.5-1 -> 2.0.6-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libfontenc (1.1.4-3 -> 1.1.6-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libsoup3 (3.0.7-1 -> 3.0.8-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded xkeyboard-config (2.36-2.1 -> 2.36-3)
[2022-09-13T09:58:09+0200] [ALPM] upgraded gtk-update-icon-cache (1:4.6.6-1 -> 1:4.6.7-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded librsvg (2:2.54.4-1 -> 2:2.54.5-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libxft (2.3.4-1 -> 2.3.5-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libtiff (4.4.0-3 -> 4.4.0-4)
[2022-09-13T09:58:09+0200] [ALPM] upgraded shared-mime-info (2.0+144+g13695c7-1 -> 2.0+155+gf4e7cbc-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libjpeg-turbo (2.1.3-2 -> 2.1.4-2)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libxau (1.0.9-4 -> 1.0.10-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded egl-wayland (2:1.1.10-1 -> 2:1.1.11-2)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libdrm (2.4.112-1 -> 2.4.113-2)
[2022-09-13T09:58:09+0200] [ALPM] upgraded libpciaccess (0.16-3 -> 0.16-4)
[2022-09-13T09:58:09+0200] [ALPM] upgraded python-urllib3 (1.26.11-1 -> 1.26.12-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded file (5.42-1 -> 5.42-2)
[2022-09-13T09:58:09+0200] [ALPM] upgraded gnupg (2.2.36-1 -> 2.2.39-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded sqlite (3.39.2-2 -> 3.39.3-1)
[2022-09-13T09:58:09+0200] [ALPM] upgraded gnutls (3.7.7-1 -> 3.7.7-3)
[2022-09-13T09:58:09+0200] [ALPM] upgraded lshw (B.02.19.2-4 -> B.02.19.2-5)
[2022-09-13T09:58:08+0200] [ALPM] upgraded fzf (0.32.1-1 -> 0.33.0-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded bluez-libs (5.65-2 -> 5.65-3)
[2022-09-13T09:58:08+0200] [ALPM] upgraded bluez (5.65-2 -> 5.65-3)
[2022-09-13T09:58:08+0200] [ALPM] upgraded libxml2 (2.9.14-1 -> 2.10.2-2)
[2022-09-13T09:58:08+0200] [ALPM] upgraded glib2 (2.72.3-1 -> 2.72.3-3)
[2022-09-13T09:58:08+0200] [ALPM] upgraded binutils (2.39-2 -> 2.39-3)
[2022-09-13T09:58:08+0200] [ALPM] upgraded curl (7.84.0-2 -> 7.85.0-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded ca-certificates-mozilla (3.81-1 -> 3.82-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded libtasn1 (4.18.0-1 -> 4.19.0-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded lz4 (1:1.9.3-2 -> 1:1.9.4-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded libnghttp2 (1.48.0-1 -> 1.49.0-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded bat (0.21.0-2 -> 0.21.0-3)
[2022-09-13T09:58:08+0200] [ALPM] upgraded libgit2 (1:1.4.4-1 -> 1:1.5.0-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded pcre (8.45-1 -> 8.45-2)
[2022-09-13T09:58:08+0200] [ALPM] upgraded archlinux-appstream-data (20220727-1 -> 20220830-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded apparmor (3.0.7-1 -> 3.1.1-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded python (3.10.5-2 -> 3.10.6-1)
[2022-09-13T09:58:08+0200] [ALPM] upgraded gcc-libs (12.1.1-4 -> 12.2.0-1)
[2022-09-13T09:58:06+0200] [ALPM] upgraded glibc (2.36-2 -> 2.36-3)
[2022-09-13T09:58:06+0200] [ALPM] upgraded iana-etc (20220603-1 -> 20220715-1)
[2022-09-13T09:58:06+0200] [ALPM] upgraded tzdata (2022b-1 -> 2022c-1)
[2022-09-13T09:58:06+0200] [ALPM] upgraded alsa-card-profiles (1:0.3.56-1 -> 1:0.3.57-1)
[2022-09-13T09:58:06+0200] [ALPM] upgraded abseil-cpp (20220623.0-1 -> 20220623.1-1)
[2022-09-13T09:54:40+0200] [ALPM] upgraded archlinux-keyring (20220727-1 -> 20220831-1)

I would comment all those in etc/environment
Here is how i have it on my other install:

#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#

QT_AUTO_SCREEN_SCALE_FACTOR=1

# Available options: gnome, kde, qt5ct, xcb
#QT_QPA_PLATFORMTHEME="qt5ct"
#QT_QPA_PLATFORMTHEME="gnome"

#QT_STYLE_OVERRIDE="kvantum"

# Force to use Xwayland backend
#QT_QPA_PLATFORM=xcb
#QT_QPA_PLATFORM=wayland

#Not tested: this should disable window decorations
# QT_WAYLAND_DISABLE_WINDOWDECORATION=1

EDITOR=/usr/bin/nano

The one you’re showing is the same as my original /etc/environment so it doesn’t work.

Check this if it applies to you:

If it does:

echo XDG_CURRENT_DESKTOP=KDE | sudo tee -a /etc/environment 

Just checked. This line doesn’t resolve the problem.

echo XDG_CURRENT_DESKTOP=KDE | sudo tee -a /etc/environment