Nvidia-settings has almost no options - raytracing disabled too

Writing from my mobile. Installed both software and did a reboot. Now the screen is black and that’s it. Nothing happens anymore (does not boot).

that should not happen, did you change any settings or just simply installed ? please go to a TTY-console (STRG-ALT-F5) and check if you can login. then we have to fix it

don’t hesitate, if it’s black change with STRG_ALT_F5

he need to edit the sddm.conf since he is on kde
he needs to edit the file /etc/sddm.conf and simply put a # before the line starting with DisplayCommand and the one starting with DisplayStopCommand
to look like this:

and wouldnt it be better since he is on laptop to use the prime hybrid drivers, because of battery?

Thank you both.
I was able to login via TTY and used nano to modify the file sddm.conf.
I also removed the Nvidia driver via mhwd and reinstalled on the shell via mhwd the hybrid driver I initially had. Did a reboot and everything stays dark. Strange.

I just did install Optimus-manager and the qt version and did a reboot nothing else.

so remove optimus from tty:
pamac remove optimus-manager optimus-manager-qt
systemctl reboot

please log to console and post the output

systemctl status optimus-manager

you can’t access GSYNC with prime

i dont know about that, but since he installed the video drivers after he installed optimus, he needs to remove it …
and if he switches to nvidia he should have available new options in the nvidia settings, but dont know about the gsync…

he already explained it. that’s the reason why to run optimus in real nvidia-mode to access g-sync

yes thats what i mean, he switches in optimus to nvidia so that he can access the settings

So I reverted everything back. The two settings in sddm.conf are commented out. The video-Nvidia is installed again and Optimus-manager.
Screen again dark.

Did the command but I cannot handwrite this stuff via mobile it’s outputting. It’s all infos, no errors or warnings and that Optimus manager commands demon has started (this stood out so mentioning it).

Edit: when I run inxi -GC it tells me that Display loaded: modesetting failed: nvidia

okay so the optimus-daemon is active. please boot to the dark-screen, change to a console as before and login.
from there edit /etc/default/grub with sudo rights and edit the following:


you add the following to the existing entries that are there


store the file and run

sudo update grub
sudo mkinitcpio -P

after do a restart

Is there an alternative to the update command as my system says not found?

my mistake

sudo update-grub
sudo mkinitcpio -P

missed the minus

Thank you so much. It worked. Screen is working, boot to Desktop and most importantly: Optimus Manager ran and selected Nvidia card. And finally - the nvidia-settings looks as I’m used to it with the X Server options.
Super cool.

Unfortunately though: No G-SYNC option and Raytraycing still doesn’t work as the games do not recognize the graphics card!? Very strange.

just to check this, please redo

glxinfo | egrep -i server

is it nvidia now ?

Yep, vendor string reads: NVIDIA Corporation.
I find contradicting information in the internet. One side says that Raytracing is not possible in the NVidia linux drivers yet but only AMD, others say, Raytracing is. Don’t know.
I don’t care too much about that feature though. Most important would be getting G-SYNC to work.

okay, i would recommend that you take your time for a good backup-solution first. i think it wasn’t a good idea to jump into waters without a life-west. if you have one that works for you make firm how to backup and restore a system that you can fiddle with the system and if it’s broken you’ll have your live-insurance.
i already linked some explanations for g-sync but you have to fiddle a little bit and that’s always better with a backup. you could go on with this g-sync later next days if you’re backup works and open a new thread to it ? i would do so.

Will do Olli, learned a lot in this thread and will now systematically understand what I actually did with your and brahma’s help. Lots of reading ahead but it’s part of the journey.

Many thanks for your patience with me newbie, I marked the answer with the grub update as the solution. I will sort the G-Sync out somehow!

Best wishes and have a nice evening,

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.