Nvidia-settings has almost no options - raytracing disabled too

Dear Community,

I recently made the switch to Manjaro Linux, so considering myself an absolute noob but I simply had enough of Windows 11 and thanks to GamingOnLinux on YouTube found out that thanks to Proton I can game here too. So here I am.

Installing and maintaining Manjaro on my Desktop was no problem at all. However I encountered issues on my gaming laptop which is a Lenovo Legion 5 with an RTX 3070 graphics card.

The problem was, that the nvidia-settings had only sparse options available compared to my desktop. Basically, I cannot change anything. I wanted to enable GSYNC (which this monitor has and is available in the Windows 11 basic installation also on this laptop) but there is no option. It looks simply empty.
So before posting here, I tried to resolve the problem myself as I consider this a great learning experience to get into touch with Linux.

Screenshot of my sparse nvidia-settings attached (Edit: was not possible to upload).

Step 1: nvidia-intel-hybrid-prime driver
This was pre-installed by Manjaro and I assumed that this driver was the issue as (from what I learned) this prime-thing utilizes the internal graphic card when I am on the Desktop for example and then switches to the NVidia once demanding process comes.

Step 2: Removed the hybrid driver via the GUI in Manjaor and installed video-nvidia
Big mistake - my system was stuck in boot and nothing happened anymore. So I did my research how I can rescue my system via a LiveUSB stick and chroot.

Step 3: Removed the prime driver and force-reinstalled the video-nvidia driver
Chroot worked super and I was able with the Manjaro Wiki to list installed drivers, uninstalled them and force re-installed the video-nvidia. I did a reboot and voila - my system booted to the Desktop again with the video-nvidia driver. That felt really good.

Step 4: Checked nvidia-settings again as normal user and root
To my suprise - I had the same sparse options again :-|. Nothing had changed at all, this was quite frustrating. So I did another research and came across this thread as the user had the same issue and by chance, I too had no xorg.conf file in my X11 folder. Unfortunately I am not allowed to link the thread here as the forum doesn’t allow me to post links and upload screenshots. So I cannot show the settings dialogue nor the forum thread (it was in this forums thread 99277).

Step 5: Created new xorg.conf file
Worked without issue per the link above. I did a reboot and once again (unlike the user in that thread) my settings still are the same without any possibility to change a thing.

Step 6: Testing a game
I therefore tried Resident Evil Village. The Laptop spooled up indicating all is fine. Graphics were wonderful and it was definitely not utilizing the internal graphics card. It showed 8GB RAM which was the RTX3070 card. However, the Raytracing options are all greyed-out - so I assume, my graphic card is not correctly recognized.

Now I’m here. No ideas what I can do, every thread I read I try with the same result.
Does anyone of you have at least an idea why the detailed options in nvidia-settings are missing (GSYNC activation) and why the games do not recognize the graphic card which would enable Raytracing. As said on my Desktop computer no problem at all.

Looking forward to any advice.
Thanks in advance,

have you checked this (maybe you have to run with sudo)

Via nvidia-settings

Gsync monitors should automatically be enabled. To enable Gsync compatible monitors do the following:

    In nvidia-settings go to the "X Server Display Configuration" page, then under the Advanced button is the option to "Allow G-SYNC on monitor not validated as G-SYNC Compatible". Then click apply.
    Now, under OpenGL settings, check "Allow Gsync/Gsync Compatible."

Tip: In the same menu, you can check the "show Gsync indicator" option to display an indicator that Gsync is working in the top right corner.


also some basic information of the described inxi-command would maybe helpful

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


Hi Olli,

my apologies, forgot to attach the inxi (at the bottom of this thread).

I wish I could post a screenshot but the forum shows a red warning, I have no ‘X Server Display Configuration Settings’ in the nvidia-settings.
All I have from top to bottom is:

  • System Information
  • GPU 0 - (NVIDIA GeForce RTX 3070 Laptop GPU)
    ** Thermal Settings
    ** PowerMizer
  • Application Profiles

inxi output:

  Kernel: 5.15.59-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=056970a1-c3ad-4a16-9ca7-a04cd5a5a1e3 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82JH v: Legion 5 15ITH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 15ITH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN
    serial: <superuser required> UEFI: LENOVO v: H1CN47WW date: 03/07/2022
  ID-1: BAT0 charge: 80.3 Wh (100.0%) condition: 80.3/80.0 Wh (100.3%)
    volts: 17.5 min: 15.4 model: Sunwoda L20D4PC1 type: Li-poly serial: <filter>
    status: full cycles: 21
  RAM: total: 31.14 GiB used: 2.63 GiB (8.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
    model-id: 0x8D (141) stepping: 1 microcode: 0x3E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 942 high: 1377 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 944 2: 1127 3: 777 4: 801
    5: 791 6: 958 7: 992 8: 1016 9: 1289 10: 1377 11: 999 12: 796 13: 794
    14: 792 15: 822 16: 812 bogomips: 73744
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Lenovo driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:24dd class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0998 built: 2020 res: 1920x1080
    hz: 165 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.4
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228b class-ID: 0403
  Sound Server-1: ALSA v: k5.15.59-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 58:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp88s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.39 TiB used: 88.71 GiB (6.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVL21T0HCLR-00BL2 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: AL1QGXA7 temp: 39.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Crucial model: CT500P5SSD8
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P4CR324 temp: 30.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 311.56 GiB size: 305.6 GiB (98.09%) used: 53.69 GiB
    (17.6%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: 056970a1-c3ad-4a16-9ca7-a04cd5a5a1e3
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 72.3 MiB
    (28.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: SYSTEM_DRV
    uuid: 247D-7C22
  ID-3: /home/<filter>/pCloudDrive raw-size: N/A size: 500 GiB used: 34.95
    GiB (7.0%) fs: fuse source: ERR-102
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 641.06 GiB fs: ntfs label: Haupt
    uuid: 70C87E4CC87E1098
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 1000 MiB fs: ntfs
    label: WINRE_DRV uuid: F82C7EE62C7E9EF6
  ID-4: /dev/nvme1n1p1 maj-min: 259:7 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-5: /dev/nvme1n1p2 maj-min: 259:8 size: 465.75 GiB fs: ntfs label: Games
    uuid: C65829A5582994E9
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-4:2 info: SINOWEALTH Game Mouse type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 480mA chip-ID: 258a:1007 class-ID: 0301
  Device-2: 3-9:3 info: Integrated Express ITE Device(8910) type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 048d:c101 class-ID: 0301
  Device-3: 3-14:4 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 376 Uptime: 58m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: 1392 pacman: 1385 lib: 441 flatpak: 7 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.20```

can you run

sudo nvidia-settings 

and check the advanced-option (bottom right corner)

Hi Olli,

there is no such button as I don’t have these ‘X Server Display Configuration’ settings as you have on your screenshots. I only have the 3 main options listed in the thread before.

please post the output of

glxinfo | egrep -i server

still in intel-mode ?

~> glxinfo | egrep -i server                                                                                                                                                                            
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

That is what the output shows…

and that’s what i was concerned, you are still in intel mode.
please post the output of



systemctl status optimus-manager

Oh that’s interesting. Somehow I feared that but as a youngling in linux the learning curve is quite steep, so thank you for the guidance and insight how to troubleshoot. The outputs are:

~>systemctl status optimus-manager
Unit optimus-manager.service could not be found.

okay, please open your graphical installation pamac and install these two packages


you have to enable the aur-packages before you can find them.

OK will do and provide the outcome. Would you suggest switching back to the initial primus-hybrid driver which I removed in favor of video-nvidia? Or doesn’t it matter?

no, use optimus, in this way nvidia is always the primary and active gpu

Writing from my mobile. Installed both software and did a reboot. Now the screen is black and that’s it. Nothing happens anymore (does not boot).

that should not happen, did you change any settings or just simply installed ? please go to a TTY-console (STRG-ALT-F5) and check if you can login. then we have to fix it

don’t hesitate, if it’s black change with STRG_ALT_F5

he need to edit the sddm.conf since he is on kde
he needs to edit the file /etc/sddm.conf and simply put a # before the line starting with DisplayCommand and the one starting with DisplayStopCommand
to look like this:

and wouldnt it be better since he is on laptop to use the prime hybrid drivers, because of battery?

Thank you both.
I was able to login via TTY and used nano to modify the file sddm.conf.
I also removed the Nvidia driver via mhwd and reinstalled on the shell via mhwd the hybrid driver I initially had. Did a reboot and everything stays dark. Strange.

I just did install Optimus-manager and the qt version and did a reboot nothing else.

so remove optimus from tty:
pamac remove optimus-manager optimus-manager-qt
systemctl reboot

please log to console and post the output

systemctl status optimus-manager

you can’t access GSYNC with prime

i dont know about that, but since he installed the video drivers after he installed optimus, he needs to remove it …
and if he switches to nvidia he should have available new options in the nvidia settings, but dont know about the gsync…