Not restoring after hibernating

Hi from Manjaro KDE,

I installed Manjaro KDE having a swap partition of enough memory - 16GB. For me Hibernate is available by default. But the problem is, when I turn on my laptop, it boots as if I had shut it down, without restoring where I left off. After searching in internet I found posts describing errors, but for me no error is displayed. Please help me making it work.

Thanks.

Do you have a resume device in: /etc/default/grub, a resume hook in: /etc/mkinitcpio.conf ?

What is output of cat /proc/cmdline ?

I experienced that hibernation is really buggy on linux, but standby works in most cases. I disabled it. Anyway hibernation is more a Windows Thing.

If you want to troubleshoot the problem then provide some logs:

journalctl -b -1 is a good start.

If you prefer a gui use: sudo pacman -S manjaro-log-helper :wink:

I didn’t find anything saying RESUME

No. Only these hooks are there:
HOOKS="base udev autodetect modconf block keyboard keymap filesystems"

BOOT_IMAGE=/vmlinuz-5.8-x86_64 root=UUID=91bc5c35-cc76-48ab-a458-0ba12de4df5a rw quiet apparmor=1 security=apparmor udev.log_priority=3

Make sure you read this thoroughly and apply the changes needed. You need to set the resume “location” in /etc/default/grub and set the resume hook in /etc/mkinitcpio.conf. Then rebuild the kernel image and update grub.

@megavolt This isn’t the first time I see users reporting that hibernation is a Windows thing and doesn’t work well on Linux. Well, I use it every day on several computers and it works perfectly for many years. Hibernation is extremely useful because you can just suspend your work without worrying with power losses. When your work depends on many files and/or applications open, hibernation allows you to keep the flow for weeks without rebooting.

I even read, recently, someone saying hibernation is only useful on laptops. Well, guess where power losses make the most damage!

I’m not saying everyone should hibernate. It just depends on you workflow and preferences. It is just wrong that hibernation doesn’t work on Linux and that it isn’t useful.

3 Likes

@mbb Honestly i never made it working correctly on any device. Every time i get a kernel panic, black screen, or the computer just don’t give beep. All data were lost and its just frustrated me. That is my experience and it became a habit to disable it on the first go, because i hate such behavior.

I am happy that it works for you :heart:

2 Likes

It needs to be tested. On some machines some divers or hardware components can give problems, but these can usually be worked around. I have an old 32 bit laptop running archlinux32 where I have hibernation disabled, but that’s because I really don’t want to spend time understanding what’s wrong.

Another culprit might be the kernel combined with the hardware. From what I’ve been seeing, newer kernels with newer hardware usually give more problems. Maybe this is why my experience is so different. I use neither.

Thanks. I finally did it. Here is how:
(Replace “[UUID_of_the_swap_partition]” with the actual UUID)

  1. In /etc/fstab added:
    UUID=[UUID_of_the_swap_partition] none swap defaults 0 0
  2. In /etc/default/grub added:
    resume=UUID=[UUID_of_the_swap_partition] to GRUB_CMDLINE_LINUX
  3. In /etc/mkinitcpio.conf added:
    resume to HOOKS (after udev)
  4. sudo mkinitcpio -P && sudo update-grub

That’s all. Hibernated and it resumed! :+1:

4 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.