Not detecting audio hardware

System shows No output or input devices in kde audio applet ,bluetooth audio device working fine

System info

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.13.19-2-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × 11th Gen Intel® Core™ i5-1135G7 @ 2.40GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics

inxi -Aa


Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo driver: sof-audio-pci-intel-tgl
           alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes

systemctl status alsa-state

○ alsa-state.service - Manage Sound Card State (restore and store)
     Loaded: loaded (/usr/lib/systemd/system/alsa-state.service; static)
     Active: inactive (dead)

System data is showing 2 incompatible sound servers running

           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes

PipeWire cannot support audio unless PulseAudio is removed and replaced, but it can impede PulseAudio functions

To continue using PulseAudio, use this command to stop, disable and mask PipeWire service and socket

systemctl --user disable --now pipewire.socket pipewire.service && systemctl --user mask pipewire.socket

OR

Install metapackage manjaro-pipewire to remove and replace PulseAudio

pamac install manjaro-pipewire
2 Likes

it didn’t workout

At first i tried first command for disabling and masking pipewire and didn’t workout , after that i installed manjaro-pipewie and unmasked, enabled pipeware service using the commands .It also didn’t workout

systemctl --user unmask pipewire.socket && systemctl --user enable --now pipewire.socket pipewire.service

inxi -Aa

Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo driver: sof-audio-pci-intel-tgl
           alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.38 running: yes

Sorry for my english

If PulseAudio was fully replaced by PipeWire I would expect system data to show PulseAudio is no longer present, like this

Sound Server-3: PipeWire v: 0.3.38 running: yes

I suspect manjaro-pipewire has not installed all dependencies correctly to replace PulseAudio

Please post response to this command to show status of systemd services

systemctl status --user --full --no-pager pipewire.{socket,sevice} pulseaudio.{socket,sevice}

The incompatible sound servers was the only thing that appeared to be a problem from the data available

Both sound servers not working might also be due to audio devices not detected properly in ALSA

Please post more information about ALSA configuration

sudo alsa-info.sh --upload
1 Like

You need to download sof-firmware. And then reboot your computer.

2 Likes

I have a Lenovo laptop also. I had to download sof-firmware to get audio to work also.

1 Like

Thanks all ,I disabled & removed Pipewire and reinstalled & enabled pulsaudio using these commands and rebooted .Audio works fine now
systemctl --user disable --now pipewire.socket pipewire.service && systemctl --user mask pipewire.socket

sudo pacman -S manjaro-pulse pulseaudio pulseaudio-alsa pulseaudi
o-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-ctl sol-firmware

systemctl --user unmask pulseaudio

systemctl --user --now enable pulseaudio.service pulseaudio.socket

Data shows Sound Open Firmware driver sof-audio-pci-intel-tgl is already installed to support Intel SST device

Only the metapackage manjaro-pulse package needs to be installed to revert to PulseAudio

The metapackage has Dependencies – pulseaudio pulseaudio-alsa pulseaudio-bluetooth pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

And package manager should offer to install Optional Dependencies – paprefs pasystray pavucontrol pavucontrol-qt pulseaudio-ctl pulseaudio-equalizer

If the systemctl command was effective and system has been reverted to using PulseAudio, the sound servers should look like this:

           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: no

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.